Sound KO on openSuse 11.1 w/ intel ICH9 on hp 6830s

Hello!

I’m having trouble with the sound output on my laptop.

Laptop: HP Compaq 6830s
openSUSE version: 11.1
Desktop: KDE 4
Audio device: Intel Corp 82801I (ICH9 Family)
Audio codec: Analog Devices AD1984A

PROBLEM DESCRIPTION: the sound output only works on the headphones on a fresh install.
I managed to get the speakers working by adding “option snd-hda-intel-hda model=laptop” to my /etc/modprobe.d/sound. But at every reboot the problem comes back until i restart alsa.
The screensaver also messes up my alsa and i have to restart alsa when it triggers.

More info about my config:

>alsa-conf.sh
http://www.alsa-project.org/db/?f=063c91e2d723135cd193e55cfe630db83996f7e6

>rpm -qa | grep alsa
alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.12
alsa-1.0.18-8.7
alsa-plugins-pulse-1.0.18-6.12
alsa-oss-1.0.17-1.37

>rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse0-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libxine1-pulse-1.1.15-44.pm.2
pulseaudio-module-jack-0.9.12-9.6

>rpm -q libasound
libasound2-1.0.18-8.7

>uname -a
Linux linux-uiux 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

>cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=laptop

Does anyone have an idea of what to try next?
Thanks in advance

Next time you reboot, and your sound does not work, type:
su -c 'rcalsasound restart’and then start your mixer and test your sound.

If that works, then add to your /etc/init.d/boot.local file the following line at the end of that file:
rcalsasound restart

I note your PC has an AD1984A hardware audio codec. Note the ALSA-Configuration.txt file for 1.0.18a of alsa has the following options listed:

 	AD1884A / AD1883 / AD1984A / AD1984B
	  desktop	3-stack desktop (default)
	  laptop	laptop with HP jack sensing
	  mobile	mobile devices with HP jack sensing
	  thinkpad	Lenovo Thinkpad X300

I see you were partially successfully with “laptop” option. Instead of laptop, did you also try mobile in your /etc/modprobe.d/sound to see if it was better? or thinkpad? or desktop ? Restart your PC after each test

I just finished trying out the 3 other options, and it turns out that:

  • “thinkpad” and “desktop” don’t work at all
  • “mobile” works as uncompletely as “laptop”

However, i have some info to add to my bug description:

1 - when i start my laptop with the power supply plugged in, the sound output works allright, whereas if power supply is unplugged during bootup, sound output through speakers is KO.

2 - when my sound output through speaker is working, only 2 events can stop it: the monitor going to sleep, or me plugging/unplugging the power adaptor a couple of times

3 - when my sound output is KO, a simple “rcalsasound restart” makes it work again

If this problem is related to alsa, i guess switching to gnome or KDE 3 won’t have no effect?

What happens if you put the following line in your /etc/init.d/boot.local file (as the last line):
rcalsasound restart
and then restart your PC under different conditions.

It didn’t change the sound output behaviour, either when booting with the power adaptor plugged, or unplugged

The problem is the same with gnome, with an additionnal extra-low volume problem. Guess i’ll stick with KDE for now.

The current state of my sound configuration is acceptable, but i wish it was better.

  • When i boot whith the power adaptor plugged, the sound works through speakers until i disconnect the power adaptor

  • When i boot unplugged, sound through speakers is ko

  • When sound is ko, “rcalsasound restart” makes it work again

  • When i boot with power plugged, log in, then log out, unplug and log in again, the sound works long enough for KDE to play it’s log in sound, a
    nd then fails.

Do you now what piece of software handles power management? How to configure the OS behaviour when the power adaptor is unplugged?

Oldcpu, i see you suggested an alsa update to another user that has the same alsa version as me (here).

Since this seems not to be a casual 1 click update, do you think it’s woth trying in my situation?

For power management issues, IMHO you should start a new thread, ensure you mention power management in the title.

Typically I recommend an update to alsa, when I research the alsa site and note that there is an update specific to one’s PC’s hardware audio codec. I did not note that in the case of your PC.

Still, you could try an update, and if it makes things worse, you could roll back to the old alsa, using your installation CD/DVD. To update, open a gnome terminal or a kde konsole, type “su” (no quotes - enter root password when prompted) to obtain root permissions, and then send (copy and paste) the following six commands in sequence, one at a time to update your alsa:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia 
zypper install alsa alsa-utils alsa-tools alsa-plugins-pulse alsa-plugins alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

and then restart your PC and test you audio.

I tried to upgrade ALSA, but it had an awful result on my sound output :\

Fortunately, downgrading to Suse-OSS repos version went allright and everything is back to my beloved status-quo!

I’ll now open a new thread about power management. I’m only a very few steps away from making every built-in function of my laptop work allright, I’ll then fill in the HCL.

Thanks a lot oldcpu :smiley:

hi

You have to add folloeing line to /etc/modprobe.d/sound
options snd-hda-intel model=laptop

If you look at the first post, where user brassgeek included the script output:
http://www.alsa-project.org/db/?f=063c91e2d723135cd193e55cfe630db83996f7e6
you will see they already had added “model=laptop” and they were trying to improve further upon that.

Their efforts with an alsa update failed, and they went back to their original configuration, which I assumed matched that of the 1st post, where they already had “model=laptop”.

But thanks for the effort ! … Any and all help is appreciated.