Sound issues

Not sure if this belongs here, or in the hardware forum, so I’ll start here and let the mods move it if they see fit.

I developed a perplexing sound problem yesterday, and I’m hoping you guys can help me get it back to working correctly.

I’m running 11.4, and have HDMI out going from the computer to my TV. I’ve got audio out going from the TV to auxiliary 1 on a receiver. I also have a standard 3.5mm audio out going from the onboard mobo audio to auxiliary 2 on the receiver. For a while (basically since I installed 11.4), I’ve been using the 3.5mm audio output to auxiliary 2 on the receiver with no issues. I like this, because it lets me continue to listen to music while watching tv (sporting events where the announcers annoy me) or playing video games.

Monday night, everything was working fine, I stopped playing music, turned off the tv and the receiver (the computer is always on unless the power is out), and went to bed. When I got home from work yesterday and turned on the tv and receiver, I had no audio anymore. Plugged the 3.5mm cable from the computer into my phone, and heard music fine, so the problem isn’t the cable or the receiver.

After playing around with the computer for a while, here’s what I ended up with:
Yast shows two audio devices. When I first got home, card 0 was SBx00 Azalia (Intel HDA), and card 1 was ATI Technologies Inc. Playing a test tone on card 0 with the receiver on Auxiliary 2 gave me no output. Switching the ATI card to default and playing a test tone with the receiver still on Auxiliary 2 gave me no output.

Looking in the System Settings -> Multimedia listing, I see six audio options:

  1. HDA ATI HDMI, HDMI 0 (HDMI Audio Output)
  2. HDA ATI SB (ALC888 Analog)
  3. default
  4. hw:0,0 (mouseover displays ALC888 Analog)
  5. hw:0,1 (mouseover displays ALC888 Digital)
  6. hw:1,3 (mouseover displays HDMI 0)

This may not have been the original order they were in, I started screwing around with making different cards default in Yast prior to opening this menu. With the receiver still on auxiliary 2, I get test sounds out of none of these options. However, if I switch the receiver to auxiliary 1, then I do hear test sounds from the two HDMI options.

So now I do have audio working again, although it’s coming through HDMI and into auxiliary 1 on the receiver. I’d really like to get back to having audio through the 3.5mm cable and into auxiliary 2 on the receiver, but I’m thoroughly perplexed and out of ideas here.

Any advice would be greatly appreciated.


Assuming you have not removed nor disable pulse audio, then I find installing the application pulse audio volume control (pavucontrol) and using it to tune your audio is the easiest way to approach multiple devices. I wrote in my blog some of my pavucontrol experience documented here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums .

I enabled pulse audio and installed this package, and continue to have the same issue.

Any other thoughts?

Following oldcpu’s advice about ‘pavucontrol’, did you launch it to configure the preferred output device?

Does this mean you were not using pulse audio before when the HDMI was working ?

I did, and I have the same issue. As long as I tell it to use the HDMI audio, I have sound. When I switch it to analog, I no longer have sound.

The HDMI works both with and without pulse audio. I’m not sure if pulse audio was turned on when I was using the 3.5mm output before or not, but the 3.5mm output still doesn’t work regardless of whether pulse audio is enabled or disabled.

Recent openSUSE versions are mostly only tested WITH pulse audio enabled. Hence if you were using HDMI without pulse audio, then I don’t think I can help.

I’ll assume you were able to get it work with pulse audio and that you have changed nothing wrt pulse audio. In that case, can you please provide some more sound configuration information. Please provide the output of running the sound diagnostic script with your computer connected to the internet by sending this script command from a terminal :


and select the SHARE/UPLOAD option. This will check your hardware/software audio configuration and upload it to a pastebin site, and it will give you the URL where that output is located. Please post that URL here so we can check your HDMI configuration and see if it yields any useful information.

Also, can you run ‘pavucontrol’ and provide us a screen dump of the ‘configuration tab’ and also tell us what HDMI options pavucontrol is providing in that configuration tab selection (showing us the option you selected).

My goal is to not be using the HDMI output at all, I want to get the 3.5mm output working again. Whether pulse audio was enabled before the 3.5mm output stopped working, I don’t remember, I know that was one of the things I switched trying to get it working again, but I don’t remember what the initial state of it was.

Here’s a screenshot of the current settings in pavucontrol, which does have audio working through the HDMI output. However, I want it running back through the 3.5mm output, and changing the settings in here don’t accomplish that either.

Script results are here

I note from the diagnotic script an ALC888 hardare audio codec with your Microstar on openSUSE-11.4 with a 32-bit kernel.

The diagnostic script provides this for your output audio devices:

!!Aplay/Arecord output


**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

ie hw:0,0 (analog), hw:0,1 (digital), and hw:1,3 (HDMI). Those can be important if we decide to use command line speaker tests, … but for now, lets not do that.

When you note you want to use the 3.5mm audio output to auxiliary 2 on the receiver, I have no idea as to what that means wrt your PC hardware. Is the 3.5 mm output a line output ?

I note you have the line muted in some cases in your mixer (and have rear mic selected for input to the mixer):

**Simple mixer control 'Line',0**
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 **[0%]** -34.50dB] [on]
  Front Right: Playback 0 **[0%]** -34.50dB] [on]
**Simple mixer control 'Input Source',1**
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
**Simple mixer control 'Rear Mic',0**
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 **[0%]** -34.50dB] [on]
  Front Right: Playback 0 **[0%]** -34.50dB] [on]

In pavucontrol under the configuration tab, under ‘internal audio’ you have ‘analog stereo duplex’ selected. What other choices are there under ‘internal audio’.

When playing a media file with an application, did you check in pavucontrol ‘output devices’ (with show all output devices selected) did NOT have your ‘internal audio’ selected device muted ? Also, when playing the media file with an application, go to the playback tab, ensure ‘all streams’ are selected in the SHOW, and check under playback that you have the internal audio device selected and not the HDMI device selected ?

Yeah, the 3.5mm should be the standard line out, so I would expect that to be hw0,0

When playing a media file with an application, did you check in pavucontrol ‘output devices’ (with show all output devices selected) did NOT have your ‘internal audio’ selected device muted ? Also, when playing the media file with an application, go to the playback tab, ensure ‘all streams’ are selected in the SHOW, and check under playback that you have the internal audio device selected and not the HDMI device selected ?[/QUOTE]
Here’s the remaining options in that menu:

I’ve tried a number of the different options there, and selection different ones has no effect when I’m trying to use the internal audio.

While playing music, if I change the output device from the HDMI to the internal audio, the sound stops working, but I can clearly see that it isn’t muted. Also, if I go to the output devices tab and scroll down to the internal audio display, the bar at the bottom that looks like a visual display of sound is fluctuating, same as the one for the HDMI does when that output device is selected.

I don’t know why the line out would be muted, everything I see in pavucontrol shows it at 100% for both right and left.


When you change the pavucontrol configuration, you have to restart it else sometimes it will not work.
Try turning off the hdmi at the top in the pavucontrol configuration.
Open the pavucontrol playback while playing audio and down the playback gui select all streams and see all the streams and try selecting what will work.
Lastly when you got it going open the output devices, choose all output devices down the gui and adjust the volume.

Try to install also the xfce-mixer it is a nice mixer that can help.

Thats good news. Do not forget then in ‘pavucontrol’ to go to ‘playback’, and ensure all streams are selected under ‘SHOW’, and ensure in playback that you have the appropriate device selected (because you can control devices there and the HDMI may be selected by mistake there for the application you are using).

Unfortunately, pavucontrol does not show everything, so it would be useful to ensure there is no mixer setting blocking your analog sound setting.

Also - a silly point, but it needs to be mentioned - Ensure your cabling is correct ! I’ve had my cabling changed by my wife and also (more often) by the maid on occasion, when cleaning and they mistakenly put the cables back in the wrong place.

I’ve tried all of this, unfortunately no amount of selecting the output device I want leads to sound coming from that device.

The only stream I’ve got going is Amarok, though I’ve been making sure to select the internal audio device in there as well.

Alright, maybe we’re onto something here. Now that I’ve installed pavucontorl, kmix won’t launch. When I click it in the menu or type it into the run command, I get the bouncing icon near the pointer for a few seconds like it’s trying to run, and a window shows up briefly on the taskbar, then it disappears.

That was the first thing I checked after making sure the computer wasn’t muted. I can pull the cable out of the back of the computer and plug it into my phone and I have audio no problem, and when I plugged it back in I did ensure I plugged it back into the correct jack on the motherboard.

I run both kmix with pavucontrol with no problem. So IMHO there is a configuration problem there … When you type ‘kmix’ in a terminal, what error does it give ?

Also, there are other mixers, such as amixer (requires complex syntax), alsamixer, and xfce-mixer.

Here’s the error I receive in the terminal:

naskie18@linux-3unv:~> kmix
kmix(20971) sink_input_cb: Ignoring sink-input due to it being designated as an event and thus handled by the Event slider 
unnamed app(20970): Communication problem with  "kmix" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 


I don’t have any other mixers running (at least not that I can see in the system monitor).

I’ve never seen that error before. A brief search suggests it could be associated with external devices also connected to one’s PC, such as Bluetooth or a USB device.

And that is how it should be.

So what we attempted to say, and I guess we did not say it very well, is try to run one of the other mixers.

Both amixer and alsamixer come with the rpm alsa-utils, which should be installed on your PC. If not, then please install it.

If you type from a terminal:

man amixer

you will be given instructions on how to use amixer. Its not easy due to syntax complexities.

If you type from a terminal:

man alsamixer

you will be given instructions on alsamixer. One can run alsamixer by typing


xfce-mixer you may need to install as it likely is not yet installed.

Ah, I gotcha now. I’ll give one (or more) of the others a try next week, as I’m about to be out of town for the weekend.

I’ll post back with the results, thanks for all the help so far.