Sound issues..

Been searching for anyone who has run into the sound issue I have, but have been unsuccessful.

Dell C521, Dual Athlon, Suse 11.1 64bit, KDE 4.2.3

Audio was working fine until yesterday. Card shows as HDA Nvidia (STAC92xx Analog), driver is snd-hda-intel.

I have run speaker-test (get nothing), alsaconf (doesn’t help), and removed PulseAudio (no effect).

What’s odd is if I go into YAST/Hardware/Sound, I can see the card (shows as MCP 51 High Definition Audio). Test sound does not work.

However, if I delete it (then shows as Not Configured), then edit it, and choose Normal Setup, clicking the Test button yields a wonderful bit of music. Once its saved, though the sound goes away. Sometimes I can get static from the speakers, but eventually nothing.

Any ideas? I realize it could be hardware related, but the fact that it makes sound in YAST (though not again until I delete/add it), makes me think a config issue.

Thx in advance

Bump bump bump

What happens if you add your regular user to group audio per step#6:
SDB:AudioTroubleshooting - openSUSE
Note you should restart after trying that.

Assuming that does not work, … can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

I’m currently on vacation, so my replies may be a few days apart.

oldcpu’s recommendation is certainly the best, allowing you to figure out the root of your problems. still, i’ve had a similar problem recently (different hardware) and could solve it by changing priority of frontend devices and audio backend in personal settings -> computer administration -> multimedia.

depending on your configuration you’ll probably have xine and gstreamer backends installed, and a couple of frontend devices (there are different tabs in the admin screen for front- and backend). in my case xine backend works more reliably than gstreamer, and switching between different detected audio devices (click “apply” after changing) brought my sound back to life.

Thanks…i uploaded the data to:

The script did not ask to update (ran as root).

Output of rpm -qa|grep alsa


Output of prm -qa|grep pulse


Output of rpm -q libasound2


uname -a:

Linux linux-9l57 #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux


options snd slots=snd-hda-intel

wRyD.ELN_dPkuGaC:MCP51 High Definition Audio

alias snd-card-0 snd-hda-intel

Thanks again for your help, and enjoy your vacation!

Thanks for the input…i have done that a bunch of times. If I have the “Configure Desktop” app up when I do the YAST trick, I can get the test sound once, then it dies.

I just tested adding myself to the “Audio” group per oldcpu’s suggestion, but that did not work either.

This whole thing is interesting…fairly new to this, and what better way to learn it than to have issues.

Thx again…

OK, I note a 64-bit openSUSE-11.1 with the latest kernel on a Dell Dimension C521 with a Stac9227 hardware audio codec.

I’m not that familiar with the stac9227. I did a search on the alsa website for possible updates and I noted this for the stac9227: Search results - AlsaProject

and for the stac92xx (generic): Search results - AlsaProject

I also noted your PCM/Master volume both at 100% and on, and 1-speaker on at 100%, and the other two muted. I don’t know what those two do.

Simple mixer control ‘Speaker’,0
Capabilities: pvolume pswitch
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘Speaker’,1
Capabilities: pvolume pswitch
Front Left: Playback 64 [100%] [0.00dB] [off]
Front Right: Playback 64 [100%] [0.00dB] [off]
Simple mixer control ‘Speaker’,3
Capabilities: pvolume pswitch
Front Left: Playback 64 [100%] [0.00dB] [off]
Front Right: Playback 64 [100%] [0.00dB] [off]
I don’t know enough about your hardware to know if muting those two speakers has any impact.

I note for the stac9227 it is possible to force various model options at boot, with a list of those options being here (only one at a time can be forced, and it must be done in a specific syntax in the /etc/modprobe.d/sound file):

	  ref		Reference board
	  3stack	D965 3stack
	  5stack	D965 5stack + SPDIF
	  dell-3stack	Dell Dimension E520
	  dell-bios	Fixes with Dell BIOS setup

But before messing around with that, I note you stated sound works, and then stops. Lets look into that.

When sound works, run the following in a terminal, and copy the output to a text file and save it.

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

then when sound is NOT working, do the same:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and copy the output to a text file and save it.

Compare the two outputs and determine what is the difference? Is there an application that has seized your sound device in the case where sound is not working that was not present when sound worked ? [reference: SDB:AudioTroubleshooting - openSUSE - determining which application is using the sound device ]

The remainder of the information you provided will be useful if later we determine it necessary to update your alsa version.

Thanks, I’ll run through that and let you know what I find out.

Much appreciated!

Update…I finally got around to messing with some stuff. The lsof commands were all over the place since it would work one second, and not the next. However, the behavior seems so odd, that one of your recommendations made a difference.

The sound would work in YAST, then maybe once in the “Configure Desktop” applet. Second time in ConfigDesktop, you could hear a lot of static, and the music very faintly. Third time, nothing.

I went into YAST, and modified the card config, adding the “dell-bios” entry into the “model” field. Seemed a logical choice since the behavior was so weird. It seemed like the driver was losing communications with the card, or forgot how to deal with it. Bingo. That made things much better. Sound now works consistently from what I can tell. I’m not a big sound guy, but its nice to have it when you need it.

Still one issue where, on a restart, the sound is not there. Setting it back up in YAST, fixes it for the session.

Not completely solved, but much much better.

Thanks for the time and the tips!

The YaST front end in openSUSE-11.1 and earlier will write to the file /etc/modprobe.d/sound and do some other things (such as restarting alsa). Post here output of
cat /etc/modprobe.d/sound
so we can see what YaST did

Next time you restart, if sound is not there, instead of going to YaST, type:
**su -c ‘rcalsasound restart’ **enter root password when prompted for a password, and restart your mixer and test your sound.

If that works, we can set things up to have “rcalsasound restart” run at every boot.

Output of cat /ec/modprobe.d/sound:

options snd-hda-intel model=dell-bios
options snd slots=snd-hda-intel

wRyD.ELN_dPkuGaC:MCP51 High Definition Audio

alias snd-card-0 snd-hda-intel

Upon restart, no sound. Executed the su -c ‘rcalsasound restart’ command and Kmix, but no help. went back into YAST, re setup the card with the ‘dell-bios’ option and sound works.

Thx for the help again…almost there I think. I can live with re-configing the sound each boot (don’t do it often), but it would be nice to figure out why.

Thx again!

After this, before going to YaST, did you test with root permissions in a terminal? When testing, try each of the tests from step-1 in the audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE


Select Edit model

add ref

select ok

follow it though and reboot your sound.

Close Yast, restart kmix or what ever it is in Gnome.

open kmix or … un-mute and turn the volume up on everything, in my case I chose ‘right’.

Close mixer, make sure volume is at a reasonable level.

Reboot your puter. after you login, you should be hearing the startup file play.


China_Jobs, welcome to openSUSE forums.

I note you replied to a number of sound support threads, and in every case recommended the application of the model “ref”.

In fact, that model option might work for user mhibisht, as their PC has a stac9227. I note from the alsa-configuration.txt file for 1.0.16 of alsa the follow options might work with that option:

STAC9200, STAC9205/9254, STAC9220/9221, STAC9202/9250/9251, STAC9227/9228/9229/927x, STAC92HD71B*, STAC92HD73*

However the option may not work, and each option in the list for the stac9227 should be applied one at a time to see which one works best. I provided that list for the 9227

One needs to be very precise on the model options that are applied, and they must be selected from the alsa-configuration.txt or hd-audio-models.txt file that is documented by the alsa packagers.

We can use all the help we can get in the forums, so if you get the chance you could read the following files (comes with the documentation in every alsa tarball):

  • alsa-configuration.txt
  • hd-audio-models.txt
  • hd-audio.txt

and that should shed some light on this, and the various aspects associated with troubleshooting Linux sound.