Sound Issues

Hello,

I’m new to Linux and just installed Suse 11.1 on my desktop and I can’t seem to get the sound working properly. When I first turn the computer on, I can’t hear any sound and there is an icon on the lower right hand corner that looks like a speaker with a cross over it.

I have tried the suggestions from this post:

SDB:AudioTroubleshooting - openSUSE

One of the suggestions was to go to YAST, delete the sound card and add it back in, after doing that I am able to hear music from Amarok and from videos. I thought that would fix it so I turned off my computer and turned it back on to see if it did work, but I get no sound again. I went back into YAST, deleted and edited the sound card again and I have sound again.

Can someone please help me out, I don’t want to keep deleting and adding this sound card every time I turn on or restart my computer.

Thank you very much.

there is a bug in pulse audio in openSUSE-11.1 that your sound is constantly muted upon boot. Just go into your mixer and ensure PCM, Master, and Speaker volume are not muted. You have do to that each time you boot because of the bug.

Reference the remainder of you multimedia, have a read here:
openSUSE Forums - View Single Post - sound problems on Gateway M-6874h
to see if that helps a bit in understanding multimedia on openSUSE Linux.

Thank you very much for the quick reply. Since there’s nothing I can do at the moment, I’ll just delete it then reenable it. Thanks again for your help.

Why delete it? Did you check your mixer to see if it was muted like I had thought? If so, unmuting in the mixer should be quicker than going to YaST to delete and re-enable.

If unmuting in the mixer does not work, just type:
su -c ‘rcalsasound restart’
enter root password when prompted, and see if that works

I tried your suggestions and typing in the command worked. Doing that was much easier than deleting the card then reenabling it.

Thanks again for your help.

OK, what you could consider now is putting that command into your /etc/init.d/boot.local file, to run every time you boot.

ie add at the end of the /etc/init.d/boot.local file the line:
rcalsasound restart

Hey there.

I put the command at the end of my /etc/init.d/boot.local file like you suggested and restarted my computer to see if worked. I can hear the music that the system plays when Suse starts up, but when I go to Amarok and try to listen to music, I don’t hear anything.

Is there another command I can use so that I can hear the music from Amarok also?

Thank you again for your help.

I wonder if this is an amarok issue? Or whether you have the required multimedia codecs installed? Are you using the packman version?

What is the output of

rpm -qa |grep amarok

What repos do you have enabled?

zypper lr --details

If I do (with openSUSE 11.0):

zypper info amarok

I get

Information for package amarok:

Repository: Packman Repository
Name: amarok
Version: 1.4.10-100.pm.1
Arch: i586
Vendor: packman.links2linux.de
Installed: Yes
Status: up-to-date
Installed Size: 9.1 M
Summary: Media Player for KDE

Just some possible ideas…

Further to deano_ferrari’s excellent post and request for information, please note that Amarok-1.4.10 has a menu item Settings > configure Amarok > Engine where one can select the sound engine that Amarok uses. I suspect Amarok-2 has something similar.

One can typically choose the xine or the yauap engine. The xine engine as packaged by Novell/SuSE-GmbH is typically crippled for most proprietary audio codecs (such as mp3) and to play mp3 with xine (and hence play with Amarok with the xine engine) one needs to replace the Novell/SuSE-GmbH libxine1 with the Pacman packaged libxine1.

I do not use yauap engine, but I believe the same applies there, where one needs to replace an application for the yauap engine to handle proprietary codecs.

Thanks oldcpu. That info concerning the sound engine(s) is one of the things I was driving at. You explained it well. (Thats why I was wondering what repos might have been configured).

Try checking installed xine packages with

rpm -qa |grep xine

It should reveal the packman versions (something like):

amarok-xine-1.4.10-100.pm.1
phonon-backend-xine-4.3.1-28.21
libxine1-codecs-1.1.16.3-0.pm.3
libxine1-1.1.16.3-0.pm.3
xinetd-2.3.14-115.1

Yesterday after a security update from Yast, my sound stop to work. There is no sound on KDE when start, or when I play mp3’s, movies, videos, youtube.
I did try to run alsaconf, but nothing works to restore sound. ALso my Kmix show nothing is muted.
Anyone with similar problems.

Thanks.

That happens sometimes with kernel updates.

Typically, if it does, its not a big deal to fix. You could work your way through the audio troubleshooting guide here: SDB:AudioTroubleshooting - openSUSE

or if it is believed that the kernel update broke your sound, go direct here to obtain user-space alsa updates: Alsa-update - openSUSE

or

If the user-space alsa updates suggested above do not work, one can also try installing even more cutting edge (essentially daily (or momentary) snapshot packages from the upstream GIT trees). There is guidance here for that Alsa-update-snapshot - openSUSE

Note in both cases one MUST send 6 zypper commands. Not 3 commands. For some reason many users ignore with wiki advisory that one must send 6 commands and send only 3. So please send 6 that are consistent with your openSUSE version and your kernel version.

Also, please NEXT TIME start a NEW thread. Do NOT tag on to someone else’s thread for what could be a different problem.

Thank you guys for all the help you have been giving me. I’m not sure if the problems are related, but I just noticed that I can’t hear anything from Youtube also.

Here are the outputs from the commands you have asked for.

rpm -qa |grep amarok

amarok-1.4.10-26.2.1
amarok-libvisual-1.4.10-26.2.1
amarok-yauap-1.4.10-26.2.1

For the zypper lr --details command, the list was too big so instead of pasting the output I thought it would be better to list the repositories that I have enabled.
Emulators
Mozilla
OpenOffice STABLE
Packman
openSUSE 11.1-0
repo-debug
repo-non-oss
repo-oss
repo-source
repo-update

zypper info amarok

Repository: Packman
Name: amarok
Version: 1.4.10-100.pm.2
Arch: i586
Vendor: packman.links2linux.de
Installed: Yes
Status: out-of-date (version 1.4.10-26.2.1 installed)
Installed Size: 9.3 M
Summary: Media Player for KDE

rpm -qa |grep xine

xinetd-2.3.14-129.28
libxine1-gnome-vfs-1.1.15-23.3.3
libxine1-pulse-1.1.15-23.3.3
libxine1-1.1.15-23.4.1
amarok-xine-1.4.10-100.pm.2
xine-ui-0.99.5cvs-20090203.pm.0821

oldcpu, I have the GStreamer/Yauap engine selected for Amarok. Do I need to replace that?

Thanks again.

First, look what the output of those commands gives on my PC where xine and amarok both work:

oldcpu@hal1000:~> rpm -qa | grep amarok
amarok-libvisual-1.4.10-100.pm.2
amarok-packman-1.4.10-100.pm.2
amarok-xine-1.4.10-100.pm.2
amarok-yauap-1.4.10-100.pm.2
amarok-1.4.10-100.pm.2
oldcpu@hal1000:~> rpm -qa | grep xine
libxine1-pulse-1.1.16.3-0.pm.3
xinetd-2.3.14-129.35
libxine1-codecs-1.1.16.3-0.pm.3
xine-ui-0.99.5cvs-20090203.pm.0821
amarok-xine-1.4.10-100.pm.2
libxine1-1.1.16.3-0.pm.3
libxine1-gnome-vfs-1.1.16.3-0.pm.3

I believe it shows that I have replaced the crippled SuSE-GmbH versions of Amarok and xine with Packman packaged versions that are not crippled.

I recommend you update your software for multimedia. To do so, I recommend you setup your software package manager repositories with 4 and only 4 repositories. Those 4 are OSS, Non-OSS, Update and Packman. There is guidance how to do that here: Repositories/11.1 - openSUSE-Community Again ONLY those 4. OSS, Non-OSS, Update and Packman. No others. None. Just those 4. OK ? If you have others, disable them. There is a good chance OSS, Non-OSS, and Update are already setup and you only have to add Packman.

The reason is other repositories may conflict and cause problems, and only average to advanced users typically have the knowledge to detect the problems and then debug/fix them.

So, once those 4 are added, go to YaST > Software > Software Management, and change the ‘filter’ to “search” and search for replacement Packman packaged versions of amarok and xine (such as libxine1). Use what I have installed above as a guide.

Note you can tell Packman packaged versions by the “pm” in the version number.

Now if you wish to continue using the GStreamer/Yauap engine , you should also replace the Novell/SuSE-GmbH packaged versions of gstreamer with the Packman packaged version.

I agree. A quick look your xine packages show you don’t have the libxine1-codecs package (packman version is required) and the libxine1 package you currently have installed is the Novell/SuSE-GmbH version (as noted by oldcpu). Make sure you have set the Packman repo priority higher (=LOWER number). Thats why I asked for your ‘zypper lr --details’ output.

Hello there again.

I tried to install the same packages as the one oldcpu had, but after restarting my computer, I still don’t have sound on Amarok.

Here are the outputs from the commands.

rpm -qa | grep amarok

amarok-packman-1.4.10-100.pm.2
amarok-xine-1.4.10-100.pm.2
amarok-yauap-1.4.10-100.pm.2
amarok-1.4.10-100.pm.2
amarok-libvisual-1.4.10-100.pm.2

rpm -qa | grep xine

libxine1-1.1.16.3-0.pm.3
libxine1-pulse-1.1.16.3-0.pm.3
libxine1-codecs-1.1.16.3-0.pm.3
amarok-xine-1.4.10-100.pm.2
xinetd-2.3.14-129.28
phonon-backend-xine-4.1.3-4.2.9
libxine1-gnome-vfs-1.1.16.3-0.pm.3
xine-ui-0.99.5cvs-20090203.pm.0821

Is there something I’m missing? Thanks.

Did you change the selected sound engine in amarok to xine?

Also try to play the file with xine to confirm the xine engine is working ok.

If the file is called song.mp3 you can do that by navigating to the directory when the file “song.mp3” is located and type:
xine song.mp3

I have the engine set to yauap.

I tried your suggestion and I did not hear anything when I typed the command.