sound issues, opensuse 11.1, x86-64, kde 4.1

Hi,

I think sound (at least on my system) falls into the category of “it doesn’t just work yet” on linux…

I have a cheapo emachines system T6420, athlon 64, built-in system sound. At the end of this message is the first relevant-sounding item from yast -> hardware -> hardware info -> save to file (it’s a long file).

There are a collection of odd things happening:

  1. When I login to kde, I get a message (which promptly disappears) about “phonon: ALC??? device not working, switching to default.”

  2. When I move around in yast -> hardware -> sound, the ambient level of hiss from the speakers can increase or decrease. Less vaguely, the sound test under the “other” button never works.

  3. I can get sound from amarok playing flac files. But, the sound is very “tinny.” The higher I turn the volume, the more pronounced the “fuzz” is on high-frequency sound. It’s not a subtle effect, and I’m not some audio freak.

In opensuse 11.0 sound works well on my system, although I’ve primarily been using 11.1 in various beta forms for a while, so I really don’t know what if anything I did to configure things.

Any advice? Perhaps more to the point, are there things to change in opensuse to get closer to the “sound just works out of the box” limit?

Thanks,
Dave


3: udi = ‘/org/freedesktop/Hal/devices/pci_10de_26c_sound_card_0_oss_pcm_0_0’
info.subsystem = ‘sound’
info.callouts.add = { ‘hal-acl-tool --add-device’ }
info.product = ‘ALC880 Analog OSS PCM Device’
linux.device_file = ‘/dev/audio’
info.callouts.remove = { ‘hal-acl-tool --remove-device’ }
oss.device_file = ‘/dev/audio’
info.udi = ‘/org/freedesktop/Hal/devices/pci_10de_26c_sound_card_0_oss_pcm_0_0’
oss.originating_device = ‘/org/freedesktop/Hal/devices/pci_10de_26c_sound_card_0’
oss.card = 0 (0x0)
oss.card_id = ‘HDA NVidia’
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:10.1/sound/card0/audio’
info.category = ‘oss’
oss.device_id = ‘ALC880 Analog’
info.capabilities = { ‘oss’, ‘access_control’ }
info.parent = ‘/org/freedesktop/Hal/devices/pci_10de_26c_sound_card_0’
oss.type = ‘pcm’
oss.device = 0 (0x0)
linux.hotplug_type = 2 (0x2)
access_control.file = ‘/dev/audio’
linux.subsystem = ‘sound’
access_control.type = ‘sound’

Hi

I had a similar issue with opensuse 11.1 and, although it is a work around than a fix, I found removing pulseaudio using YAST worked a treat.

I have a different soundcard (Maudio 2496) but the sound was vastly improved.

I hope this helps and good luck!

Hi,

Eliminating pulse worked like a charm! Just deleted pulseaudio in yast, several others were removed as a result. Thanks.

Morte au pulse!

Hi,
Unchecking the Pulse Audio in YaST2 truly did the magic. Sound is now louder.
Thanks.