Sound issues kernel 5.14

Hi deano,

0.742350] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <>
0.790114] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
0.790115] software IO TLB: mapped [mem 0x000000005b363000-0x000000005f363000] (64MB)
0.820359] tpm tpm0: Firmware Bug]: TPM interrupt not working, polling instead
3.613853] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/tgl_dmc_ver2_08.bin (v2.8)
5.533750] ACPI: video: Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
6.719219] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
6.719356] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
6.728543] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-64.ucode failed with error -2
6.753272] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=1 (0x1b/0x0/0x0/0x0/0x0) type:speaker
6.753275] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
6.753276] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
6.753277] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
6.753278] snd_hda_codec_realtek hdaudioC0D0: dig-out=0x1e/0x0
6.753278] snd_hda_codec_realtek hdaudioC0D0: inputs:
6.753279] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18
6.753279] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12
6.756845] iwlwifi 0000:00:14.3: loaded firmware version 63.c04f3485.0 QuZ-a0-hr-b0-63.ucode op_mode iwlmvm
7.883908] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
7.906555] Bluetooth: hci0: Found device firmware: intel/ibt-19-0-4.sfi
9.526483] Bluetooth: hci0: Waiting for firmware download to complete
9.526884] Bluetooth: hci0: Firmware loaded in 1582325 usecs
9.547016] Bluetooth: hci0: Firmware revision 0.4 build 5 week 39 2021

No, that’s a different problem, and you should start your own thread to discuss it.

I think your PC has a Tiger Lake processor. hence sof-firmware, which you installed is necessary.

However IMHO it is mistake to apply the snd_hda_intel force-probe fix, and that could break your sound while that is in place. Also, the thread where you reference blacklisting ALC1220 appears to be for entirely different hardware than what you have … ?? Do I have that correct ? If so, you should not do that.

Randomly applying such fixes, while they are in place, could break your sound and invalidate any other fixes to audio that you may have attempted already, leading total confusion as to the issue (at least that is the case for me when I look at this thread).

Thanks for chiming in here Lee. Your comments make sense to me (especially the snd_hda_intel: probe_mask=1 option)…

Hello oldcpu … greetings from long ago :slight_smile:

I’ve delete the force-probe … although there still isn’t any sound and I have also tried before with it deleted … cheers

OK - thanks. Don’t forget to also remove the ‘blacklist’ command you applied - or can you confirm you found that recommendation by a user with identical hardware?

Can you now run the diagnostic script again, and paste the link here on this forum?


My hope is that running it now will provide diagnostic information that is not ‘tainted’ by those settings.

Thanks … the Blacklist command hasn’t been running … it was only a trial … here is the test script … many thanks for looking!

I note that the script states “No sound servers found”. This could be a pipewire issue.

I assume in the amixer that the IEC958 corresponds to the HDMI and that you are not trying to use HDMI.

I also note the simple mixer control ‘loop back mixing’ is enabled. I don’t know if that a correct setting. It exceeds my knowledge.

With this current configuration, have you retried (I know you tried before - but did you try again? ) :

speaker-test -c2 -l5 -twav

Did that yield any sound?

Also try this

aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

as both a regular user and with root permissions.

If that fails, try this (although I think hw:0,0 is likely correct)

aplay -D hw:0,1 -vv /usr/share/sounds/alsa/test.wav

My idea with those two commands is to try and see if this is an underlying alsa, or a piperwire/pulse audio issue.

I am surprised to see no mention of pulse audio, and the ‘no sound servers’ in the script. Did you remove pulse audio at some point in time ?

FWIW, I get the same reported on my system (where pipewire is in use and sound is working), so I don’t think that is indicative of a problem as such…

!!Sound Servers on this system 

      Installed - Yes (/usr/bin/pipewire) 
      Running - Yes 

No sound servers found.

When pipewire is properly installed, the pulseaudio package is removed. It is replaced by a wrapper (pipewire-pulseaudio) for applications that may depend on it.

Thanks deano … as with oldcpu, I was puzzled by “No Sound Server” … also I have pipewire-pulseaudio installed … as you may recall …

pactl info | grep -i server

result is:
Server String: /run/user/1000/pulse/native
Server Protocol Version: 35
Server Name: PulseAudio (on PipeWire 0.3.39)
Server Version: 15.0.0

Confirm that I am not trying to use HDMI

I also note the simple mixer control ‘loop back mixing’ is enabled. I don’t know if that a correct setting. It exceeds my knowledge.

Using alsamixer, I can’t see the loop back or any way to change it.
However under F2 System Information
.in /proc/asound/timers I do see “Client Sequence Queue 0: stopped”
. in /proc/sound/pcm I see:
… 00-00 ALC1220 Analog : playback 1 : capture 1
… 00-01 ALC1220 Digital : playback 1

speaker-test -c2 -l5 -twav

This test ran, the speaker sound gauge moved up and down but there is no sound at the speaker

aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav
aplay -D hw:0,1 -vv /usr/share/sounds/alsa/test.wav

as a regular user, both these commands ran but neither moved the sound gauge nor yielded sound at the speaker
as root, both commands ran but neither yielded sound at the speaker … the 0,0 command moved the speaker gauge but the 0,1 didn’t move the gauge

I am surprised to see no mention of pulse audio, and the ‘no sound servers’ in the script. Did you remove pulse audio at some point in time ?

thanks, I think deano has addressed this point

I saw on
to use

sudo alsactl restore\CODE]
which produced the possibly interesting result:
alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HDA Intel PCH at 0x6203178000 irq 174)
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6

Just a tip: When posting output, please enclose it within CODE tags as you have been when posting commands that led to the output.

The output is significant. Searching online for similar errors turns up reports of other users having issues with alsa version 1.2.5, so a bug report is likely required here.

many thanks deano … I’ll await the bug situation …

Actually … I thought there might be near term patches but this doesn’t seem to be the case … so might be facing having no sound for a long time if I wait for bug fix

Likely the quickest way to get the fix, is to write a bug report yourself on the openSUSE kernel in Tumbleweed. That will get the immediate attention of the SuSE-GmBH packager for sound in the kernel, who is also an alsa sound driver developer. There is a good possibility he will likely want to immediately work with you, giving you some tests to try to get the sound working. He is possibly the best person on this planet to solve this issue (IMHO) … We are very fortunate in the openSUSE distro to have him as a packager.

There is guidance for raising a bug report on openSUSE here:

I believe you can use your openSUSE forum user name and password when logging on to the bugzilla site.

Don’t bother referencing this thread, as the openSUSE packager will not read a forum thread, so your bug report needs to have all the salient information. Run the diagnostic script

/usr/sbin/ --no-upload

and attach the resultant text file (that will be saved in /tmp) to your bug report.

As long as the openSUSE packager is not on vacation or working on some urgent task, you are likely to get a reasonably quick response.

Thanks oldcpu … will do

Thanks everyone for your help … our developers have advised that my hardware is supported in kernel 5.15, which was released on 7 Nov 2021 … and we need to wait for the kernel to be released in Tumbleweed

The current kernel version for TW is currently 5.15.1 as I write this, so perhaps make sure your system is up to date and test again?