Sound Issues (ESD system sounds)

This week I re-installed my openSUSE 11 x64 version in the hope to get this issue resolved. There for a clean install was made via NET installer.

However the following occured after initial boot-up after installation finished:

Without an .asoundrc file I don’t get any sounds and get the error like

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink 
profile=chat: Could not open audio device for playback.

Alsa was not producing sound by default (Terratec DMX 24/96 6Fire, ICE1712 chipset). I restored my .asoundrc file and had sound working again.

Pulseaudio fails to get a sink and server. It doesn’t matter if I have my .asoundrc in my home directory or not, either way I’m not able to get a sink and server (manager shows “Default Sink: not set”).

ESD deamon is not producing system sounds. If I go to Control Center > Sounds and have it set to “Auto detect” then it produces the beeping sound. On the node “Sounds” I have checked the boxed, but if I click any play button I don’t hear anything at all.

I’ve been trying all sort of things but haven’t been able to get it working properly. I had issues under 10.3 as well: Terratec Dmx 6fire 24/96 - openSUSE Forums

My .asoundrc file: 1712 .asoundrc - ALSA wiki I’m only using the dmix & duplex config. However I already followed the steps in the archived thread, without luck and now am lost what to do.

Help is appreciated. Thanks. :slight_smile:

As you know, my surround-sound knowledge consists of only very limited theoretical, with no experience.

It is possible that 11.0 has some quirks with the syntax of the /etc/modprobe.d/sound file, that were not in openSUSE-10.x. I recommend you put the “model=dmx6fire” syntax in the last line of your /etc/modprobe.d/sound file with something like:
options snd-ice1712 model=dmx6fire
then restart alsa with “rcalsasound restart” and see if that makes a difference.

Pulse audio is also giving some openSUSE-11.0 users a lot of heartburn, and some have resorted to partially or completely removing it. You can see what pulse audio apps are installed by typing:
rpm -qa | grep pulse

If someone with more knowledge than I in this area does not chip in to help (which should not be too difficult given I know so very very little about surround sound) then I think you may be into bug reporting territory. Apologies that I can not help more.

Thanks OldCpu for your time once again. :slight_smile:
This time around it is not surround sound that is causing problems (my alsa works correctly now), but I don’t have system sounds at all.

If I run “pulseaudio” from console I get the following:

W: core-util.c: setpriority(): Permission denied
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
*** PULSEAUDIO: Unable to connect: Connection refused
W: alsa-util.c: Device hw:0,0 doesn't support 6 channels, changed to 12.
W: alsa-util.c: Device hw:0,0 doesn't support sample format s16le, changed to s32le.
ALSA lib conf.c:3843:(parse_args) Unknown parameter 1
ALSA lib conf.c:3969:(snd_config_expand) Parse arguments error: No such file or directory
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0,0
E: module-alsa-source.c: Failed to create source object
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0,0"): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.

Anybody any suggestions to get that ESD deamon working from/ at start up? Either with Pulse or Alsa.

I got system sounds working with Pulse support as well. On the Ubuntu forums I’ve found the following: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron) - Page 35 - Ubuntu Forums

I followed step A and D.

My current .asoundrc file is as follows:

pcm.!default {
  type pulse

ctl.!default {
  type pulse

pcm.pulse {
  type pulse

ctl.pulse {
  type pulse

# "Sensaura" like effect
pcm.ice1712 {
   type hw
   card 0
   device 0

pcm.sensaura { #!default
   type plug
   ttable.0.0 1 
   ttable.1.1 1 
   ttable.0.2 1 
   ttable.1.3 1 
   ttable.0.4 0.5 
   ttable.1.4 0.5 
   ttable.0.5 0.5 
   ttable.1.5 0.5 
   slave.pcm ice1712

In /etc/pulse/ I changed the line that loads the alsa sink to fhe following (according to the Ubuntu guide):

### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)
load-module module-alsa-sink device=sensaura
#load-module module-alsa-source device=hw:0,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

After restarting PulseAudio it gave me all system sounds. Rebooting system still gave me sound and I still have 5.1 sound.

This thread can be marked as SOLVED. :smiley:

Well done, and thanks for sharing your solution.