Sound issue with video files

I was having problems playing videos at all (here: Video files won’t play and Dolphin keeps closing… - openSUSE Forums) but now videos will play but without sound.

I’m using vlc and smplayer, on a laptop running KDE 11.2, and VLC gives me this error:
SMplayer acts like nothing is amiss.

I’ve gone through the restricted media guide, and the first few steps of the audio troubleshooting guide that is linked in another thread and neither have helped.

I tried installing alsa firmware which installed something but did nothing, then I tried a soundtest and all I could get back was this:

:~> speaker-test -Dplug:front -c2 -l5 -twav
If ‘speaker-test’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf speaker-test

and I’ve just tried the yast step but can’t work out how to delete and re-add my card.

speaker-test comes with the package alsa-utils. Please install alsa-utils.

I’m surprised it is not installed now. :\ Did you remove any alsa apps?

What is output of:

rpm -qa '*alsa*'
rpm -q libasound2

I wouldn’t know an alsa app to know if I removed it. I did swap all sorts of stuff in my other thread by following a guide intended to let me play restricted media so it’s possible.

Also I don’t really speak linux :shame: so I’ll assume output is what it gives me back when I type those things in the terminal. It gave me this:

me@linux-i0ah:~> rpm -qa ‘alsa
me@linux-i0ah:~> rpm -q libasound2

Is that all ?

No alsa?

No alsa-utils ?

Try this:

su -c 'zypper install alsa alsa-utils'

and enter root password when prompted. If that install is successful, reboot and test.