Sound Issue with ATI Technologies Inc IXP SB400 AC'97 Audio

No sound from flash players, totem, amarok, xine. but the rest of the system sounds work fine. To make this even more strange I decided to test a youtube link in vlc and it worked fine, in fact vlc is the only media player that works at all. Two systems effected laptop and now a desktop. Both sport the integrated ATI 200xpress GPU and are made by hp.

Short term fixes that have work for this issue

rcalsasound restart and alsaconf

both fix the sound issue on a single time basis, but this is no longer good enough.

This issue started with the kernel update to that comes as part of online update for 11.1.

Card info

lspci -v

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
        Subsystem: Hewlett-Packard Company Device 2a27
        Flags: bus master, 66MHz, slow devsel, latency 64, IRQ 17
        Memory at fe02a000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
        Kernel driver in use: ATI IXP AC97 controller
        Kernel modules: snd-atiixp

dmesg info that related to the sound card

ATI IXP AC97 controller 0000:00:14.5: PCI INT B -> GSI 17 (level, low) -> IRQ 17

I also received a message form the kde warning that sound driver had stopped functioning and it was falling back to another. And when I did alsaconf the first time and every time there after it gave a message saying that it wanted to turn off 1 input channel and 1 output channel in a message box, if you said no which I did it started kcontrol.

Both systems fail to load kdm after the kernel update, I had to login using init 3 and run sax2 before things worked.[/size]

I had a feeling that kde 4.2.2 was part of the issue so I upgraded to kde 4.3 rc1 and the sound now works with flash player and the rest of the media players.

I most likely just needed to upgrade to kde 4.2.4 to get it going again.