Sound issue with alsa on 11.1

My final issue with openSUSE 11.1 is sound. I had no issues with sound from 10.0-11.0 but after a fresh install of 11.1, I noticed the sound isn’t quite as good. I have to have Amarok at no higher than 15% or the sound is distorted(this wasn’t the case with openSUSE 11.0). The sound quality isn’t as good and it would seem that the sliders on the mixer are extremely touchy now. I can post more information about my system if needed but I built this system a year ago with openSUSE 11.0 and it worked flawlessly. I regret taking the time to backup my data to do a fresh install of openSUSE 11.1 since I have had some issues with it. Nonetheless here I am so I would be open to fixing the issues before going back to 11.0

Thank you for your time.

What works for some users is to go to YaST > Hardware > Sound > Other > Volume and adjust the volume levels there. In particular Master and PCM volume controls (although for some PCs there is a Speaker volume control). Sometimes 95% is the best level (to increase the sound level). Sometimes 65% is the best level (for distortion reduction). Sometimes other levels. Then close YaST … and then go to one’s mixer (kmix in KDE or alsamixer/amixer in Gnome) and adjust the Master and PCM volume levels there (also possible Speaker volume). The combination of the settings in the two control applications (YaST and then one’s mixer) can sometimes be used to reduce the distortion.

Also note some PC’s have surround sound, and in that case it is possible the surround sound controls also have to be tuned.

Good luck.

Thanks for the reply. That was one of the first things I tried. It was odd because the mixer was so touchy. I have become so accustom to Suse that its very much like knowing that your car isn’t running quite right. I did some searching here on the forums and this is what worked for me.

I un-installed all of the “pulse-audio” stuff as suggested for some other issues. After a reboot my mixer was no longer touchy but Amarok was still distorting after 15%. I noticed I didn’t have the Amarok-Packman installed but mp3s still played. I removed Amarok and then selected the metapackage to install Amarok from packman. That seemed to do the trick. Everything is as it should be now. :slight_smile:

Ahhh that rings a bell. Could it have been your previous Amarok was using a different sound engine? I vaguely recall one of the sound engines used by Amarok caused distortion for some users on mp3.

Glad to read you had success. Thanks for sharing your solution.