Sound is super quiet in 11.1.

This it the second time in less then 2 weeks this has happened. >:(

This is the other thread: Sound super quiet in openSUSE 11.1 - openSUSE Forums all my info is there.

That solution worked wonderfully for a while. My sound was not working on the 25 but today I got it to work but only just.


Did you try going into ‘Mixer’ and turning up ‘PCM’?

Good Luck,

yes I have tried that and yast and any other ways to turn up the volume. None of them worked.

I note from that thread that you never provided an indication if the zypper commands worked. … I simply left that thread as I had no idea as to your success or failure. Glad to read my efforts were not for naught, even if they were successful only for a brief time.

I like to try help users, but if they do not reply, its difficult to know what to recommend.

Reference your current problems, you could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note with lower sound, often one needs to go to YaST > Hardware > Sound > Other > Volume and move up both PCM and master volume there to 95%. Then close YaST. Then go to one’s mixer (kmix or alsamixer) and move up the PCM and Master volume (and sometimes the Speaker volume) to 95% for testing (backoff on levels once a good volume level is established).

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? With openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… hopefully with that information I may be able to make a recommendation (as opposed to a guess).

Good luck with your efforts.

rpm -qa | grep alsa


rpm -qa | grep pulse


rpm -q libasound2


uname -a

Linux linux-f5e0 #1 SMP 2009-03-31 14:50:44 +0200 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-atiixp

hB6S.6XWGdpUeKe3:IXP SB400 AC’97 Audio Controller

alias snd-card-0 snd-atiixp

also the YaST thing didnt work.

That looks correct … Is there any chance your download/install of those rpms was corrupted? Did you try forcing a re-install of the alsa (and libasound2) rpms?

When testing your sound, did you test with root permissions and also test with your headphones? The 48% volume setting on your headphones suggests you did not test with your headphones.

Some very speculative notes reference your mixer:

I note your PC has a CX20468 … I could not find direct reference to this on the alsa web site. I highligted in a different colour some aspects you could try playing with (restoring to original setting if it does not help).
!!-------Mixer controls for card 0 [IXP]

Card hw:0 ‘IXP’/‘ATI IXP rev 2 with Cx20468-31 at 0xd0003400, irq 17’
Mixer name : ‘Conexant Cx20468-31’
Components : ‘AC97a:43585430’
Simple mixer control ‘Headphone’,0
Front Left: Playback 15 [48%] -24.00dB] [on]
Front Right: Playback 15 [48%] -24.00dB] [on]
Simple mixer control ‘IEC958’,0
Mono: Playback off]
Simple mixer control ‘External Amplifier’,0
Mono: Playback [on]

You could try switch ON digital audio (IEC958) to see if that helps. If it does not, switch it OFF. You could try toggle the External Amp to OFF to see if it helps (typically it should be ON). If that does not, switch it back ON.

I note alsa is loading the snd-atiixp. Is that the same sound module that was loaded before when you sound works?

In some cases the alsa driver loads the snd-intel-hda sound module instead for a Conexant CX20xxx hardware audio codec. You could try manually unloading the snd-atiixp and loading the snd-intel-hda as a test (although thats very wild speculation on my part).

IMHO you need to write a bug report on this:
Submitting Bug Reports - openSUSE
be certain to put the bug report against the sound component. Note that the Novell/SuSE-GmbH maintainer who maintains sound for openSUSE, is also an alsa developer, so you will be getting the best technical support possible at that point.

Good luck.

I did what you recommended and none of it worked, also i posted a bug and got a response. they told me to blacklist snd-atiixp-modem.

I havent tested it it but will post if it worked.

Well that didnt work. But i did get a screen shot of an error or something it is hear:

It looks to me that the blacklist of snd-atiixp-modem did not work.

After blacklisting and rebooting, did your run ‘alsaconf’ or YaST > Hardware > Sound (and edit your sound device) again?

Ya I reconfigured my card and turned up the volume but it still didnt work.

I also noticed that I dont have either of the following files /etc/asound.conf or ~/.asoundrc. and is there any way to test Phonon and make shour that it isnt the problem.

Your best bet at this stage is to follow the advice given you in the bug report you raised.

Try logging on as root and following the steps. If that doesn’t work, try removing/installing/configuring other Intel sound cards (as root) until you find one that does. That’s what I did and it seems to be working fine.

One issue I can’t explain is when I’m logged on to my normal account and enter Yast–>Hardware to view the sound card settings, I’m prompted for the root password, at which I enter. I then click on Sound, and the volume decreases. The problem is repeatable. I can log off (not restart) and back on, and the sound goes back to normal, but when I log on on as root to view the sound card, it decreases. But the sound seems to be at the same level when logged on as root as when I’m logged on, so go figure.

Odd, for sure, but this is my first run at Linux and with my machine being over 4 years old I would expect some problems. But overall, not bad. I’ll run with it and work on the issue as things start to make more sense.


OK so I got my sound to work by reinstalling opensuse and all the alsa stuff. Then my computer froze and I could not get it to reset so I just turned off my computer by pressing the power button. When I turned it back on my sound was faint again. Any ideas?

Yes, … Your sound probably worked with the basic openSUSE-11.1 setup. Then you likely updated a bunch of things, but did not restart. When finally the freeze forced a reboot, your sound did not work with the changed configuration after the reboot.

As far as helping - not possible without more detail. You have a new installation, many things could have changed. I won’t even attempt this.

You have a bug report going now to get the help you need.