Sound is oversteered and too loud


I’ve recently installed OpenSuse 11.0 and I have this problem with the sound. When I play songs or movies in Amarok, Kaffeine, VLC etc., everything sounds really too loud and oversteered (especially the high tones).

If I turn the volume down to <10% in the audio players and then turn the volume to 100% in KMix, the sound is ‘playable’ but not yet good. Sounds comming from the OS itself and other programs like Kopete also sound bad all the time.

/sbin/lspci returns I have this sound device:
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC’97 Sound Controller (rev a0)

and KMix reports a SIS SI7012 device

Perhaps I need to install an other driver or configure this one some kind.

Anybody knows what to do?


Best regards!

  • onraad,

in the mixer, try setting the PCM channel to a lower value.


I typically keep all my volumes at around 60% to 80% (and never higher), which includes master volume and PCM volume. For some (not all) apps, adjusting the applications volume control will adjust the PCM volume control. For vlc, one should always keep its volume VERY low, as I find its volume control very bad for introducing distortion.

Use the hardware volume control on your speakers to adjust the volume.