Sound is only working for root

Although sound was working fine last week, since I performed “zypper up” I now get no sound when logged in as me. I am able to issue the command

aplay -vv /usr/share/sounds/alsa/test.wav

as root and sound works fine. I have checked pavucontrol, the audio icon, and the “audio mixer” and nowhere is sound muted; the volume is 100%. Programs playing sound show the volume varying as the signal is produced.

I have tried adding myself to group “audio” and rebooting, but this has made no difference.
I have run /usr/sbin/alsa-info.sh which produced this output
http://www.alsa-project.org/db/?f=36358e2fa75c50f92bdaa4c58e760c5730a45afb

There are some possible explanations.

One is your regular user has the mixer misconfigured, while user root does not have the mixer misconfigured. In which case you would need to configure the mixer for the regular user. I note you post that you checked this for regular user.

Another possibility is a regression in a kernel update and you now need to add your regular user to goup ‘audio’, restart, and test.

There was also a regression in pulse audio a week or two ago that broke sound for some users. However there has been a fix for that, with a new pulse audio update available that should be installed.

I tried pavucontrol, the Master icon on the screen, and “Audio mixer” that is accessible by right-clicking that icon and all were behaving normally with full volume indicated.

Another possibility is a regression in a kernel update and you now need to add your regular user to goup ‘audio’, restart, and test.

Yes, I tried that too. Adding myself to “audio” group and rebooting made no difference.

There was also a regression in pulse audio a week or two ago that broke sound for some users. However there has been a fix for that, with a new pulse audio update available that should be installed.

I have done a “zypper up” again this morning and rebooted. Root still has sound but I get nothing from

aplay -vv /usr/share/sounds/alsa/test.wav

Try another user or just zap the ~/.pulse directory some time that get corrupted also believe there may be a ~/.config/pulse remove any files there reboot

If removing ~/.pulse per gogalthorp’s excellent suggestion does not work , then please provide more information. You can do that as a regular user in a konsole/xterm by sending the command (with PC connected to the internet) :


/usr/sbin/alsa-info.sh

do not update if asked to update, and select the UPLOAD/SHARE option, and let script run to completion. When complete look in the konsole/xterm and it will give you a URL/web address to share with those trying to help. Please post that URL/web address here. We will look at it and possibly come up with a recommendation.

I removed the ~/.config/pulse directory, rebooted, and that worked a miracle. Thanks so much for your help.