sound is gone after upgrading to Leap 15.3 from Leap 15.2

Hi,

after upgrading to Leap 15.3 from Leap 15.2 I lost sound. On Leap 15.2 the analog sound and microphone worked (after installing sof-firmware).

When running sound configuration in Yast2 I see that Starship/Matisse and Nvidia HD Audio Controllers are found and one can configure them (whatever the default configuration Yast2 chooses). But when I try to play test sound no sound played. Also, when I run pavucontrol I can see only Nvidia output device, the Starship/Matsse does not show up there.

If anybody has an idea how to fix it I will greatly appreciate it.

Here is a brief summary of the setup:

  • sof-firmware installed
  • alsa-firmware installed

lspci |grep -i audio

22:00.4 Audio device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
4b:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)

ps ax | grep pulseaudio

6260 ? S<sl 0:00 /usr/bin/pulseaudio --daemonize=no --log-target=journal

CPU: AMD Ryzen Threadripper 3990X
Kernel: 5.3.18-57-default

The output from alsa-info.sh:

http://alsa-project.org/db/?f=a306567ec390af52b18fca8d3f42840ff0b9fc3d

Thank you for your help in advance!