sound is gone after upgrading to Leap 15.3 from Leap 15.2


after upgrading to Leap 15.3 from Leap 15.2 I lost sound. On Leap 15.2 the analog sound and microphone worked (after installing sof-firmware).

When running sound configuration in Yast2 I see that Starship/Matisse and Nvidia HD Audio Controllers are found and one can configure them (whatever the default configuration Yast2 chooses). But when I try to play test sound no sound played. Also, when I run pavucontrol I can see only Nvidia output device, the Starship/Matsse does not show up there.

If anybody has an idea how to fix it I will greatly appreciate it.

Here is a brief summary of the setup:

  • sof-firmware installed
  • alsa-firmware installed

lspci |grep -i audio

22:00.4 Audio device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
4b:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)

ps ax | grep pulseaudio

6260 ? S<sl 0:00 /usr/bin/pulseaudio --daemonize=no --log-target=journal

CPU: AMD Ryzen Threadripper 3990X
Kernel: 5.3.18-57-default

The output from

Thank you for your help in advance!

Create bug report.
Your sound system is very unstandard.

Bug report with opensuse or Gigabyte?

As for “very unstandard”, Gigabyte and Asus trx40 boards are, probably, the only good boards for Threadripper workstations, lots of people use them …
Besides, it looks like the problem is with suse kernel , because everything worked fine with Leap 15.2 which also uses 5.3 kernel, though a different build …

The output from alsa-info contains this:

!!Soundcards recognised by ALSA

 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xc2200000 irq 164
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xcc080000 irq 163

Is there a way to change “Generic” to anything else, what are allowed entries?

You may try to report a bug to Gigabyte, but it/they will refuse to support Linux with that case.
IDC about how “good” is this motherboards. Threadripper TRX40 chipset have no support for ordinary Intel HDA sound chips, so manufacturers need additional chips (Realtek ALC4050H here). This mobo has 2 sound cards created with 2 chips each, and these 2 “sound cards” are not equal with each other.
SUSe’s kernels are heavily patched. Possibly problem lays not in kernels. Leap 15.3 starts using Pipewire.

Leap 15.3 is too new, simple solution is in using Leap 15.2.

Thank you for your reply.

Unfortunately, complaining to Gigabyte is futile, been down that road. At beast they will reply in a couple of weeks with “we do not support Linux”, as you correctly pointed.

I guess I will live without sound for now, rolling back to Leap 15.2 is not an option, and if it was down time is significant …

In my experience with SUSE (not opensuse), they do not care much about multimedia as they are focused on servers. And it looks like the kernel in Leap 15.3 came from, not opensuse due to new paradigm of building opensuse distros. Hopefully somebody will find a fix. After all it was possible with Leap 15.2.

I have a similar issue with my Panasonic CF-SZ6 notebook.

Upon upgrading from 15.2 -> 15.3 my sound system has become unreliable. With both 15.1 and 15.2 I was always able to plug in a headset into the 3.5" jack and the OS would automatically switch to the headphone output and mic input.
This is not the case anymore. If I plug in the same headset now it won’t switch at all. Only if I go into alsamixer and manually unmute the headphone jack and mute the internal speakers, it works.

Should I file a bug report?

Probably you should.
But I suspect lots of things are “broken” with this new grand idea of taking packages directly from SUSE and sound system is not a top priority.
If, for example, you use boost (c++ libraries) and install both 1_75_0 and 1_66_0 (“legacy”) libs, your zypper/yast2 will **** out with a complaint that it cannot find libbost_{thread,system}.so.1.66.0. One have to update config files in /etc/ manually to rectify the cituation. Otherwise no updates, etc.

If you want help from developers - create bug report and follow theirs instructions.
Do not blame someone without any attempts on negotiations.

Try to use Pulseaudio without Pipewire:


I am not blaming anyone, just stating my observations. I used SuSE long enough (since '99) to know that any major change in the distribution, code-wise or management-wise, is going to cause some pain.

Thank you for the links, unfortunately they are all about Tumbleweed, which is 5.12.9 kernel and Nvidia/HDMI.

I will try to play with pipewire though, will post the results if succeed in getting sound back.

Sound is broken here too

00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

I don’t think Intel audio is a rare hardware.

First thing I did was removing all pipewire packages still no sucess.

Is there any working workaround?

Created a bug in bugzilla

After last update of sysconfig and Yast2 two days before I deleted my 50.sound.conf and
also /etc/modprobe.d and made a reboot. Then I made a new sound-configuration
in Yast. Since that, my internal sound with intel-driver works as expected.
Please do not test sound in yast! It does not work - test your sound after reboot in KDE-Plasma Audio-Settings.

Hope your sound-problem is also gone with this instructions!

I deleted my 50.sound.conf and also 50.sound.conf.YaST2save …

Confirmed … belatedly :-). Removing /etc/modprobe.d/50-sound.conf and after that switching from USB audio profile “Off” to “Default ALSA Profile (unavailable)” did the trick. My workstation is now on kernel 5.3.18-59.34, latest version/updates available for Leap 15.3 as of today date.

Thank you @Johnny15 for great help!

One speculative possibility is that you have installed an sof-firmware that is too new for your kernel.

I note you have " sof-firmware-1.8-lp153.33.1.noarch "

Further I note this in the dmesg:

    9.862286] sof-audio-pci 0000:00:1f.3: Firmware info: version 1:8:0-9e7a8
    9.862287] sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:18:1 Kernel ABI 3:18:0
    9.862287] sof-audio-pci 0000:00:1f.3: warn: FW ABI is more recent than kernel
[59977.483109] sof-audio-pci 0000:00:1f.3: warn: FW ABI is more recent than kernel 

I think LEAP-15.3 comes with an older sof-firmware than 1.8 (I believe 1.6 ?? ).

Edit - I note: I note from that LEAP-15.3 comes with sof-firmware-1.6.1-2.9.

Could you downgrade to the older 1.6 sof-firmware, then reboot and test ?

I don’t know for certain this is the issue, but I am puzzled over the massive errors in the dmesg.

Rear and front outputs both?
ILL front sound output has better quality in your case.