Sound is foobar since end of April

Two weeks ago i have retrofited my seldom used desktop machine with a GeForce card. At the same time, sound went foobar (f#¤%&/ up beyond recognition). At first, i thought it’s some kind of hardware conflict. But numerous tests show that most probably it’s not a hardware. Possibly, it may have something to do with infamous system updates from the end of April. I used to perform updates regularly (whenever prompted).

OpenSUSE Live 13.2 i686
http://www.alsa-project.org/db/?f=120a5d830dee2dc0e29704d1fc39d62528a941d4
Sound like a bell! I could play only .wav and high resolution .flac files. Due to missing codecs no videos, though. (Whew, not even plain .vob files…) But as far as i can say, everything is quite normal.

Ubuntu Studio 15.4 86_64 Live session
http://www.alsa-project.org/db/?f=f26d55df843bdc22d5a228fc6294029a710ac714
Again, sound is perfect right out of a box, all codecs are already pre-installed, i can play a couple of HD videos (.mkv, .mp4) simultaneously!

Knoppix 7.4 86_64, Live of course
http://www.alsa-project.org/db/?f=fd214b3fa682c5c5fed3435bec5922d1330a25e7
Well, what can i say… All codecs installed, all sounds and videos play perfectly.

OpenSUSE 13.2 86_64, hard drive boot, --/home is half a year old.
http://www.alsa-project.org/db/?f=15ec30f9d6f4232bef2d263f9ca95d5c2f64285f
Sound is foobar. All i can play at the moment is a orchestra fanfare in YaST->Hardware->Sound / Volume
Amarok does not start, other programs like VLC seem to be working, but no sound. Mixers show only two channels (L+R) of Pulse audio. Nothing else plays.
Which is probably my own fault – trying to fix it i messed up.

During a last week i have reinstalled system three times. Right after a fresh installation sound seems to be working fine – however i can’t say this 100% due to missing codecs. As soon as i add Packman repo, or commit to online updates (hundreds of packages), sound goes foobar.
When it happens, i can play all the files, but they sound horrible. It depends a bit on a processor load. If i play just simple .mp3 file with idle system, it sounds almost good, just stuttering. Especially female voices sound bit strange; fanfare in Yast sounds unclear. In a moments of high load, decompressing video or something in a background, it goes much worse. In extreme cases, Sade sounds like Lord Vader talking through walkie-talkie. With bad batteries. The pitch of all sounds changes considerably. Everything is considerably distorted, like processed through guitar overdrive pedal.

I will really appreciate if someone in the knowledge have a look at results of my alsa tests. Please tell me what to do.
I am ready to perform another clean install and start over again. If that makes sense.

Thank you in advance, Zibi

zbychobikerider wrote:

>
> Two weeks ago i have retrofited my seldom used desktop machine with a
> GeForce card. At the same time, sound went foobar (f#¤%&/ up beyond
> recognition). At first, i thought it’s some kind of hardware conflict.
> But numerous tests show that most probably it’s not a hardware.
> Possibly, it may have something to do with infamous system updates from
> the end of April. I used to perform updates regularly (whenever
> prompted).
>
> OpenSUSE Live 13.2 i686
> http://tinyurl.com/luoql9b
> Sound like a bell! I could play only .wav and high resolution .flac
> files. Due to missing codecs no videos, though. (Whew, not even plain
> .vob files…) But as far as i can say, everything is quite normal.
>
> Ubuntu Studio 15.4 86_64 Live session
> http://tinyurl.com/nhuy4kf
> Again, sound is perfect right out of a box, all codecs are already
> pre-installed, i can play a couple of HD videos (.mkv, .mp4)
> simultaneously!
>
> Knoppix 7.4 86_64, Live of course
> http://tinyurl.com/nefsbxj
> Well, what can i say… All codecs installed, all sounds and videos play
> perfectly.
>
> OpenSUSE 13.2 86_64, hard drive boot, --/home is half a year old.
> http://tinyurl.com/pa7xrsd
> Sound is foobar. All i can play at the moment is a orchestra fanfare in
> YaST->Hardware->Sound / Volume
> Amarok does not start, other programs like VLC seem to be working, but
> no sound. Mixers show only two chanels (L+R) of Pulse audio. Nothing
> else plays.
> Which is probably my own fault.
>
> During a last week i have reinstalled system three times. Right after a
> fresh installation sound seems to be working fine – however i can’t
> say this 100% due to missing codecs. As soon as i add Packman repo, or
> commit to online updates (hundreds of packages), sound goes foobar.
> When it happens, i can play all the files, but they sound horrible. It
> depends a bit on a processor load. If i play just simple .mp3 file with
> idle system, it sounds almost good, just stuttering. Especially
> female voices sound bit strange; fanfare in Yast sounds unclear. In a
> moments of high load, decompressing video or something in a background,
> it goes much worse. In extreme cases, Sade sounds like Lord Vader
> talking through walkie-talkie. With bad baterries. The pitch of all
> sounds changes considerably. Everything is considerably distorted, like
> processed through guitar overdrive pedal.
>
> I will really appreciate if someone in a knowledege have a look at
> results of my alsa tests. Please tell me what to do.
> I am ready to perform another clean install and start over again. If`s

that makes sense.

Thank you in advance, Zibi

Which output are you getting the bad sound from ( analog/digital/hdmi )?
also which card?

Have you installed the propriety nVidia`s?


Mark
Nullus in verba
Caveat emptor
Nil illigitimi carborundum

Check the drivers in yast NVIDIA will bring it’s own HDMI sound to the game so try changing the order of the drivers in yast. So before yo probably had only one sound device now yo have one more :open_mouth:

Note you should also be able to set the preferred sound device in the pavulcontrol (you have to install it)

I have analog output of M-Audio 2496 connected (by RCA cable) to my vintage stereo.
I do not have any hardware that i could use to test a digital output.
GF video card has HDMI output but i do not intend to use it. I do not any hardware (see, i do not have a TV in a house!).
Most of a time i had this sound device GF119 not configured. Today i configured it, it makes no difference.

The GF card get automatically configured with nouveau drivers and works fine. At some point i installed nvidia drivers, makes no difference.

During last 10 days i tried countless configurations. At some point i even removed the GF card and returned to original video card embedded into a motherboard. No difference in sound.
The only thing that seems to matter is whether updates are installed or not. Fresh system, right after installation, works fine. As soon as i start any updates, it gets screwed. I tried it many times.

Pulse audio is not running according to that script file.

What sort of repos do you have setup ? Only OSS, Non-OSS, Update, Non-Oss-Update and packman? Or did you throw in a host of others ?

Your PC hardware is relatively exotic … so I would recommend surfing for tuning specific to your hardware. I note both the Knoppix does not use pulse (rather it uses Jack). I note the Ubuntu does use pulse but it also has a host of exclusions (?) in its modprobe options.

You mentioned you have done a few installs. Did you have a clean home each time ? If not, would a new user have the same problems wrt sound as your current user ?

There were no “infamous updates” at the end of April IMHO.
There was indeed a pulseaudio update that had problems, but this got fixed the very next day.

But, you should try to remove the folder ~/.config/pulse/ (and probably reboot afterwards to be sure). PulseAudio can be very picky about that, and the broken update might have made some changes that the fixed one doesn’t like.

Due to missing codecs no videos, though. (Whew, not even plain .vob files…)

“Plain .vob files” are actually MPEG2, so it’s obvious you cannot play them without restricted codecs.
I suppose you confuse them with Vorbis/Theora? (which is a free video codec)

Amarok does not start

What happens when you try to start it in a terminal? What error message do you get?

During a last week i have reinstalled system three times. Right after a fresh installation sound seems to be working fine – however i can’t say this 100% due to missing codecs. As soon as i add Packman repo, or commit to online updates (hundreds of packages), sound goes foobar.

Try to do a full repository vendor switch to the Packman repo:
SDB:Vendor change update - openSUSE Wiki
You might have incompatible package versions installed causing the problem with your applications, including Amarok failng to start.

When it happens, i can play all the files, but they sound horrible. It depends a bit on a processor load. If i play just simple .mp3 file with idle system, it sounds almost good, just stuttering. Especially female voices sound bit strange; fanfare in Yast sounds unclear. In a moments of high load, decompressing video or something in a background, it goes much worse. In extreme cases, Sade sounds like Lord Vader talking through walkie-talkie. With bad batteries. The pitch of all sounds changes considerably. Everything is considerably distorted, like processed through guitar overdrive pedal.

Maybe just your volume’s are too high?
Try to lower them, the application’ one and the overall volume.
And don’t use phonon-backend-vlc, this will raise the overall volume to 100% on every login.

And I suppose sound works better when you just disable PulseAudio in YaST->Hardware->Sound->Other->PulseAudio Configuration, right? Or if it is disabled already, maybe try to enable it instead… (logout/login or reboot for full effect)

What’s so exotic in DELL desktop computer? Or in M-Audio and GF extension cards?
This M-Audio Delta 2496 is few years old, has been in 3 different desktop machines before, went through countless configurations, never ever a slightest problem. In all Linux installations it worked “out of a box”.

So i performed a fresh install with a new user. OpenSUSE 13.2 86_64 from DVD. During installation i left unchecked “Add online repos before installation”. Nice and easy.
After reboot into a new system i was immediately prompted to install updates, politely declined.

In YaST->Hardware->Sound there are listed:
GF119
M-Audio Delta
I chose a second one, Normal Setup. After manually adjusting DAC and DAC2 volumes everything works fine. Orchestra fanfare sounds loud and clear.
I leave GF119 not configured.

I try to open a .wav file. Kaffeine says “Can not play format” and proposes to install additional support. I decline.
Amarok plays high resolution audio (24/96) .wav files just fine. Only then, with music still in a background, i look into Sound → Other → Pulse Audio Configuration. “Enable Pulse Audio” is checked. I click OK and then… Everything goes silent. Amarok (after restart) seems to be working normally, only without sound. Alsamixer shows only one control “Master”, i change from 100 to 85. KDE mixer says “No playback devices”, “nothing is playing audio”.

At this point i start alsa-info.sh script. Result is there:
http://www.alsa-project.org/db/?f=ea86714cf6c7c09fb5fba0e98ac6a2422ea5389b

Now, what did i do wrong? How to restore sound?

How’s about online updates and adding a PackMan repo. When, in which order?

I really appreciate your support. Will come back here in 24 hours. Before that i will disable Pulse Audio, remove /.config/pulse/ and reboot. Will report about results without delay.

OK; after a full reboot sound is back!

Now, how’s about adding full multimedia support and online updates?

Just go to Yast-Repository maintenance and select add a repo and then the community repos and select packman.

Follow instruction at the top of the multimedia forum to add proprietary codecs

Been there, done that. As i said before, in a course of two weeks i have reinstalled system a couple of times. Always, immediately i would try to be able to play my files, so i was adding multimedia capability as soon as possible. And always i would end up with a broken sound.
But i would like to pinpoint that single factor which breaks my sound. So i want to do it in smaller steps.

So i committed to regular updates, to which i was already prompted several times. Software updater showed 4 security updates, i agreed. After that immediately came 19 packages to update. Agreed. Then i was prompted to update 229 packages, i agreed, and because of dependency it developed into 578 packages. I installed all of it. Then full restart.

After a full reboot, sound is broken. Everything seems to work normally, just silent, no sound at all. I play .wav file in Amarok, a progress bar and time counter are moving, spectrum graph mowing, all the mixers show proper levels, even PCM Monitors in Envy24 Control are moving as always. Just no sound at all. Even an orchestra fanfare in Yast->Sound configuration is mum.

Current alsa-info.sh snapshot is at http://www.alsa-project.org/db/?f=104d2f33dd9fe53f25969891869b5f081e5665a0

I believe a dead sound is better than a foobar sound, so i do not want to mess up completely. I will really appreciate your expert guidance, how to restore my sound. (At this point I am not talking about a full multimedia support, all i want is just to play a simple .wav file.)

Pulse Audio is not running


Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - No



Did you turn it off in Yast??

All your volume controls appear to be off/set to 0

Deleted because duplicate post/suggestion.

Only yesterday, right after a fresh install (with a brand new user, i forgot to mention) activating Pulse Audio killed the sound. So yes, i turned it off. (My two posts from yesterday at 20:37 and 20:47).
Then i made the updates, and the sound is dead regardless whether Pulse Audio is activated or not. All volumes look quite normal (Alsamixer, Alsamixergui, KMIx, YaST, Envy24 Control), graphic peak monitor in Envy24 Control and spectrum graph in Amarok move as always.

Just for testing i have activated Pulse Audio again, installed pavucontrol, checked levels. To no avail. So i de-activated Pulse Audio, removed --/.config/pulse and made a reboot.
Still no go.

And i forgot to mention, my repos are so far only OSS, Non-OSS, Update and Non-OSS-Update.

An ICE1712 is relatively exotic compared to the vast majority of PCs. Thats not a criticism, its an observation.

In the past 10 years of supporting this forum and also 2 of the 3 forums that merged into this forum, I have found that that specific hardware tends to have more problems with GNU/Linux than the majority of other hardware for sound. Again - its an observation - not a criticism. One can do a surf on this forum for threads wrt trouble with same - and if the old forums were still searchable (which they are not) possibly one would have better statistics as to which hardware caused more problem.

Have you done any audio tests with aplay and speaker-test combinations to see if you can localize from where the sound problem originates ?

M-Audio Delta 2496 (with ICE1712 chipset) is a decent soundboard – unlike a vast majority of “high definition audio” embedded into motherboard (just an observation!). :slight_smile: It never gave me any problems. It always worked out of a box, (even with most simple Live Linux distros like SLAX).

I can’t figure out how to play anything in aplay. I am sorry. I am not good with CLI.

My desktop machine has two hard disks. One of them was used as a storage before. Yesterday i made it into a dual boot machine, with OpenSUSE 13.2 on one and Ubuntu Studio 15.4 on another. As a matter of fact, i write this post from a latter system. I’ve got some dull work to do and i like to play some music in a background. It just works, without a hitch.

I need the output of the diagnostic script to give some good aplay and speaker-test tests, but unfortunately that alsa-project site is down for the moment, and until it is up (so I can see the script output), I prefer not to speculate on a command that may simply frustrate and mislead you.

No worries. Its possible aplay and speaker-test will or will not work, but if it fails to work, then the text n the terminal that goes along with failure “may” give us some insights as to why the sound is not working.

I note the alsa-project site is back on line and from the script:


APLAY

**** List of PLAYBACK Hardware Devices ****
**card 0**: M2496 [M Audio Audiophile 24/96], **device 0:** ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

from which I can see hw:0,0 is your ICE1712 device.
Try each of the following commands both as a regular user and with root permissions. The reason to try with root permissions sometimes is to check if there is a permission issue, either with alsa or with pulse. Take note of any errors as they may give a hint as to the problem.


aplay -vv /usr/share/sounds/alsa/test.wav

The above will use the default sound device. If you have the appropriate alsa-pulse plugin installed, it will also try to route the sound through to play in pulse (from what I understand). I don’t know enough about this to be able to say the impact of enabling or disabling pulse on this command.


aplay -d plughw:0,0 -vv /usr/share/sounds/alsa/test.wav

The idea of the above is to route the sound to device hw:0,0 which I think is your ICE1712. The plug in front of the hw is to look after some formatting issues. Again, my knowledge here is a bit weak, as I am not sure how this interacts with pulse.


aplay -d hw:0,0 -vv /usr/share/sounds/alsa/test.wav

This is the same idea as the above with plughw, except here it is the raw ‘hw’ which is more dependant on formatting being setup correct. Again, my knowledge here is a bit weak as I am not sure how this interacts with pulse, although I have often thought it bypasses pulse.


speaker-test -Dplug:front -c2 -l5 -twav

From the man page, speaker-test by default will test the default device. If you want to test another sound device you will have first to get a list of all of the sound cards in your system and the devices associated with those cards.

or if that yields errors, try this more basic speaker-test command:


speaker-test -c2 -l5 -twav

Hei oldcpu! It works! It’s magic!

The first three aplay tests played beautifully! Loud and clear. The fourth returned an error:


foobar@linux-5pmz:/usr/sbin> speaker-test -Dplug:front -c2 -l5 -twav
speaker-test 1.0.28
Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Device or resource busy


The fifth one again worked fine.

Now, encouraged by such a positive development i tried to play something in Amarok, and you know what? IT JUST WORKS! Ta-daaaaaa!

Only then, i decided to repeat the test #4 as a root. And it worked fine. I made it again as a normal used, again it worked fine.

Now YOU’VE GOT ME STUNNED! I wish i could understand how these commands work. But i really don’t mind that the sound works! :slight_smile:

Here’s a snapshot of a current state: http://www.alsa-project.org/db/?f=367b45315a0da6068454780a9aa14943f125b3d2

So, what do you recommend for a next step? Adding a Packman repo and a full multimedia capability? Any particular details about how to do it?

I assume the 4th error is because pulse audio has seized the audio device and not sharing it with the speaker test “-Dplug” sound routing.

The fifth is less specific, and I assume it uses pulse audio via the alsa-plugins-pulse application.

I recommend you follow this guide: openSUSE 13.2 Multimedia Guide - Open Chat - openSUSE Forums where I believe that gives instructions wrt the Packman repo.