Sound in SUSE 11.1

Hi All,

Just Upgraded to 11.1 from 11.0 and its trashed my system, HAL and others where problems on the Repair system options. So i reinstalled clean start so to say. I have reinstalled my ati drivers but i cannot get my audigy card to work. I have no sound at all, not that it was to great before, it took me months to get it working before and i had 4.1 not 5.1, Please can someone take me through setting up my sound card, i love openSuSe and need to get it working again. Its a budget audigy 2 and i need help.

Please advise

Seems a lot of people, including myself, have propblems with sound in OpenSuse 11.1 – read a little down in this forum to find several threads.

Its likely a mixer setting that you have wrong.

Take a look at a likely solution here:
[Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](

A possible solution - it has worked for me - is to open the console and enter
su –
rcalsasound restart

Unfortunately, it has to be done after every boot but it works and it is a workaround while waiting for the bug, if that is what it is in your case too, to be sorted.

(I did try adding it to an init script but that didn,t work)

I get this from a restart i am looking into the other links at the moment, cheers all

linux-nzet:/home/dave # rcalsasound restart
Shutting down sound driverERROR: Module snd_emu10k1 is in use
ERROR: Module snd_rawmidi is in use by snd_emu10k1
ERROR: Module snd_ac97_codec is in use by snd_emu10k1
ERROR: Module ac97_bus is in use by snd_ac97_codec
ERROR: Module snd_pcm is in use by snd_emu10k1,snd_ac97_codec
ERROR: Module snd_seq_device is in use by snd_emu10k1,snd_rawmidi
ERROR: Module snd_timer is in use by snd_emu10k1,snd_pcm
ERROR: Module snd_page_alloc is in use by snd_emu10k1,snd_pcm
ERROR: Module snd_util_mem is in use by snd_emu10k1
ERROR: Module snd_hwdep is in use by snd_emu10k1
ERROR: Module snd is in use by snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_util_mem,snd_hwdep
Starting sound driver: emu10k1 done

Next step, trying to install the sounddriver in GNOME gives me the following error

Das Kernelmodul snd-aoa für die Soundunterstützung konnte
nicht geladen werden. Ein möglicher Grund dafür können falsche
Modulparameter sein, sowie ungültige IO- oder IRQ-Parameter.

The kernel-module snd-aoa for the soundcard support could not be loaded. A possible reason fot hos could be wrong modulparameters as well as an invalid IO- or IRQ-parameter.

Can anyone help?

After a restart, did you try follow this suggestion:

You could try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Also, please note that to determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL. It may be that you need to run that script twice with root permissions - the first time to update the script and the second time to get the URL provided.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I am not on the machine right now but can tell the following:

  • Speaker Test does not work, it get a “Connection refused -111” error
  • I worked my way through Audio Trouble Shotting w/o success
  • When I use alsamixer w/o parameters i get the above error
  • When I use alsamixer -c 0 I get the mixer controls working fine
  • Using rcalsasound restart doesn’t change anything

Will post the output of the script, greps and modprobe asap. IMHO it seems I would need to point the system to the card 0 although it IS set as the standard card (see alsamixer vs alsamixer -c 0).

Thanks for the offer to help

ok, I’m keen to see the output of the rpm commands I asked you to run. If you went thru the entire troubleshooting guide, then your PC will have the latest alsa.

Sure, … as a note, I am heading off on business trip tomorrow, so I may not be alble to respond to any new information between tomorrow morning and Thursday evening, European time.

There we go

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux TiBook #1 2008-12-04 18:10:04 +0100 ppc ppc ppc GNU/Linux

cat /etc/modprobe.d/sound
options snd slots=snd-powermac

rdCR.ITz6G5CcwPB:Integrated Sound (awacs)

alias snd-card-0 snd-powermac

OK, thank you for that. Your alsa-firmware version makes no sense, given your other alsa versions. Why do you not simply install the regular alsa firmware for 1.0.18 of alsa, then restart your Mac and test your sound. Move your mixer volume controls up to 95% for testing (not the low levels that you have them at now). When you get distortion you can back off on those levels.

If that does not work, I can walk you thru a complete alsa update, although I am not certain that will help.

… Next time, please mention you are using a Mac. The hardware for a Mac is different from an intel/amd based PC, and knowing that the user asking for help has a Mac is important when a volunteer like myself is trying to decide if they wish to spend their time on a support request on unfamiliar hardware.

One last thought … I tried to help a couple Mac Tumbler users a while back… in both cases they had messed up their mixer. Take a good look at your mixer:

**** List of CAPTURE Hardware Devices ****

!!Amixer output

!!-------Mixer controls for card 0 [Tumbler]

Card hw:0 ‘Tumbler’/‘PowerMac Tumbler (Dev 18) Sub-frame 0’
Mixer name : ‘PowerMac Tumbler’
Simple mixer control ‘Master’,0
Front Left: Playback 132 [75%] [on]
Front Right: Playback 132 [75%] [on]
Simple mixer control ‘Bass’,0
Mono: 36 [50%]
Simple mixer control ‘Treble’,0
Mono: 36 [50%]
Simple mixer control ‘PCM’,0
Mono: Playback 117 [66%]
Simple mixer control ‘Auto Mute’,0
Mono: Playback on] Should your levels be so low? Should not auto mute be OFF ?

I have switched my card to the onboard card so i have sound at the moment but if a fix is found let me know. I reinstalled my system and switched to my onboard sound card. on thing i did notice is that it was installing an audigy2 zs card driver, not sure if this helps but my sound didnt work with any of the sound systems.

My card is an audigy 2 value but the 11.1 installer was putting it as an audigy 2 zs card and i could not find a way to change it.

First of all, my apologies, I thought you did know from previous posts and my signature that I am on Apple PPC, sorry.

The elder version of firmware I found was 1.0.17 which I installed without success.

This happens with alsamixer in terminal

E: socket-client.c: socket(): Address family not supported by protocol
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused

when I use alsamixer -c 0 the mixer comes up perfectly. So that seems to be the problem.

I can’t help you with alsa mixer specifics. … I am a KDE3 user, and I use kmix from KDE3.

Did you address the points I raised re: your mixer?

A couple of workarounds that might work to automate this for you. One would be to add this line to the boot.local file in /etc/rc.d. in which case list the full path which should be /usr/bin/alsamixer -c 0.

The second would be to create a simple shell script to call this function and place it in the Autostart folder of .kde or .kde4 in your home directory (assuming you use KDE).

I’m not saying that either method will work for you, and if one or the other method does work, remember it is only a workaround and not a proper fix.

Thanks for help and suggestions. But that would only call the alsamixer up, which doesn’t help. The point for me is, that alsamixer does give me an error while alsamixer -c 0 does not. That shows IMHO, that the sound would be working, but for some reason the card is addressed wrongly, as forcing the mixer with -c 0 to use it works, while without any parameter the mixer should use the default card which then gives an error. Therefore i guess, that there is a problem in defining the card as default, although i did that from within Gnome. And funny enough -c 0 means using the card number zero which is the default. Alsamixer and the whole system seem to point to the nirvana instead of the sound card… i guess. But i cannot figure out how to change that.