Sound in One Login session but Administrator session: New upgrade to 13.1

I’ve upgraded from 12.3 to 13.1 quite successfully. I have been through all the multimedia proceedures and have ended up with sound in one user account/session but not the administrator’s account. I’ve created a new account (the account that has sound working existed before the upgrade) and that has no sound either. All the settings I can find appear the same.

Anything obvious someone can see?

Wayne.

I see no reason why you need sound for the Superuser (root). To begin with you never log in as root in the GUI, and why would you like to have sound in a CLI root session?

And for the user, again I assume this is in a GUI session. But you fail to explain which desktop environment you use. Also “Alll the settings” would mean that your idea about “All” and the idea others have about the sound settings would coincide. This might be not the case. I am afraid you have to explain what you checked to allow others to decide if this is indeed all and evrything or not.

You should never ever log into a GUI as root you can do major damage totally by accident. You can become root with su or sudo any time from a normal user account there is never a need to log into a GUI as root. Don’t do it.

If sound works for one user, but not for another, that suggests there is a misconfiguration in the user account where sound does not work.

In the user account where sound does not work, try removing ~/.pulse and ~/.config/pulse directories (if they exist).

Henk,

Thanks. I am using Gnome – I should have said.

I have my own GUI account “Wayne” which has administrator rights, I am not working in root all the time. Is that right? It is a single computer desktop, home system, the kids have their own GUI user accounts.

I went into the account that had sound last night to compare setting again, now that doesn’t have sound either. So, no sound at all now.

I could not find the ~/.pulse directory but did find ~/.config/pulse directory and tried deleting it. I was not allowed as it still contains files and I’m not sure whether I should continue pursing this line in light of the other GUI user account losing its sound too.

For sound settings I have checked through the “Sound” button from “All Settings” window. I also have another “Pulse Audio Volume” button amongst my Applications. This brings up a different group of setting options to that of the “Sound” button on “All Settings”. Then there is YAST sound I have looked through. Now I think there’s a conflict between the two Pulse Audio settings. The sound in the GUI user that had it, did not work after I opened the “Pulse Audio Volume” button amongst the Applications: that is, started that application. I’ve got a feeling the Pulse Audio control in my applications has come from the Packman repository. So, this appears to be my problem but am unsure of where to go from here.

I would say I have to remove one, but which one and do I just remove it through YAST? Is there anything else I need to do?

Hi,

Although you should not log-in as root in a GUI session it is still possible. I do that a lot when creating my usb installer. You can omit the user creation during the installation and log-in as root on the GUI session. (if you want to)

Once the installation is finished, you can install all your favorite the packages/apps you want and install “yast2-live-installer”. You now have a usb installer with all your favorite apps. Since it does not have a normal user then it will not be copied on the machine/computer you want to install to. :wink:

just saying…

That is somethinmg I do not understand at all. But this discussion might be off topic for your problem.

Like hcvv, I have no idea what that means.

wrt your sound, can you provide more information ?

As a REGULAR user, please open a konsole/terminal, and with PC connected to interent type in the konsole/terminal the following command:


/usr/sbin/alsa-info.sh

and then select the SHARE/UPLOAD (don’t go for an update if asked) and let the script run to completion. Then in the konsole/terminal it will provide you a URL/web address where the audio config has been updated. Please copy that URL/web address here, so we can examine your PCs audio configuration and maybe figure out what is set incorrectly ?

  1. giving your user elevated rights is not a great idea and is certainly not needed.Sounds like a bad Windows idea.

  2. Since you are messing with users be sure you are a member of the audio group. Note that for changes in groups to take effect you need to log out then back in.

Oldcpu,

Thanks, following:

http://www.alsa-project.org/db/?f=b0f7b021b28b6ed7d148266f385a107701754079

I’ve looked at this GUI account Administrator. When I go to “All Settings” then “Users”, my account under “Account Type” says “Administrator” whilst the others are “Standard”. When I go into YAST and “User and Group Management” it appears that my account is the same with some extra permissions. So, that’s where my “Administrator” account comes from. I not sure what meaning is to be attached to such but, I’m not running the GUI whilst in SuperUser.

Wayne.

I am not familiar with “GUI account Adminstor” nor do I know what application you are referring to when you say you go to “All Settings”. That rings no bells with me and I am not familiar with that.

Which extra permissions ?

Nominally the sound should be working.

I note during boot, there is some difficulty in the alsa driver idenifying your PC’s sound SSID (and possibly we can follow that up later):


   24.854897] ALSA patch_realtek.c:490 realtek: No valid SSID, checking pincfg 0x4007e629 for NID 0x1d
   24.854898] ALSA patch_realtek.c:506 realtek: Enabling init ASM_ID=0xe629 CODEC_ID=10ec0892

The aplay part of the script identifies two sound devices, card0 and card1 (both using the intel sound driver).


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
**card 0:** PCH [HDA Intel PCH], **device 0:** ALC892 **Analog** [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I assume you are using analog with card-0 and not digital sound nor HDMI for sound. Please advise if that assumption is wrong.

Assuming that assumption is correct, then your sound device is hw:0,0.

please as a regular user copy and paste the following into a terminal and advise if you heard any sound ?


aplay --device hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Please try that as a regular user, and also try it with root permissions.

Does either yield sound ?

Since you have 2 sound devices both Intel it can be confusing HDMI is normally associated with the video card (GPU) In most cases you want to be using the analog output. So that is what you want to select in the desktop configurations and any place else you see the choice

Oldcpu,

Thanks. First, the “All Settings” Window comes from the top right corner of Gnome in 13.1. I click there and a drop-down appears with a sound slider, option to change user and three symbols: crossed screwdriver and spanner, lock, and, shutdown. The crossed screwdriver and spanner produces the “All Settings” Window, which amongst other things has “Sound”, “Users” and “YAST”. Clicking on “Sound” there produces a Window which tells me my “Output” is "Digital Output (S/PDIF)-Built-in Audio.

When I open PulseAudio control from my Applications, I get a window with the following tabs: Playback, Recording, Output Devices, Input Devices, Configuration. My Configuration tab has the option for both Audio devices: Radeon HD7700/7800 Series and Built in Audio: Digital Stereo (IEC958) Output + Analog Stereo Input. the Radeon is turned “Off” because this is the HDMI sound, which is not in use. The Built-in Audio only has two options, the one selected with Digital Output + Analog Stereo Input, or, just for Digital Output. All the Analog options are listed as unplugged.

In YAST, both cards are listed: Onboard (0), ATI (1).

I ran the script you provided in a normal user terminal and in root: no sound. The script seem to execute okay and play the .wav. I also ran the script, as below, on the assumption “hw:1,3” represented Card1, Device 3: still no sound.

aplay --device hw:1,3 -vv /usr/share/sounds/alsa/test.wav

After checking all the setting windows and working out the sound appears to be Digital, I modified the script to:

aplay --device hw:0,1 -vv /usr/share/sounds/alsa/test.wav

and got:

aplay: main:722: audio open error: Device or resource busy

I had a browser window open with Youtube playing (no sound), so, I closed that and ran the script again – successfully, but still no sound.

So, my sound is DIGITAL. I was wondering if there’s something I should plug in or torn on, on the motherboard to get the Analog working but, the sound was working fine under 12.3 and also on one user account for a while?

Please note, I have to go bush for a few days, I’m a gold prospector in Western Australia and will be outback and without access to this computer until early next week. Thanks for your help thus far.

As additional information, in case it is of any use:

the motherboard is an ASUS P9X79LE, Intel i7 LGA2011 socket , with onboard graphics but no onboard HDMI.

The graphics adapter is a:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850] [1002:6819]
Subsystem: XFX Pine Group Inc. Device [1682:3262]
Kernel driver in use: radeon

Wayne.

I’ve got Analog sound.

In being about to leave, I decided to plug the sound into an old Windows 7 system for the kids. Whilst shuffling the plugs around I thought “Maybe I should try plugging into Analog on the Linux system?” Obviously, after working out I had Digital sound, the sound system was plugged accordingly. So, I shuffled the plugs, then Analog became active in the Pulse Audio Control settings whereas it had been “Unplugged”. I changed the settings and…Sound! That is Analog sound.

Thus the problem has changed: it is now that I don’t have digital sound – as I used to. Remembering that it ran perfectly under 12.3 and there was no changes to the plugs for the upgrade to 13.1 – and, the digital sound did run in one user account at the start, after the upgrade.

Anyway, the groups input has got me through to having sound for everybody before I go. I will take up further tidying up the sound system upon my return in a few days.

Thanks all, especially Oldcpu.

Wayne.

wrt permissions, I am not a gnome user - and you are using gnome desktop specific controls - so that explains why I am not familiar with what you have done to the permissions.

That is not a script from what I understand. It is the command to launch a playback application that comes with alsa-utils. The application is ‘aplay’. The remainder of the entries on that line are input values for aplay. Some info on aplay here:


oldcpu@4770:~> whereis aplay
aplay: /usr/bin/aplay /usr/share/man/man1/aplay.1.gz
oldcpu@4770:~> rpm -qf /usr/bin/aplay
alsa-utils-1.0.27.2-4.5.1.x86_64

Also, one can type ‘man aplay’ and obtain more information on that application.

hw:1,3 is for an HDMI connection. Are you using HDMI ? If not then clearly that command/application will not work.

.

Digital sound. Interesting. That is unusual.

.

What does ‘successfully’ mean ? No error messages ? Did you try the command with hw:0,1 and also hw:0,0 immediately after a fresh reboot ? Are you certain you have your cables to your speakers correctly connected ?

Is there any chance you have pavucontrol and also your gnome set up for a 5.1 surround sound system ? I note you have surround sound muted:


Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 [0%] -64.00dB] [off]
  Front Right: Playback 0 [0%] -64.00dB] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] -64.00dB] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] -64.00dB] [off]
Simple mixer control 'Side',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 [0%] -64.00dB] [off]
  Front Right: Playback 0 [0%] -64.00dB] [off]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] -34.50dB] [off]
  Front Right: Playback 0 [0%] -34.50dB] [off]

.

Note if wanting HDMI audio with the radeon driver, one needs to add a special boot code instructing the open source radeon driver to turn on HDMI sound.

Since you have no sound now you have less to lose. Backup the ~/.config/pulse directory, then remove it. Reboot and test.

Oldcpu,

Thanks again – I’ve been back a couple of days – about to head out bush again.

I have worked out (went to the audio shop where I bought the surround sound system the computer is plugged into) that I have indeed been running, and wired for, the computer’s surround sound, hence, the Digital Audio settings… So, if that is muted, as you say you noticed, that will likely be problem. Where do I correct that?

I currently have Analog audio, working perfectly.

I apologise for my poor terminology: script/command. I’ll learn.

With regards to the HDMI audio and the radeon driver, is this what provides HDMI audio when playing movies/videos? I have encountered the problem in 13.1 before, on a laptop, where the video plays but no sound through the HDMI. I never got back onto that and so it still remains unresolved. I haven’t tried playing videos/movies from DVD or ISO on this computer yet. Is it necessary for me to add the special boot code instructing the open source radeon driver to turn on HDMI sound, for this?

Wayne.

You should be able to unmute that with alsamixer application.

wrt the surround sound be muted (where one typically needs a 4.1 or 5.1 system to take advantage of it) I note from the settings from the script:


**Simple mixer control 'Surround',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 **[0%]** -64.00dB]** [off]**
  Front Right: Playback 0 **[0%]** -64.00dB] **[off]**
**Simple mixer control 'Center',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 **[0%]** -64.00dB] **[off]**
**Simple mixer control 'LFE',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 **[0%]** -64.00dB] **[off]**
**Simple mixer control 'Side',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 **[0%]** -64.00dB] **[off]**
  Front Right: Playback 0 **[0%]** -64.00dB] **[off]**


I think the above self explanitory wrt surrounnd sound being muted.

Congratulations on getting your audio back working.

Only if you have selected to use HDMI and only if you have HDMI wired. You do NOT need HDMI to watch movies/videos. You do need the right codecs with your video players - which would be a different subject than this thread if that does not work for you.

If your graphic hardware is ATI, and if you are using the open source (and not the proproietary) driver, and if your TV is connected to your PC via HDMI, then it is necessary.

I’m away for the next 2-weeks on vacation, driving through Europe with family members from Asia who came to visit. While I will take my laptop with me, my internet access will be intermittent.