Sound in Firefox but not in Songbird - SUse 11.2 64bit


I’m getting puzzled: I don’t want to use Amarok any more, as I don’t like the new interface in 2.x and don’t find a way to install 1.4 within OpenSuse 11.2.
After doing the upgrade, I installed SongBird and imported my music collection (some 13000 songs). When I click play, it acts as if everything is fine, but no music comes from the speakers. I just tried a YouTube video within FireFox, and sound is just fine. In the system settings, I find 5 devices listed, but only the top one (analog) works when clicking on Test. Within Yast, the test of the device works as well.
Here a foto of the system settings screen.

I have no idea how I can get SongBird to actually play the music. i checked throughout the forum here, but didn’t find anything helpful. Others have other problems, even though it seems initially the same.
I didn’t find any option to change settings for the sound output in SongBird. I’m also not sure if that’s the problem. Can anyone help?

Thanks in advance!

Strange, but it works now, after I restarted for the 100th time or so.

Did you try pulseaudio?
Its worth a shot

I have this exact problem! Audio works in almost all other programs, but Songbird doesn’t give any sound at all. I’m somewhat at loss here, and would appreciate all help.

Alternatively, I would like to know of a good audio player alternatives. The best I’ve found this far is gmusicbrowser, but its gstreamer output is very buggy: I had to manually select “oss” as output device, and it waits a couple of minutes between each song before starting to play.

This far I’ve been using foobar2000 through Wine. Not any kind of optimal solution either. If only Songbird worked!


You can find Amarok 1.4 here: Index of /repositories/KDE:/KDE3/openSUSE_11.2 Add that repo and then install the package kde3-amarok, and you’ll get the KDE3 version of it.

If you don’t like Amarok, then maybe Rhythmbox or Banshee?

Thanks for suggestions – indeed, I don’t like Amarok, it’s somehow very confusing and doesn’t seem to offer any possibility to configure the user interface.

I tried Rhythmbox. It has very same problem that Songbird has: no sound. Additionally, I made the following observation:

  1. When I (frequently) have sound problems, I go to YaST Control Center -> Sound. “Play test sound” does not work.
  2. I delete the configuration.
  3. I choose Edit -> Quick automatic setup -> Next. The test sound works again.
  4. Open Rhythmbox, and try to play something, to no avail.
  5. Go back to the YaST sound settings, and the test sound is not working anymore, either. I have to reconfig the sound card again.

So, Songbird and Rhythmbox try to do something that does not work. However, Amarok just works, always. Are they perhaps using some different sound systems or something?

Well, Amarok uses Xine and Rhythmbox uses GStreamer as a backend. Maybe that’s part of the problem…
What version of GStreamer are using, and from which provider? My system is using gstreamer-0_10 from packman repo, and I haven’t had any problems with it.

Also, have you checked your sound sources in alsamixer (open konsole, type in “alsamixer”) to see which channels are being used and which are muted etc?

I’m using gstreamer-0_10, and all gstreamer packages are from Packman. I checked the alsamixer, and it seems quite fine. S/PDIF Default PCM is at 00, though, and I can’t increase it.

In gstreamer-properties, “Autodetect” does not produce any test sound. OSS works, and Alsa if I change the device from “Default” to “AD198x Digital”. The other option (besides default) is “AD198x Analog”, which does not work (obviously, since I have an optical S/PDIF connection to the amplifier). However, even if select a working configuration, neither Songbird nor Rhythmbox works.

Thanks for replies this far :slight_smile: I’m out of time just now, I guess I’ll try again in a couple of days.

One quick addition – in gmusicbrowser, gstreamer only works if I manually select output device “oss”. None of the others work, not “autodetect” or “alsa” or others. Can’t find similar output device selection in other audio players, though.

i had that problem and the fix to it was to go to right click the mixer symbol and go to show mixer window and then raise PCM all the way up which made the sound work for me.

I was fond of Songbird on Windows, but can never get sound with it in Linux — Amarok is the best of a weak bunch of players, but sadly is ugly and doesn’t play all file formats.

The final time I installed Songbird, and final for that reason since I would never trust it again, when I agreed to let it form a music library it took this so literally it rearranged my entire collection on the hard disk into folders that suited itself…