Sound Gone After Latest Update

Hello all,

After updating TW today (openSUSE-release 20160605) and rebooting I found that I lost all sound. Hope someone could be of assistance. First some basic info about my set-up:


cat /proc/asound/cards
 
0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xc2820000 irq 52
1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc3800000 irq 51


lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series] (rev ff)


/usr/sbin/alsa-info.sh

http://www.alsa-project.org/db/?f=b1a7fcf5934ab3684120fbd70259e8166e1bc37b

When investigating I noticed that file /etc/modprob.d/50-sound.conf was gone. I replaced it with a back up but sound still didn’t work.


cat 50-sound.conf

options snd_hda_intel index=0 vid=0x8086 pid=0x1c20
options snd_hda_intel index=1 vid=0x1002 pid=0xaa90

When I went to Yast I saw that none of my sound cards were configured any longer. When I tried configuring them in Yast (console) I get the following message:


An error occurred during the installation of

6 Series/C200 Series Chipset Family High Definition Audio Controller
The kernel module snd-hda-intel for sound support
could not be loaded. This can be caused by incorrect
module parameters, including invalid IO or IRQ parameters.


Prior to the update this is what I had from aplay -l:


aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD91BXX Analog [92HD91BXX Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0:  PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI  1]
  Subdevices:  1/1
  Subdevice #0: subdevice  #0
card 0: PCH [HDA Intel PCH],  device 8: HDMI 2 [HDMI  2]
  Subdevices:  1/1
  Subdevice #0: subdevice  #0
card 1: HDMI [HDA ATI HDMI],  device 3: HDMI 0 [HDMI  0]
  Subdevices:  1/1
  Subdevice #0: subdevice #0

[LEFT]And now this is what I get:
[/LEFT]


aplay -l
aplay: device_list:268: no soundcards found...

[LEFT]
Prior to my update I also had this for modules:
[/LEFT]


cat /proc/asound/modules

 0 snd_usb_audio
 1 snd_hda_intel
 2 snd_hda_intel

[LEFT]Now I have:
[/LEFT]


cat /proc/asound/modules

 0 snd_hda_intel
 1 snd_hda_intel


[LEFT]
And finally to list my modules:
[/LEFT]



  lsmod | grep snd

snd_hda_codec_idt      61440  1
snd_hda_codec_generic    81920  1 snd_hda_codec_idt
snd_hda_codec_hdmi     53248  2
snd_hda_intel          40960  -1
snd_hda_codec         147456  4 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           90112  5 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               135168  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer              36864  1 snd_pcm
snd                    90112  8 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              16384  1 snd

So it seems like module snd_usb_audio is now gone and snd_hda_intel has a value of -1; although I’m not sure if that’s significant. When I looked into /var/log/zypp/history I noticed this got an update and suspect it’s the culprit. (esound-daemon|0.2.41-29.5). Anyone have any idea of what my next steps are?

Thanks.

Had the same exact issue after the specific upgrade today. It recovered after 2-3 reboots but I think the upgrade has produced multiple issues and this one was one of them. I’m experiencing very unstable behavior on KDE plasma, chrome is not starting and I even get the following on console when I try to “su”:

stratos@teras:~> su
Password: 
su: cannot create child process: Resource temporarily unavailable
bash: fork: retry: No child processes
bash: fork: retry: No child processes
bash: fork: retry: No child processes
bash: fork: retry: No child processes
bash: fork: retry: No child processes

Automounting of external disks (configured on KDE settings) is broken also and even a usb flash, when inserted says “you don’t have permission to mount”. Everything appeared after the latest upgrade so I think it is a generic fault somewhere in the system.

Privilege escalation also doesn’t work for me. I try to run yast and it doesn’t accept my root pass, although I type the same on console and it works. Something is broken badly after the latest upgrade.

I’m having problems with audio, too. Also it fails when I try to run the Software Updater >:(

Several users are reporting issues after the latest upgrade. Some say that they have resolved it by running the following as root:

pam-config --add --systemd 

It seems that is has fixed some of my issues at least. Try to see if it fixes the sound problem. Reboot after executing the command.

The pam-config command fixed these issues for me. Thanks!

I had the same problem with sound. Also could not mount any devices through plasma/dolphin, returned error message “unspecified error, not authorized to mount this device”, but mounting via console works. The /run/media directory has disappeared.

Also could not launch yast through plasma, but works launching via console.

All these now work as expected for me.

Yes, all those issues were due the latest Tumbleweed upgrade, there is a message on Factory mailing list that confirms the issue and the fix. Also an updated package will pass with the next upgrade.

Thanks for the fix. I’m new to this distro and I’m still finding my way around and I felt a little disappointed for having problems just a few days in but it’s reassuring to have people in the know to take the time to answer with a solution so quickly :wink:

Thanks for the update. I haven’t tried this fix yet. Do you happen to have the link to the mailing list posts regarding this issue?

Here is the link to the Factory mailing list announcement

https://lists.opensuse.org/opensuse-factory/2016-06/msg00113.html

Thanks. After performing the command things seem mostly fine. Except for ncmpcpp which now can not connect to mpd. I get a timeout message when trying to connect to mpd. Not sure what the issue is? I’ve tried uninstalling and reinstalling with no success. It could be related to networking but not sure.

The fix for my mpd + ncmpcpp problem involved creating file asound.conf in directory /etc to set the default sound card & device. I don’t recall if I had the file prior to the update.


card 1: PCH [HDA Intel PCH], device 0: 92HD91BXX Analog [92HD91BXX Analog]

In my case I wanted to use card 1 device 0 as my default. So I added the lines below.


defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1