sound gone after 11.1 upgrade

I upgraded to 11.1 from 102 and afterwards the sound has gone. I have worked thru the trouble shooting guide to no avail and checked the bug ref’d in it.

My config is:

HDA-Intel – HDA Intel
HAD Intel at 0xf0640000 irq 22

Alsa 1.0.17
Snd_hda_intel 0xf064000 irq 22

New kernel (pae)

Bug 485734 - intel-hda: snd_pcm_avail() overflows
This is the bug ref’d to look at but no clue there.

I have checked mixers and settings in yast and tested as said in guide.

Any ideas - and be kind not vg at linux so idiot level required.

Try working your way thru the audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

If you decide to update alsa, there is guidance here:
Alsa-update - openSUSE
If you decide to update via that guide, note you must send 6 zypper commands. You have to chose the ones specific to your openSUSE version, and for the last 3 specific to your kernel version.

Note also after sending the 6 zypper commands (with pc connected to internet) you need to reboot afterward to test.

As on initial post I have been thru the tshoot guide still not working. I have tried the alsa guide for my kernel
using cmd
zypper ar http://download.opensuse.orh/repositories/multimedia/audio/KMP/openSUSE 11.1 multimedia

this rtnd
too many arguments.
addrepo (ar) [options] <URL> <alias>
addrepo (ar) [options] <FILE.repo>

what should I do now?

What you should do is simply copy and paste the line, because by retyping it you introduced syntax errors. Or alternatively read up on the zypper command, so you can learn how it works and what its syntax is, as it is useful to understand that command.

Here - I’ll copy and paste for you - the lines should look like this (although I am guessing at the second command, because I do not know what alsa apps you have installed):

zypper ar multimedia
zypper install alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then restart your pc and test your audio.

You can check, before sending the above, what alsa versions you have, by typing:

rpm -qa | grep alsa

You can learn more about zypper by going here:
Zypper/Usage/11.1 - openSUSE

I was also having trouble with Intel HDA (Dell Latitude D620) in 11.1, this guide did the trick if updating alsa doesn’t work.
SDB:Intel-HDA sound problems - openSUSE

OK found the syntax error missing underscore
got thru the zypper commands the alsa status is:
Alsa-l 8.18-8.7

Still no sound.

tried the link for hda but stuck on how to install the kernel-source - don’t know how to do this.

unsure of way forward please assist.

why are you trying to install kernel-source? Thats not needed for sound when you already have the most current alsa installed, which you may have.

I did not see any mention of alsa-driver-kmp-pae in your previous post. Did it install correctly? If it did not your sound will not work.

I have been having a similar problem after upgrading to 11.1/KDE. The instructions provided at SDB:AudioTroubleshooting work and I get sound running just fine.

Problem is that upon reboot sound goes away again. When I reboot I get a message about Phonon and resetting to default–no options–its just a message.

The kernel source was a tip from stephen 123 on the thread.

The kmp-pae was installed OK with the other zypper cmds, so unsure what now?

For us to attempt an answer that, we need you to run the diagnostic script again. We can’t see your PC. We can’t see over your shoulder. So clearly you have to make up for that by providing the information via means such as the script.

So, what is the output URL provided after running in a terminal/konsole (with your pc connected to the internet):

Uh, unsure here i run the cmd but it rtns nothing, i checked in sbin and the file reads size 0 - something amiss?

That should not be. The file is 24.1KB in size.

How confident are you that you had a good install ?

You can also run the script by copying and pasting the following into a terminal or konsole when your PC is connected to the internet:

wget -O && bash

then paste the output URL here. Just the URL.

But frankly, if you get 0 KB for, then either you made a mistake, or you completely messed up something on your system. Perhaps you removed something you should not have. Perhaps you installed something you should not have. Because that (0 KB) for should NOT be. In which case, I may not be able to help you dependent on how bad you messed things up. I hope thats not the case.

the wget cmd came back
wget: invalid option – ‘0’
Usgae: wget [option] …


Copy and paste the line. Don’t retype it. I believe you are making syntax errors by trying to retype.

unsure how to do the cut and paste i have a netbook with no mouse by the way pls advise

No mouse? … Then you need to retype carefully. Don’t get a zero confused with an alphabetical “O” and visa versa.

OK it was an O not an 0 and here is the url:

hope this helps

It clearifies a few things. You are new to Linux? Yes? No? Its difficult to know what level to reply, without knowing your Linux familiarity.

The first thing I note is this:

I believe you read the troubleshooting guide, but clearly you had problems following it, as your PC’s configuration does NOT match what it should be had you followed my post (re the zypper commands) and followed the troubleshooting guide.

I note this:

You are mixing your lower case “L”, “I” with a “one” . You can NOT do that in Linux. OK ?

Clearly, you are missing alsa-driver-kmp-pae which was to have been installed as part of the six zypper commands I provided you. You need to be more careful if you can not copy and paste.

Your sound will NOT work after having started the zypper update, UNLESS you install that rpm. So send those six zypper commands again, and this time BE MORE CAREFUL. You need to have have PC on the Internet in order for those six zypper commands to work. You to install the rpms that I indicated in those six zypper commands in order for your sound to work

Then you need to reboot, in order for your sound to work.

And, if after that, and ONLY that installation was successful, can you then consider other troubleshooting measures, ALL in accordance with the troubleshooting guide, which you stated you followed, but clearly were not able to as clearly the results from the script indicate you did NOT complete the troubleshooting guide.

I note your PC has an ALC269, and if after following my advice above does not work, we can look at making a custom edit to your PC’s /etc/modprobe.d/sound file, to force the sound to a specific model configuration, were we will need to obtain guidance from the HD-Audio-Models.txt file (per the troubleshooting guide) which notes this for the ALC269:

  basic		Basic preset
  quanta	Quanta FL1
  eeepc-p703	ASUS Eeepc P703 P900A
  eeepc-p901	ASUS Eeepc P901 S101
  fujitsu	FSC Amilo
  auto		auto-config reading BIOS (default)

If you get this far, then post and advise, (and list the alsa rpms you have installed as I want to ensure you have the required alsa-driver-kmp-pae) and then I can provide clarification to the troubleshooting guide as to how you can apply the ALC269 model options to your PC’s /etc/modprobe.d/sound file.

My replies may be very slow and intermittent, as I am currently on vacation in a different continent, and my internet access is very limited and intermittent while on vacation (not to mention my time is very limited for this sort of activity).

OK some progress I think I have captured a summary of the all the outputs:

I ran the syppers again attached to the web:
Adding with cut and paste (now figured out)

1.added repository multimedia
2.error building cache repository cannot be determined, disabling 11.1, retrieving packman rep metadata, building rep packman, building rep multimedia cache, retrieve 11.1 update, building 11.1 update cache, loading rep data, reading installed packages, already installed alsa-utils, alsa-tools, alsa-firmware, alsa-oss, alsa-plugins, alsa-plugins pulse, resolving deps, nothing to do
3.removing rep multimedia, rep multimedia removed.
4.Adding rep multimedia, enabled – yes, autorefresh no, url to 11.1 update is listed
5.error building cache, 11.1 update repository cannot be determined, disabling rep 11.1, building multimedia cache, loading rep data, reading installed packages, resolving package deps, the following driver is going to be upgraded, alsa-driver-kmp-pae, continue YES/no – input y, retrieving…done
6.removing rep multimedia

No sound on test

after the grep alsa

onto troubleshooting guide
The sound option in YAST yielded no sound on test and on adjusting the mixers no sound on that test BUT after

speaker-test -Dplug:front -c2 -l5 -twav
it gave some faint sound, I then checked a vid clip and it was giving sound faintly – although the clip vol was 9 and the mixer set to 95% but sound there was. So no sound on YAST tests but some in real clips.

Appreciate the hols time offered.

Its “zypper”. Not “syppers”.

That looks a bit better.

This is not unusual. YaST has a known bug that its test does not work with all sound cards.

Its possible you are missing some setting in the mixer.

Go to YaST > Hardware > Sound > Other > Volume and move the volume for BOTH “master” and “PCM” up to 95%. Then close YaST. Then open your mixer (alsamixer in gnome ; kmix in kde) and move up both “master” and “PCM” volume to a good volume level.

Use the sound tests (all 3 !! ) from the audio troubleshooting guide. One of them should work.