Sound goes very distorted.

Can get it back by changing output in SOUNDPREFERENCES>HARDWARE>INTERNALAUDIO>PROFILE from Analogue Stereo to another type. Works for a while then goes again. Changing to another profile will then get it working again. Doesn’t seem to matter which one you change it to as long as you change it!
Think changing the device is resetting Pulse-Audio to get it back…

SUSE11.3
Kernel 2.6.34.7-0.3-desktop
ALSA 1.0.22.1
snd_hda_intel
SB HDA-Intel - HDA ATI SB
HDA Intel - HDA NViia - Disabled in YAST

Is the Graphics card sound grabbing Pulse Audio and if so, how do I stop it?