Sound everywhere but Firefox

Title describes it pretty well. Other users get sound in Firefox, sound works in SUSE in general, but my Firefox refuses to play sound. It has before randomly, but I can’t consistently get it to do that, nor can I find any pattern in what I did when it did work with sound.

  • openSUSE 11.0
  • KDE 3.5.9
  • Firefox 3.0.3 Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/2008092700 SUSE/3.0.3-2.2 Firefox/3.0.3)
  • Sound System is using Advanced Linux Sound Architecture
  • Sound works everywhere else but Firefox
  • The command that the Firefox Icon on the desktop says it’s running is “aoss firefox” (added the aoss before I reinstalled SUSE a little bit ago, someone else said that’d make it work then and it did, sound hasn’t worked since the reinstall though)

If someone knows what this problem is that would help a lot. Like I said, it works everywhere else, the other users using Firefox get sound from it, I don’t, but I get sound from everything else.

On openSUSE-11.0 (and 10.3 and 10.2) I typically install flash-player and mplayerplug-in (together with MPlayer). That ensures most multimedia sites work with my firefox.

Already had Flash and MPlayer, getting the Plugin though if those are all required why did it work on everyone else’s but mine?

(by the way, since I first posted, up to now, twice the sound has randomly worked on Firefox after I left my computer on and sitting around for a while)
Restarted the computer after getting all that to be absolutely sure, and there’s still no Firefox sound. It’s weird, my account being the first one created you’d think I’d have sound and others might have problems, but it’s everyone else but me that gets these issues. Hopefully someone knows a fix soon.

If sound does not work then you have something misconfigured.

Do you get sound reliably from a simple sound test? A basic command line to test your audio is to open an xterm/konsole and copy and paste:
speaker-test -c2 -Ddefault -twav
Note GNU/Linux is case sensitive

What web site is giving you problems with audio?

Hi G_Warrior107!

Do you still have your problem or had oldcpu solved it?

I have/had an simular problem.
But my mozilla firefox (in openSuse 11.0 and gnome) could make sounds out of flash and my computer has run the sound test (till I could not stand it any longer telling: right speaker, left speaker,…) so I think I have done something wrong with the bindings / file associations and the plugins in firefox.

I will now run the plugin trouble-shooting as descibed in
Troubleshooting plugins
and tell you more.

By the way:
Does anyone know how to chose manually a special plugin or a special programm to open xy-files in mozilla firefox with openSuse?
For example if I want .ogg or .mp3 files played on Aktuelle Nachrichten - Inland Ausland Wirtschaft Kultur Sport - ARD Tagesschau and other sides with banshee: Do I have to choose “/usr/lib/banshee/banshee.exe” or “/usr/lib/banshee/” or “/usr/lib/browser-plugins/”?

Where can I read more about the general way of progams handling multimedia files (.avi, .ogg, .mp3, .rm ect.) in linux openSuse?


Still getting problems, that test thing worked perfectly fine. The problem is I don’t get audio when I do anything with Firefox, the main thing I’m noticing being YouTube but there are a couple other small things every now and then that also don’t produce sound.

Also, I noticed after a little bit that Kaffeine also doesn’t produce sound, which is annoying because I like that one and prefer to use it if it’s an available choice.

By the way, sorry I haven’t responded in so long, I’ve had a project for the past little while that involved staying after school an extra couple hours every day for a little bit so I haven’t been able to check back and tell people if anything was working.

VLC plays sound just fine, which is weird because I think it’s the only thing I have that does, but really what I’d like is sound working in YouTube on Firefox (I don’t think it works in anything else either, but I prefer fixing it in Firefox because that’s what I’m going to be using anyway) and since I’ve noticed, fixing Kaffeine would be nice too. It plays videos just fine so far as I can tell, just not the audio with it.

Oh, hey, I noticed when my brother started using the computer that his sound worked perfectly fine, and so it occurred to me that perhaps somewhere there’s some sort of restriction (weird it wouldn’t apply to his “made after mine” account, but still) so I’ve gone and made sure I was part of the Audio Group in the Users thing, are there any other things to check that might be related to some users getting access to things that others aren’t?

Is there any way to just let everything have permission to use sound? That seems like it would be very nice.

When you sound does not work in firefox, check to see if some other application has the sound device. Copy and paste this to a gnome-terminal or to a konsole (and it will tell you what application is using the sound):lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
You can also type:ps -A to see if firefox is still running from his boot (using the sound driver).

Note Linux is case sensitive.

I had a similar problem, no sound in flash in firefox or opera. But had sound in mplayer and amarock. I uninstalled pulseaudio and all of it’s libs and let yast install esound in it’s stead.
Now everything works.

You can try pugin for firefox or reinstall it.

Hi, I removed the pullin-flash-plugin package and it works now.

For what it is worth. I had this problem visited upon me. Everything regarding sound worked on my bog-standard laptop (SuSE 11.1, KDE4, latest RealPlayer and Flash stuff, and Firefox 3.0.11), with the exception of Firefox.

This was particularly annoying as I am addicted to BBC iPlayer (especially during the cricket season). Following the advice in this forum, I added the Mozilla repo (URL: Index of /repositories/mozilla/openSUSE_11.1).

Dead easy to do in YaST, click on Software|software repositories|add|click on community repositories and then click next. Doddle!. I added this repo, then refreshed everything in blue and everything to do with swf… (shock wave flash from memory) and real… and then re-booted (which may not have had any effect to be honest). This was not from some Windoze hang-up but I was also amending my GRUB settings. AND IT WORKED and still WORKS!!! Shame England have been knocked out of the Twenty20 or I’d still be listening.

Hope this helps. The fluendo stuff made not one jot of difference so this leads me to assume that the Mozilla repo did the trick. But I could be wrong!

I’ve heard Flash uses alsa-oss emulation and that disabling oss did the work. I actually found it in Arch forum but can’t say if it is true since i never had problems with sound in Firefox and flash:)

Me again. Imagine my embarrassment on powering up today and the sound not working. So I realised it was only Firefox that was misbehaving so in Tools | Add-ons I saw two versions of Shockwave Flash. Disabling version 9.0r999 did the trick. Maybe this is all that is needed after adding in the appropriate repo’s.