Sound driver for Realtek 850???

I just installed openSUSE 11.1 64bit version. Everything works fine except the sound. The system seems to be unable to find a driver for the chip.
I’m using a 939Dual-SATA2 Mainboard with an Realtek 850 7.1channel AC’97 audio codec:
ASRock Motherboard - Product - 939Dual-SATA2 - Overview
I searched a bit but an found this:
Realtek ALC850 -
So I looked for the Nvidea Soundstorm drivers. On the Nvidea page they tell me to use the Intel drivers:
Linux nForce Drivers
but the system won’t exept them.
I tried your troubleshooting page also…
I installed alsa:

linux-vq8m:/home/ava # rpm -q alsa alsa-utils alsa-firmware

but still (after reboot) the two soundchecks don’t work:

linux-vq8m:/home/ava #  speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,Datei oder Verzeichnis nicht gefunden

I tried YAST and alsaconf (using gnome) but none found a sound card.
I used the alsa-info skript and got:

Please help I don’t know what to do… :frowning:

The script suggests there is something wrong with your installed rpms.

Please run the following in a terminal or konsole and post here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

thank you for your fast replies

linux-vq8m:/home/ava # rpm -qa | grep alsa
linux-vq8m:/home/ava # rpm -qa | grep pulse
linux-vq8m:/home/ava # rpm -q libasound2
linux-vq8m:/home/ava # uname -a
Linux linux-vq8m #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux
linux-vq8m:/home/ava # cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: Datei oder Verzeichnis nicht gefunden

meaning “File not found”

Strange. That looks ok.

Maybe your dmesg will give a hint … Can you reboot and with your PC connected to the internet, copy and paste the following into a gnome terminal or a kde konsole:
dmesg > dmesg.txt && curl -F file=@dmesg.txt will post your dmesg content to a paste site and give you a URL. Post just the URL here: In the dmesg I typically look for the key word “alsa” or “snd” or “hda” …

If that does not work, then I think you may need to update alsa to 1.0.19 in the hope that might help. That is possible by opening a terminal or konsole, and then type “su” (no quotes - enter root password when prompted) and then with your PC connected to the internet paste the following 6 zypper commands, one at a time, running them in sequence, in to that same terminal / konsole:

zypper ar multimedia
zypper install alsa alsa-oss alsa-oss-32bit alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then reboot and test your sound

dmesg.txt - (beta)

the update changed nothing… still:

ava@linux-vq8m:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.19

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
ALSA lib pcm_pulse.c:626:(pulse_prepare) PulseAudio: Unable to create stream: Verbindung beendet

Unable to set hw params for playback: Eingabe-/Ausgabefehler
Setting of hwparams failed: Eingabe-/Ausgabefehler

but this seems logic since there is still no sound card detected.So what device should play the sound? Maybe someone know where to get these “nvidea Soundstorm” drivers from.They worked for the guy in Realtek ALC850 - but I don’t find them on the Nvidea page.
Thank you very much for your help…

Check that your sound device is switched ON in your PCs BIOS.

That WAS the problem! I’m so sorry for waisting your time but I simply haven’t thought off that possibility. Thank you very much!!!

Congratulations on sorting this!

Glad to read its working now.