Sound Crashes Unexpectedly in Firefox Flash


I don’t normally post to forums asking questions because chances are someone else had the same problem as me and posted the question, or I would find a solution searching around. However, I’ve read so many different stories about sound and Flash, and Flash crashing Firefox etc., but I’ve yet to find someone with my problem. So, after this small introduction, here’s my problem:

Flash version 10.0 r45 in Firefox plays video, graphics, and sound just fine. However, while I’m playing a video on YouTube, or listening to Pandora, the sound could unexpectedly crash. When this happens, sound doesn’t just stop playing. It keeps playing but loops the sound every second or so - it’s kind of strange to describe; the sentence, “Hello, how are you?” could sound like “He-he-he-he ar-ar you-you-you”. Has anyone experienced this?

I say it happens ‘unexpectedly’ because I can’t replicate the crash on demand, but it happens in every Firefox session. It seems that it does not matter what I’m doing - I’ve tried crashing it by making a flash video full screen and exiting continuously etc. because sometimes it happens when I’m going to full screen or changing tabs. However, most of the time it happens when I’m not even touching the computer - I’m not sure if some background process can cause Flash’s buffer to overflow, or whatever. Other times, it doesn’t even need me to play anything for it to crash the sound in Flash - it could loop sound from the first time I tried playing it in flash in that FF session.

Even when I exit Firefox or pause the sound it takes a few second for the loops to stop. However, when I restart Firefox the sound is fine until it crashes again and I have to restart, again!

I tried removing libflashsupport as I read in other threads that it causes sound issues - no luck there. I uninstalled, installed and all that jazz. Tried strace - doesn’t report any flash errors for some reason, or as far as I can understand. I also installed the Flash debugger for use with the Firebug extension, Flashbug addon in Firefox, but I’m not getting anything there either - I think it can’t locate the flash debugger, although it lists the right version.

I haven’t had this problem with Chromium yet, but I mostly use it when Flash sound in Firefox crashed and I don’t want to reload FF; I think they use the same ‘’? Also, just to clarify, sound from the MPlayer plugin works fine, and when the sound crashes in Flash it does not cause FF to crash and quit. Firefox continues to run normally but when I play sound in Flash it starts looping.

I’ve had sound problems in the past and I’m thinking there is something I messed up in the packages I have installed. I uninstalled pulseaudio because it was the only way I could find to get my Skype working. How would I know if there are conflicting elements? Here’s what I get from ‘lsof | grep snd’:

firefox     956    angelos  mem       CHR      116,4                3850 /dev/snd/pcmC0D0p
firefox     956    angelos  120r      CHR      116,2        0t0     3751 /dev/snd/timer
firefox     956    angelos  122u      CHR      116,4        0t0     3850 /dev/snd/pcmC0D0p
firefox     956    angelos  123u      CHR      116,8        0t0     3874 /dev/snd/controlC0
keytouchd  4518    angelos    4u      CHR      116,8        0t0     3874 /dev/snd/controlC0
knotify4   4683    angelos   12u      CHR      116,8        0t0     3874 /dev/snd/controlC0
kmix       4690    angelos   10u      CHR      116,8        0t0     3874 /dev/snd/controlC0
keytouchd  8563    angelos    4u      CHR      116,8        0t0     3874 /dev/snd/controlC0

It seems to me like there should be a conflict between all those using the same sound control? However, why would it just happen unexpectedly?

Also, is there a way that I could dissociate sound from Firefox without having to reload a whole session with many tabs? It would be a quick fix if I could release and reassociate sound from Firefox, if there is such a thing. I hope I’m making sense here :stuck_out_tongue:

I’m sorry it seems like random information, and it’s lengthy with run-on sentences! I just wanted to give you everything I have because I can’t find what is causing the problem, other than flash itself. After so many months of just restarting FF, it doesn’t seem like an efficient workaround anymore. I would appreciate any ideas, workarounds (reloading Flash/sound without restarting FF?), or solutions you may have!

So I’ve finally come to the wise minds of the forums, seeking solutions using the power of the crowds!

Thanks for taking time to read about my problem, I’d appreciate any feedback on anything you think is causing the problem or any other help! :slight_smile:

what is keytouchd ?

When I have no sound playing, I get:

oldcpu@hal2009:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
knotify4 2876 oldcpu   12u   CHR  116,7      0t0 5540 /dev/snd/controlC0
kmix     2927 oldcpu   10u   CHR  116,7      0t0 5540 /dev/snd/controlC0

and when youtube is playing sound:

oldcpu@hal2009:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
knotify4   2876 oldcpu   12u   CHR  116,7      0t0 5540 /dev/snd/controlC0
kmix       2927 oldcpu   10u   CHR  116,7      0t0 5540 /dev/snd/controlC0
npviewer. 15519 oldcpu  mem    CHR  116,4          5501 /dev/snd/pcmC0D0p
npviewer. 15519 oldcpu   12u   CHR  116,2      0t0 5068 /dev/snd/timer
npviewer. 15519 oldcpu   13u   CHR  116,4      0t0 5501 /dev/snd/pcmC0D0p
npviewer. 15519 oldcpu   14u   CHR  116,7      0t0 5540 /dev/snd/controlC0

I don’t know. What is keytouchd?

Firefox is not the most stable of apps. My wife can get the very latest Firefox-3.6.3 to crash in a handful of seconds, at will, by sending it to some of her favourite web sites.

One can restart alsa sound driver with:

su -c 'rcalsasound restart'

followed by restarting one’s mixer (type ‘kmix’)
but I think you are looking to retain more than just a restart of the sound driver.

Thanks for the reply!

keytouch lets me map the volume buttons as well as other buttons I have on the laptop. I know it is not the best solution for mapping those buttons but I’ve had it for a very long time, while the flash sound crashes are in the recent months. I’m not sure why it is added twice, I’ll have to look into that, but since it’s been like that I would think it’s unlikely that it would suddenly cause problems.

I’ll try the command restarting alsa or kmix when it crashes again and see if it does something.

As for Firefox I’d think it would be stable after having so many revisions and versions up to 3.6.3, but I can crash my FF with any Java applet easily - so I’m guessing the plugins are not up to standards? And even installing addons can add so many variables to any FF crash.

Thanks again!

Out of curiousity, if you have not done so already, what happens when in Firefox you change Firefox > Edit > Preferences > Applications > Shockwave Flash File and select “Use Flash Player (Default)” and leave that setting in place?

Or is that what you have been using all along?

I’ve been using ‘Use Shockwave Flash (in Firefox)’, but I didn’t choose that from there - it must’ve changed during a flash update. I changed it now to ‘Use FlashPlayer (default)’ and it is playing fine, although I don’t know if the change happens after FF is restarted.

I have a feeling this may be what the problem is since I never manually changed that. I’ll let it run and see what happens!

Have you tried to unninstall nspluginwrapper? I had a similar issue awhile back, and someone at the suse IRC channel pointed me that this could be caused by some applications having installed it as a dependency even though I’m on a fully 32-bit system (this app is supposedely to make 32-bit apps be able to run on 64-bit architectures)


Thanks for the reply. Unfortunately I don’t have nspluginwrapper installed to uninstall it. The problem is not resolved by changing the Flash source in the FF settings either. Using the command to restart alsa also crashes FF as it is being used by FF. This is really a helpless situation for Flash in any platform other than windows.

There was an update today for Flash, fingers crossed it won’t happen again, but I doubt it will work fine.

Thanks again, hopefully someone has the same problem resolved. Also, zeph7r, was the problem you had with flash with the sound looping and lagging in flash as well? I asked a while back in the IRC channel but unfortunately no one could help.