Sound conflicts with wireless

Right now I either can have wireless or sound. When I get sound I lose my wireless which may be due to some kernel issue. I use the madwifi, madwifi-kmp-default, madwifi-kmp-pae, & compat-wireless-kmp-pae for my athero ar 9285. This gets my wireless going.

I followed
SDB:AudioTroubleshooting - openSUSE
and couldn’t get sound

Then I followed
Alsa-update-snapshot - openSUSE

I get sound but lose my wireless. I reinstall madwifi-kmp-pae, & compat-wireless-kmp-pae. I have to downgrade some kernel conflicts and I have wireless, but no sound.

My sound information is here

I forgot to say. With my wireless working, my sound does work with my headphones just not the laptop speakers.

the Dude abides wrote:
> I forgot to say. With my wireless working, my sound does work with my
> headphones just not the laptop speakers.

that sounds like a driver problem…

most laptop makers solve that problem by working directly with MS to
make a driver which allows MS-windows to control if the speakers get
sound, and how much, etc…

unfortunately, those same manufactures do not always (if ever) work
with Linux driver makers…

on the other hand, if you buy a laptop with Linux installed it will
generally have the drivers needed to allow sound from speakers to be
controlled via a driver which doesn’t block networking, or anything

now, trying to then install Win7, Mac OSX, OS/2 or any other system on
that laptop made with Linux compatible hardware/drivers might be just
as troublesome…


I did a fresh install with 11.2; sound works with no wireless or kernel conflicts.

Glad to read its working now. I believe the reason it did not work before was because you had openSUSE-11.1 with the kernel and your PC has the IDT 92HD75B2X5 hardware audio codec. One must update their alsa in such a case.

IMHO by updating to openSUSE-11.2, you get 1.0.21 of alsa which solved that problem.

Again, I’m glad to read its working for you now.

the Dude abides wrote:
> I did a fresh install with 11.2; sound works with no wireless or kernel
> conflicts.

good for you, but for future reference:

most often it is both unwise and unnecessary to reinstall Linux to get
a working system (unlike some other systems, where reinstall is step
one on the telephone support check-list)…

the reason is that whatever was wrong will probably just be duplicated
again…well, there is of course there is the possibility that
something you did caused the problem…

but, in either of those cases it is better in the long run to either
squash the bug which came with the program, or learn what went wrong
(and what you did, that you shouldn’t do again)…

that is, just reinstalling most often leads (in time) to the same
problem again…

likewise, the old trick of rebooting to fix problems is also not a
great idea…


At the time of the post I was running pae and changed that to default as iwfinger suggested. The main problem I encountered was the wireless card. I had a difficult time finding solutions to get it to work, and when it did work there were many more dependence issues. Since, the computer was for someone else, unfortunately I wasn’t able to be as patient as I would have liked to, so going with the newer version was the easier way out; consequently with the loss of learning good valuable lessons for next time. I’m not exactly sure what changes were different in 11.2 madwifi that enable it to work out of the box without the same dependence issues as 11.1 version, I installed? I appreciate the responses.

Are you using madwifi in 11.2 ? I think the ath5k open source driver is eventually to replace madwifi and its possible you are using that instead in 11.2 ? My wife’s PC’s wireless has an atheros chipset and it uses the ath5k with no problem for wireless access.

Next time I stop by my friends, I will look at the card info. Other than a few codec issues, I didn’t have to deal with sound or wireless, so I didn’t look at what version of drivers were being used. I was just happy, everything worked flawlessly.