sound conflict pulse and alsa// error messages

could not get my sound to operate so i followed the intructions to

Multi-media and Restricted Format Installation Guide - openSUSE Forums

now i have a working audio and video player but my sound is depreciated to an almost inaudible level

when i try to open pulse i get connection failed:connection refused

and when i try alsa gui i get function snd_ctl_open failed for default:connection refused

can anyone please correct this with me or for me. Noob wanting not to regret leaving windows .thanks

:\walk a mile in someones shoes before you critisize them

that way youll have there shoes and be a mile away

openSUSE version? KDE or Gnome, and version? Sound card/chip, make and model?

hi sorry im brand noobish it would be 11.2 and gnome it is a hti intel if im not mistaken and im not sure how to get the rest of the information. please be patient i know next to not about this step by step instructions would help

Probably because your mixer has your audio down to almost inaudible levels.

With your PC connected to the Internet and your volume control set to maximum (which you state is too low) run this diagnostic script:


and select SHARE/UPLOAD. Then post here the URL it provides. Just the URL. That will give us a better look at your audio configuration.

No worries. :slight_smile: Just follow oldcpu’s instruction - he will sort it if anyone can.

Newer version detected: 0.4.59
To view the ChangeLog, please visit Git - alsa-driver.git/history - utils/
ALSA-Info script has been downloaded as /tmp/alsa-info.Nblo9ZkFIY.
Please re-run the script from new location.

i accepted the new version this is the output unsure of how to proceed

thank you :shame:

so an update but the same issuestill seem to have no sound after rebooting and going through the same steps as proposed .i know have my gui back in the toolbar for volume but without sound

still need directions thanks

In order for the update to be applied, you need to run the script with root permissions.

Once the update is applied, just run the script again as a regular user.

I need the URL from the script output.

In addition to the output URL from running the script, please also provide output from running:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf

here the info you guys requested sorry i had to run the script a couple times for it to take hope this helps and thank you

sorry had to split the output wouldnt post the whole dump:sarcastic:

I edited your post.

What you gave was incomplete.

What you gave was also NOT what was asked for. I asked for the URL. JUST the URL.

Now please, if you can NOT get the URL, then paste the FULL output (and not just PART of the output) to a paste bin site such as New - Pastie

Your mixer indicates you have your speaker muted. Take a look at this:

Simple mixer control ‘Speaker’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Front Left: Playback 0 [0%] -64.00dB] [off]
Front Right: Playback 0 [0%] -64.00dB] [off]
As long as this is muted, you can be guaranteed there will be no sound.

subliminalfix@linux-dvnr:~> rpm -qa ‘alsa
subliminalfix@linux-dvnr:~> rpm -qa ‘pulse
subliminalfix@linux-dvnr:~> rpm -q libasound2
subliminalfix@linux-dvnr:~> uname -a
Linux linux-dvnr #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux
subliminalfix@linux-dvnr:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

5Dex.FpyRil_5h_0:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

thanks again and sorry for the confusion i ha put the link to the complete output in the bottom of the post reply after i realized my error
heres the rest i believe

thank you

Ok, thanks for that. That looks correct, and its useful information in case it becomes necessary to update the alsa sound driver.

Take a look at your “speaker” settings in your mixer. Currently they are muted (as noted above).

i see what you have found although i am unsure which interface this is become an issue i have rechecked the pulse volume and it appears correct as well the gui on the task bar appears to be active still confused thanks for your time ???

I am not a Gnome user, but clearly the speaker volume is muted. You need to move that volume setting up using the mixer that is provided by Gnome.

In KDE this is easy to do.

should i change to kde it would be of little inconvenience as all i need is to be up and running with audacity thanks again

is this an issue in installation with kde?? i can reboot if i can use a mirror to change the ??desktop??:shame:

thanks for the help a little more to fiddle with then all should be well