Sound cards disappeared

After recent upgrades all sound cards disappeared in Plasma - no sound in many applications. Using pipewire. How to fix?

Can you specify which Tumbleweed snapshot broke your settings? Because snapshot 20221105 or 20221104 did not even have anything hardware/sound/kernel related updates…
What does “many application” mean?
Do you use packman?
Did you do vendor-switch for audio/video codecs?

Browsers, audacious have sound. mpv and telegram do not, plasma do not see any sound cards, no USB camera mic as well.
I use packman, switched to it completely. Not sure which Tumbleweed snapshot broke things, I think yesterday one - 20221105: yesterday I had sound, today - not.

How is it possible that you have sound without soundcards seen by systemsettings :open_mouth:

Did you doublecheck systemsettings5 -> hardware -> audio and checked all the dropdown boxes and settings?

Maybe some informations about your system could help to pin down the problem. Some inxi output as example…

So basically saying: applications that can output directly with alsa - have sound, which needs pulse - do not. systemsettings5 -> hardware -> audio page is blank! Yast->Sound sees sound cards, no sound however there as well.

> inxi --audio
**Audio:**
  **Device-1:** AMD SBx00 Azalia **driver:** snd_hda_intel
  **Device-2:** NVIDIA GA106 High Definition Audio **driver:** snd_hda_intel
  **Device-3:** Logitech C920 PRO HD Webcam **type:** USB
    **driver:** snd-usb-audio,uvcvideo
  **Sound Server-1:** ALSA **v:** k6.0.6-1-default **running:** yes
  **Sound Server-2:** PipeWire **v:** 0.3.59 **running:** yes

What does the following command report?

wpctl status

Just in case this thread is relevant to your situation…
https://forums.opensuse.org/showthread.php/576328-Soundcard-only-quot-Dummy-Output-quot?highlight=wpctl

For some reason pipewire-pulse was not started, I did:

systemctl --user restart pipewire.service pipewire-pulse.service

Seems works fine now. Not sure if I also need to do:

systemctl --user enable --now pipewire pipewire-pulse

On restart no sound again. Trying to do the following however get an error:

> systemctl --user enable --now pipewire pipewire-pulse
Failed to enable unit: Unit file /etc/xdg/systemd/user/pipewire-pulse.service is masked.

How to fix?

Fixed like suggested here: https://www.reddit.com/r/openSUSE/comments/re5akg/comment/ho71dnu/?utm_source=share&utm_medium=web2x&context=3

> sudo systemctl --user --global unmask pipewire-pulse.socket pipewire-pulse.service
Removed "/etc/systemd/user/pipewire-pulse.socket".
Removed "/etc/systemd/user/pipewire-pulse.service".

then do

> systemctl --user enable --now pipewire pipewire-pulse

And now sound fully works!

Most sound cards are compatible with openSUSE. If your system cannot recognize sound devices, there is probably a failure in PulseAudio, the sound back-end of openSUSE. You can restart PulseAudio with the following commands.

If pulseaudio is already running:

pulseaudio -k

If pulseaudio is not running:

pulseaudio -D

You do not need to restart system. If it is pulseaudio’s problem, your sound should come back immediately :)](https://thecapcut.com/capcut-logo-png/)

Read above: I use pipewire and everything is solved already.