Sound Card Randomly drops from configuration

Since I started to use Suse 11.3, I’ve been having problems with my sound card. It starts normally and I can use it without further problems, until it randomly stops working. I don’t know what causes it to stop working, it just does. Then, if I go to YaST>Hardware>Sound (it shows I have a 82801G (ICH7 Family) High Definition Audio Controller), press edit then reset, it works again!

I’ve been doing this for like 4 months, but I’m growing tired of doing it and not being able to just sit back and enjoy music on the amarok. I don’t know what should I report, so that’s why I only say the sound card identification. Thanks in advance and I’ll be ready to provide more information n.n

As you might know by now, I’m kind of new to Linux, so please ignore the newbieness on this message…

Slightly confusing title,because really your card is detected.
Anyway… Can I hazard a guess and assume you are using kde? And that this is an on-board device?

This device dropping happened to me in kde on odd occasion.
But I also use gnome and it never happened in gnome.

A quick fix for me in kde was, in a su - terminal do

rcalsasound restart

I know about the title, stupid me, but couldn’t change it, sorry…
Yeah, KDE and on-board sound.

I’ll try your fix when it happens again (since I don’t know how to trigger it can’t try it right now).

Also I remembered I had a gnome question, but I’ll open a new topic with it.

After running:

su -c 'rcalsasound restart'

per caf4926’s suggestion, if you are asked if you want to keep some old KDE sound configuration, say NO. And then after restarting alsa in a terminal as a regular user type ‘kmix’ to restart kmix.

Note you can tell which application has seized your audio device and not sharing it (if that is happening) by typing:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

note the last entry is “/dev/snd/*” which is different from the previous.

The problem with that command is it is difficult to understand, and one has to run it many times under different conditions to finally make sence as to what it is saying. And it also tends to be specific to each PC, so posting it on a thread is typically not helpful. Its very much user PC specific.

Just tried the
su -c ‘rcalsasound restart’
and everything worked fine (yay!)

I did what oldcpu said before the restart and I got this:

lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/kirby/.gvfs
      Output information may be incomplete.
kded4   5629 kirby   24u   CHR  116,7      0t0 3976 /dev/snd/controlC0
kmix    5770 kirby   12u   CHR  116,7      0t0 3976 /dev/snd/controlC0

then after:

lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/kirby/.gvfs
      Output information may be incomplete.
chrome   6316 kirby  mem    CHR  116,4          79820 /dev/snd/pcmC0D0p
chrome   6316 kirby   32r   CHR  116,2      0t0 79817 /dev/snd/timer
chrome   6316 kirby   34r   CHR  116,4      0t0 79820 /dev/snd/pcmC0D0p
chrome   6316 kirby   35u   CHR  116,7      0t0 79823 /dev/snd/controlC0
kmix    16533  root   10u   CHR  116,7      0t0 79823 /dev/snd/controlC0
amarok  16572 kirby  mem    CHR  116,4          79820 /dev/snd/pcmC0D0p
amarok  16572 kirby   14r   CHR  116,2      0t0 79817 /dev/snd/timer
amarok  16572 kirby   15u   CHR  116,4      0t0 79820 /dev/snd/pcmC0D0p
amarok  16572 kirby   16u   CHR  116,7      0t0 79823 /dev/snd/controlC0

It looks like the application kded4 seized the audio device and refused to share it !

I don’t see see kded4 there. I note chrome browser and amarok. Are you playing sound successfully from two sources there ? That is how it appears.