Sound card microphone boost

openSUSE 13.2 64bit KDE

While trying to diagnose a Skype problem I installed a Creative Sound Blaster Audigy2 ZS SB0350 Sound Card. Microphone input level was far too low. The driver YaST installed had numerous settings but no microphone boost. Creative Sound does not provide Linux support that I could find, but in the process of searching I read that the Windoze driver provides microphone boost. Does anyone know of a Linux driver that does the same?

Thanks in advance.

The alsa audio driver provides a boost functionality for mics. Note also, one’s desktop volume control typically has a mic capture level control. Further pavucontrol provides a mic capture control on an application and device basis.

One can see the alsa settings with amixer. For sound card 0 :


amixer -c 0

for found card 1


amixer -c 1

ie specific the sound device in the amixer command.

Then look at the amixer output . For example on my PC I use my USB webcam mic for Skype (where my webcam mic is device-2) and I get :


oldcpu@oldcpuj:~> amixer -c 2
Simple mixer control 'Mic',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 52
  Mono: Capture 18 [35%] -53.00dB] [on]

Clearly - NO ALSA boost there.

But for card-1 on my PC, after typing “amixer -c 1” I note this entry:


Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

I have 0% boost which means it would be difficult capturing audio with that Mic (on card-1). But I use the card-2 mic all the time so I have no issue.
.

Thanks for the quick response. I’m confused. I need to use Pulse Audio (for Skype). When I invoke “alsamixer” it does not allow me to adjust levels and refers to Pulse Audio. “pavucontrol” does not offer a boosted mic setting. If I use amixer as you suggest will it work with Pulse Audio?

On the same topic, deano_ferrari suggested using “pactl” to configure Pulse Audio which I might try first. My major complication is that I have only one slot on my motherboard thereby making testing of two sound boards, one of which might be defective, and the onboard sound a little time consuming.

That does not sound right.

I have pulse audio enabled on my wife’s PC, my mother’s my own and some friends (all running openSUSE) and in each and every one (~10 PCs), the levels can be adjusted with alsamixer.

From what I know, pulse audio simply adds another layer of control on top of what one does with alsamixer.

Whats wrong with using pavucontrol ?
.

Of course you are correct, so I am starting from scratch. I disabled Pulse Audio in YaST. I removed all PCI sound cards and set the onboard sound card in my BIOS. It’s called MCP61. YaST recognizes it and it produces the test sound. But when I invoke “alsamixer” it reports the card is “HDA Nvidia” and of course nothing is adjustable. When I try to set the card (F6) it only shows “HDA Nvidia”.

If I start my KDE Configure Desktop>Multimedia>Audio and Video Settings>Device Preference>Audio Playback>Music all it shows is the HDA Nvidia device.

If it was not for Skype I would not use Pulse Audio. What puzzles me is what changed after months of reliable operation. All I have done is “zypper up” periodically.

my /etc/modprobe.d/50-sound.conf reads…

options snd slots=snd-hda-intel

CvwD.UmTAZydDBn2:MCP61 High Definition Audio

alias snd-card-0 snd-hda-intel

FYI - When I invoke “amixer -c 0” it does not show a “Rear Mic”, only “Front Mic”. I do not want to use the Front Mic connector.

After three unrelated reboots “amixer -c 0” now shows a “Rear Mic” and “Rear Mic Boost”. The KDE “Configure Desktop” shows the correct on-board sound card which I can boost to reasonable output levels with pavucontrol. But alsamixer still doesn’t provide any adjustments.

Is it possible that it takes more than one reboot for settings to change?

I can turn the rear mic on and off with pavucontrol when using Skype (off - to eliminate feedback from the speakers into the mic) but it would be nice to have alsamixer functional.

Multiple reboots should not be needed. Further, alsamixer should ‘just work’.

Try forcing a re-install of alsa-utils (which contains alsamixer) in case alsa-utils is corrupted.

In case you are curious how to determine that alsamixer comes with alsa-utils, I typed " whereis alsamixer" and I obtained " alsamixer: /usr/bin/alsamixer /usr/share/man/man1/alsamixer.1.gz ". Knowing that alsamixer was located in /usr/bin I then typed “rpm -qf /usr/bin/alsamixer” which gave me “alsa-utils-1.0.28-5.6.1.x86_64” (thats on an openSUSE-13.2 system - but the same will work for other openSUSE versions).

Did that. Nothing changed. alsamixer still points to a non-existent NVidia device. By the way /etc/modprobe.d/50-sound.conf shows

"options snd slots=snd-hda-intel

CvwD.UmTAZydDBn2:MCP61 High Definition Audio

alias snd-card-0 snd-hda-intel"

By the way, trying to change the device while running alsamixer (F6 option) offers nothing but HDA NVidia.

What does the following report?

arecord -l

Assuming card #0, do

amixer -c 0

What controls listed in output?

Launch alsamixer with

alsamixer -c 0

Are you sure you can’t use the right arrow to bring ‘Mic Boost’ into view.

Maybe running the diagnostic script would give us a better picture

/usr/sbin/alsa-info.sh

Share the link to the uploaded file that it generates so that others can review.

At this point I suddenly realized (and this is truly embarrassing) that what I was seeing in a reduced window… http://bayimg.com/bAiKhaAgH did not show the control bars until the window was enlarged quite a bit more. The bars pop in. So YES alsamixer is running and I should be able to turn the mic off (or reduce the volume) from a script. I still don’t understand why YaST reports it as a MCP61 High Definition Audio with a snd-hda-intel driver and alsamixer reports it as HDA NVidia. Never mind, it works.

My sincerest apologies to you and oldcpu for wasting your time. Mea culpa…mea culpa…

It happens… we’re all humans. :slight_smile: In a small window, you can scroll along using the left/right arrows.

Glad to read its working. Well done in your determination to see this through.