Sound Card Issues With openSUSE 11.1

while playing any sounds in Suse 11.1 it is choppy like every few seconds it sounds like a skip on a cd. i have a Sound Blaster Live 5.1 and it has had perfect sound in the past with other distro’s and also with earlier versions of Suse.

from what i have been readin all morning it probably has something to do with pulse audio.

all i want is my sound so is there a way to just go back to the drivers and what not that all this used to work on?

When I had problems with my sound I removed all the PulseAudio rpms from the system and everything worked great. Just using ALSA now.

there is a really easy fix to this as i was having the same problem and couldn’t figure it out.
dropped Suse went to Fedora and figured it out while messing around, so i went back to Suse 11.1
and boom it worked for Suse as well…

i prefer vim but you can use any editor that your confortable with to edit the file:


look for a line that says:

load-module module-hal-detect

add this to the end of it tsched=0 so that it looks like this in the file

load-module module-hal-detect tsched=0

that should fix your problem :slight_smile: don’t forget to rebewt the system after making those changes.
need i remind you to make a backup of any file before editing it? just to be safe.

p.s. all your doing is deactivating the supposed glitch-free setting in pulseaudio. hope this helps
meh now if i could only figure out how to get 5.1 surround working i would be set. :stuck_out_tongue:

Thanks for that. Upon reading your post, I noted this thread in the fedora project:
Features/GlitchFreeAudio - FedoraProject
… according to that page, the PulseAudio sound server has been rewritten to use timer-based audio scheduling instead of the traditional interrupt-driven approach. Timer-based scheduling may expose issues in some Alsa drivers. To turn timer-based scheduling off, one follows the recommendation you posted.

I also added that to the openSUSE audio troubleshooting guide wiki:
SDB:AudioTroubleshooting - openSUSE

How do I edit that file? I get a permission error.:\

If using kde, type:kdesu kwrite /etc/pulse/
if using gnome type:gnomesu gedit /etc/pulse/

In both cases, type root password when prompted for a password.

Incredibly fast reply! Will reboot and check if this really was my problem. Now how do I reboot?:wink:

Well, no. I am playing Rocks and Diamonds and there is this disturbance in the sound. Like playing a really hairy LP? Not really very important seeing that i love analogue.

Try going to YaST > Hardware > Sound > Other > Volume and move the PCM and Master volume controls far to the right. Then close YaST. Then go to your mixer, and lower the volume level in your Master/PCM volume and see if that helps.

Also, make certain your mic is not on.

Nope, like a fireplace. I think mic is off, In the sound-other section it was set to zero. Had some problems with sound up until now. I actually only discovered Suse because I spent two days trying to manuall install the realtek driver in Ubuntu!

The intent is in YaST > Hardware > Sound > Other > Volume is NOT to set it zero, but rather set the volume HIGH. Close YaST.

Then in the mixer set PCM/Master volume to low.

Yup! Got that, what I meant was that mic is set to zero. -Sound in “YaST > Hardware > Sound > Other > Volume” is max. -Mixer is low. -Distortion is unchanged.
No problems with music or dvd, just that game and its rather primitive yet haunting track (midi?).