Sound Blaster Z, patches found on internet search, valid?

Opensuse 42.1 – KDE

An internet search says, that linux sound x32bit works, but linux sound x64 doesn’t work.

Another reports to change the “local.rc” file. Also, the driver won’t work if you have more than one type of sound connection, motherboard audio and sound card.

I realize this thread is a little old but it looks like Linux 3.9 might be adding support for the Sound Blaster Z. According to alsa_info.sh my Sound Blaster Z uses the CA0132 codec, which accord to http://www.phoronix.com/scan.php?page=news_item&px=MTMwODM support for that DSP is getting added to 3.9.

https://bugzilla.kernel.org/show_bug.cgi?id=109191https://bugzilla.kernel.org/show_bug.cgi?id=55541

http://www.linux-hardware-guide.com/2014-08-02-creative-sound-blaster-z-ca0132-internal-sound-card-pci-expresshttps://forums.linuxmint.com/viewtopic.php?p=688382

http://bighow.org/38160220-_all_variants__Creative_Recon3D___Sound_Blaster_Z__CA0132__Support.html

Heyyo,

Since kernel 3.7 the CA0132 sound cards (Sound Blaster Recon 3D and the Sound Blaster Z) have worked properly on Linux 32bit kernel where the firmware loader works properly and says “ca0132 DOWNLOAD OK http://www.linux-hardware-guide.com/wp-includes/images/smilies/icon_smile.gif DSP IS RUNNING.”
Tested up to 3.16.2. 64bit has errors and requires using commands such as…
sudo kill ps uax |grep pulseaudio | grep -v grep | awk ‘{print $2}’ ; sudo rmmod snd-hda-intel; sleep 3; sudo modprobe snd-hda-intel

There is a way I known to get sound out of this card, I have one and tried it.

It is form here:[all variants] Creative Recon3D + Sound Blaster Z (CA0132) Support - Page 4

First of all, BEFORE turn the PC you need to plug the speaker or headphone to the front panel headphone socket.

Then open a terminal(ctrl+alt+t) and run one of the follow line of code ASAP after logining in.(Because it sometimes work, depend on luck)[enter your user password when sudo ask for it]

sudo kill ps uax |grep pulseaudio | grep -v grep | awk '{print $2}' ; sudo rmmod snd-hda-intel; sleep 3; sudo modprobe snd-hda-intel

OR

sudo kill ps uax |grep pulseaudio | grep -v grep | awk '{print $2}' ; sudo rmmod snd-hda-intel
//Then(This is not a command!)
sudo modprobe snd-hda-intel

Sometimes, you will need to run it twice.

If you encounter only one side sound out, then try alsamixer or gnome-alsamixer in terminal, check the sound level.

PS:It is really a hassle to change plug every time I change OS, so I could only stick with Windows.

https://community.linuxmint.com/hardware/view/21276

  1. Open up Terminal.
  2. sudo nano /etc/rc.local
  3. and then before the “END” at the bottom of the rc.local file? add these two lines:

rmmod snd_hda_intel
modprobe snd_hda_intel model=generic

  1. Save (CTRL O) and then exit (CTRL X)
  2. sudo reboot

The fix for 64bit kernels on Linux Mint with Kernels pre 3.16?

  1. Open up Terminal.
  2. sudo nano /etc/rc.local
  3. and then before the “END” at the bottom of the rc.local file? add these two lines:

rmmod snd_hda_intel
modprobe snd_hda_intel position_fix=1

  1. Save (CTRL O) and then exit (CTRL X)
  2. sudo reboot

And that should get it to work… if your microphone doesn’t work?

  1. Open up “Terminal”
  1. Type in “alsamixer” and hit enter
  2. Press “F6” to Select Sound Card
  1. Select “HDA Creative” and hit enter
  1. Press “F4” for Capture
  1. Use the left and right arrows to navigate the selections and use “Insert” key to enable/disable selections
  1. Select the “AMic1/DMic” and click your “Insert” key to enable it. Do the same with “AMic1/DMic Auto Detect”.
  1. If the input is quiet, select “Mic1-Boost” and click your “Insert” key to enable mic boost.

Patches:

https://bugzilla.kernel.org/attachment.cgi?id=197431&action=diff

https://github.com/voron00/linux/commit/fcbf5ba088c9bc8104f32738e356600ecfb85689

http://bighow.org/38160220-_all_variants__Creative_Recon3D___Sound_Blaster_Z__CA0132__Support.html

I have discovered a solution:
Someone noted that the 32-bit kernel plays just fine, but that the 64-bit kernel needs a special fix in /etc/rc.local. Add the following before exit0:
rmmod snd_hda_intel
modprobe snd_hda_intel position_fix=1
Reboot and it will work. Someone in the ALSA team simply needs to get this patch upstream. The sound is amazingly beautiful along with the pulseaudio equalizer. Much better than Windows.

How do these patches work? The bug reports hold a lot of info that could help.

Has anyone be able to use these patches to get sound off the analog jacks or the digital output? Even to a limited extent.

There is something called an wrapper to use windows internet drivers on linux. Can the same trick be used with the mswin ‘sound blaster z’ driver?

Thanks.

I checked a couple of the URL’s, but f.e. the last one is over a year old. Which in terms of kernel development is quite a long time. Did you already try a more recent kernel? F.e. by using the Krypton live image ?

I have opensuse leap 42.1 with the multimedia package. I have all the latest updates and done almost all sound logs, through all work in the other forum posts. I have sound working through the monitor speakers. In all that information, there are people who said they got it working by various means.

As noted in your last post in an old thread - this is really a continuation of this old thread: https://forums.opensuse.org/showthread.php/512478-sound-problem-Sound-Blaster-Z-PCIe-KDE of importance in that thread is the bug report you raised https://bugzilla.opensuse.org/show_bug.cgi?id=969239 where Takashi Iwai (an alsa sound driver developer) noted:
Actually, SoundBlaster Z is a known notorious device. There are way too many variants, and only a few of them actually work with the current upstream driver, because of the incompatible binary firmware. So, for these, you have little hope, sorry.

But for HDMI, it’s a different issue. But this is rather an issue of BIOS, I suppose. The symptom appears that BIOS advertises all three HDMI/DP ports as available although only you can see only one of them. And the order of HDMI/DP ports doesn’t follow your expectation.

That said, as long as PA works, this is no bug that it’s assigned to HDMI2. There is no connection between HDMI port enumeration in HD-audio side and i915 graphics side, as they are connected and probed in different manners.

and further, Andreas Stieger noted as a result " Interpreting as resolved - wontfix ".

I think it highly unlikely you will encounter anyone on our forum who can surpass the assessment of those two.

Having typed that, you are MOST WELCOME to try for a fix via our forum, but I think it is only fair to point out to anyone trying to help that an alsa developer notes that there is no plan to fix this in alsa nor in pulse, as this appears to be a PC BIOS issue.
.