Sound Blaster X-Fi error

Hello all,

First of all nice job on the forums. :slight_smile:
I have a little problem with my X-fi. It was working fine till my hard drive died. I had just deleted my backup with view of making a new one but hadn’t. Typical, I know :smiley:

Anyways, a new hard drive and instalation later I cannot get my X-fi to work. I noticed something worrying in Dmesg:

emupia: no version for "InterlockedIncrement" found: kernel tainted.
ctalsa: disagrees about version of symbol snd_pcm_lib_free_pages
ctalsa: Unknown symbol snd_pcm_lib_free_pages
ctalsa: disagrees about version of symbol snd_pcm_set_ops
ctalsa: Unknown symbol snd_pcm_set_ops
ctalsa: disagrees about version of symbol snd_device_new
ctalsa: Unknown symbol snd_device_new
ctalsa: disagrees about version of symbol snd_card_new
ctalsa: Unknown symbol snd_card_new
ctalsa: disagrees about version of symbol snd_pcm_hw_constraint_integer
ctalsa: Unknown symbol snd_pcm_hw_constraint_integer
ctalsa: disagrees about version of symbol snd_pcm_lib_preallocate_free_for_all
ctalsa: Unknown symbol snd_pcm_lib_preallocate_free_for_all
ctalsa: disagrees about version of symbol snd_pcm_lib_ioctl
ctalsa: Unknown symbol snd_pcm_lib_ioctl
ctalsa: disagrees about version of symbol snd_pcm_lib_malloc_pages
ctalsa: Unknown symbol snd_pcm_lib_malloc_pages
ctalsa: disagrees about version of symbol snd_pcm_lib_preallocate_pages_for_all
ctalsa: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
ctalsa: disagrees about version of symbol snd_ctl_remove
ctalsa: Unknown symbol snd_ctl_remove
ctalsa: disagrees about version of symbol snd_card_free
ctalsa: Unknown symbol snd_card_free
ctalsa: disagrees about version of symbol snd_ctl_free_one
ctalsa: Unknown symbol snd_ctl_free_one
ctalsa: disagrees about version of symbol snd_pcm_hw_constraint_minmax
ctalsa: Unknown symbol snd_pcm_hw_constraint_minmax
ctalsa: disagrees about version of symbol snd_ctl_add
ctalsa: Unknown symbol snd_ctl_add
ctalsa: disagrees about version of symbol snd_pcm_new
ctalsa: Unknown symbol snd_pcm_new
ctalsa: disagrees about version of symbol snd_pcm_period_elapsed
ctalsa: Unknown symbol snd_pcm_period_elapsed
ctalsa: disagrees about version of symbol snd_card_register
ctalsa: Unknown symbol snd_card_register
ctalsa: disagrees about version of symbol snd_ctl_new1
ctalsa: Unknown symbol snd_ctl_new1

The Tainted Kernel bit in the first line worries me. Do I need to reinstall my kernel?
I think I have all the Alsa things and the driver compiled fine.


Can anyone just give me advice before I do something wrong to my kernel? Thanks

Re-install your kernel? Heck no, I would not.

You confused me here … did you do a custom compile? If so, which of the alsa apps did you compile? Or did you install from rpms, and that word “compiled” was a typo.

Is that the output of an "rpm -q… " command?

Again, I would not mess with your kernel.

We need some more information :slight_smile: … what openSUSE version were you using before the crash? What openSUSE version are you using now? If using 11.0RC1, a number of users have had issues with “pulseaudio”.

Anyway in an effort to make this easier to figure out, could you please run the two diagnostic scripts noted in the opensuse audio troubleshooting guide, and paste here the URL(s) that those scripts will produce:

also, provide the output of:
uname -a
rpm -q libasound2
cat /etc/modprobe.d/sound

Thanks for the reply. Was hoping you would reply since your advice is usually excellent :slight_smile:

I should have provided more info so here goes:

The drivers are the standard ones and no I did not compile them as such. The word ‘Install’ should have been use. The Alsa list is indeed the output of a ‘rpm -q’ command.

I have 10.3 with the kernel.

The following is the output of the talsa script since the other one did not give me a URL for the info. I could not print out or paste the result of it.

No Paste URL

Uname gives me:

Linux Dexter #1 SMP 2008/02/10 20:01:04 UTC x86_64 x86_64 x86_64 GNU/Linux

rpm -q libasound2:


cat /etc/modprobe.d/sound:

cat: /etc/modprobe.d/sound: No such file or directory

On my last install there was no sound file either so I’m not to worried bout that. I hope this helps. Let me know if you need anything else. Thanks for the help!

Also forgot to mention that when I start ctsound (the process that starts the driver) this is what I get:

Starting ctsound: Loading X-Fi Drv - Please Wait...FATAL: Error inserting ctalsa (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)

Hope this helps. :slight_smile:

What happens you restart your alsa with: rcalsasound restart

That is a puzzle, … you have no sound file, but you say your sound worked before?

I’ve observed on the forums, that the X-Fi is tricky to get working. … For example on this site of Linux incompatibilities, the PCI version of the X-Fi is deemed incompatible: Linux Incompatibility List - Audio

On the alsa web site it also states the X-Fi is not supported:
Matrix:Vendor-Creative Labs - AlsaProject

I supppose you could try adding a .asoundrc file for your device under /home/username/.asoundrc. Some same files are here:

for example:

# usb.default begins ###
pcm.!default {
type hw
card 0
ctl.!default {
type hw
card 0
# usb.default ends ### 

although for that to work, I would have guessed you need a /etc/modprobe.d/sound file. Hence I don’t think it will work.

Are you certain you were using alsa drivers before? Any chance you loaded the OSS driver, and you forgot?

I did some research in the whole error inserting module thing. Didn’t come up with much so I decided to reinstall SUSE. I had only just installed it anyways so I did not loose much. When I was back up and running I compiled the driver straight away and it worked. I then did the 1-click install for my Nvidia card and noticed it installed a new kernel. And, my sound stopped working. A reinstall of the drivers resulted in the same error.

So, I started again. This time I installed all my online repositories, including Nvidia. I ran a online update to get the latest files (including the kernel and Nvidia driver). After all this was done I installed the creative drivers and sound worked after my reboot.

Dexter# cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: No such file or directory

As you can see I have sound but no sound file. I also do not have a sound card visible in the Yast - Hardware - Sound section.

This is how it was before my other drive died. I am not doing a backup which I WILL save so I will not have to do this again.

Thanks for the help and I hope Creative do a proper job on their drivers soon. But I am not holding my breath :slight_smile:

Please, what driver was this? The OSS driver? or the alsa driver.

I note there are openSUSE rpms for alsa 1.0.17RC2 for openSUSE-11.0.