Sound Blaster Audigy & SUSE 10.1

I am a newbie and have just installed this version of SUSE and everything went fine (i.e. all hardware was detected and drivers loaded) However when i try to play a file it seems as if it is playing but no sound. I have checked to make sure nothing is muted so it’s not that. I have also added my username to the audio group. I want to try to change the driver but dont know how. The one being used is for SoundBlaster Live not audigy. It is using snd-emu10k1
and i want to try snd-emu10k2. Do you think this would work and how do I do it?

Thanks,
Bill

Do you mean openSUSE-10.1 ? or SLED ? or SLES?

If openSUSE-10.1, I do not recommend you do not waste your time on it. All subsequent releases were significantly superior to 10.1, especially in areas of software package management.

You can download for free the latest openSUSE-11.1, which is significantly superior to openSUSE 10.1 in most ways. Software.openSUSE.org

Thanks for the reply. I am very new and I’ve installed many distros and this is the only one that seems to work. I can hear the speakers pop when I reboot so I know it is something simple but I cant find it.

One more thing…you said "All subsequent releases were significantly superior to 10.1, especially in areas of software package management. " Can you tell me how this could resolve my issue?

Please answer my question. Do have have openSUSE-10.1 ? or some 10.x version of SLED or SLES ?

openSUSE comes basically crippled for multimedia as packaged due to the fact openSUSE follows a free software philosophy (ie no proprietary codecs). To install non-crippled applications and codecs means one needs to install software. To install software means one needs a good software package manager. The one that came with openSUSE-10.1 was not very good.

So, are you using openSUSE-10.1 or SLED/SLES-10.x ?? There is a difference.

I’m sorry, yes it is opensuse 10.1 and thanks for helping

I recommend you do not waste your time on openSUSE-10.1.

It is no longer supported by Novell. It is no longer supported by Packman 3rd party packagers.

Its no longer supported on web pin search engine. http://packages.opensuse-community.org/

Its simply not supported.

You will waste a large amount of time trying to configure it, when it will be significantly quicker to take the time now to download 11.1 and install 11.1, which will configure SIGNIFICANTLY faster.

I recommend you download and install 11.1. You can find it here:
Software.openSUSE.org

If you prefer to download a CD, instead of the DVD, you could also try out the latest openSUSE-11.1 KDE-4.3 Live CD from here: “KDE Four Live” CD](http://home.kde.org/~binner/kde-four-live/)

Also when I hover my mouse over the speaker icon in my tray it only tells me the mic sound level…does that help?

Honestly, this is a waste of time.

There is a troubleshooting guide for audio : SDB:AudioTroubleshooting - openSUSE

… but again, I recommend you STOP now, and start make preparations to install 11.1.

Thanks I’m downloading it now, but what if I have the same problem? I went through the guides you created and they were great thanks for helping!!!

If you have the same problem there will be many people who can help you with 11.1. But with 10.1 it will be difficult to get help.

I tried then installed the live CD and when I booted the screen was black. As I said i earlier posts 10.1 was the only one that would boot and update and boot again. I am now DL 10.3 and will try that. I really dont want to go back to Windows.

I have success installing recent versions (I’m up to 11.2M5 actually) by doing a net install. Once you have 10.3 running, you can get to 11.1 via a net install. Perhaps zypper dup will work also. But you need better expertise than mine to confirm that for you.

This is typically easy to fix.

If you have 2 PCs, I recommend you go back to this state.

Typically, in such a case, the FIX is to boot to a text log in (run level 3) and run a command to configure one’s graphics with a basic vesa driver. Then after that is done, one can later install a higher performance driver.

Also, do NOT use an RW CD for this, as those are notorious for introducing record/playback problems with an OS. Use a -R or +R.

To fix the “black screen”, then boot the PC with Linux installed, and when the green menu (giving you a boot selection) appears, type “3” (no quotes) and that will appear in the options line. That will direct the boot to run level 3 (an ascii/text log in).

Log in as the regular user you set up. Type the password.

Then type “su” (no quotes - enter the root password).

Then type:
sax2 -p
and post here the output. That will tell us what graphic device(s) your PC has.

then try to install a vesa driver. Assuming only 1 graphic device, type:
sax2 -r -m 0=vesa
(thats zero equals vesa). Give it some time to configure your graphics.

Note if your PC has two graphic devices, instead that might be: “sax2 -r -m 1=vesa”.

If that completes successfully, type:
shutdown -r now
to reboot. … do not press “3” when rebooting

You can also shutdown completely with ‘shutdown -h now’

Here is what it says in 10.3 which is working.

Chip: 0 is -> VESA Framebuffer Graphics 01:00:0 0x1002 0x4242 AGP fbdev

This suggests to me you are using the vesa driver on some AGP card. I don’t know what manufacturer based on that. But it also suggests to me on 11.1, if you had run:

sax2 -r -m 0=vesa

as I described above, it should have worked.

I’m sorry for not knowing what you all need to help me. It is a ATI Radeon 8500DV. What other information do you need and I will get it. Again, thanks SOOOOO much for the help!!! I’m using opensuse 10.1 still with no sound and I am dual booting winxp pro (suse is on its own physical drive) I really want to get rid of windows but am frustrated

I guess the important thing here, is I am not going to waste your time nor my time trying to support openSUSE-10.1. While its possible to get sound working on that, given you just installed it, I do not believe there is anything to be gained by using it, as I am confident openSUSE-11.1 can be made to work.

openSUSE-10.1 is not supported by anyone, and by trying to use it, you will miss out of most of what could be a good Linux experience.

Please read post#15 above. Maybe print it out. Then re-install openSUSE-11.1. When you get to the part where you rebooted and the screen was black then restart the PC, and in the green boot menu, type “3” (per the instructions in post #15).

In post#15 I recommended you type:
sax2 -r -m 0=vesa
and that should work.

Alternatively you could type:
sax2 -r -m 0=radeon
and that also should work.

Again, follow the instructions in post#15

I really dont want to be a pain in the butt, Here’s where I am. The KDE Live cd works when running from my cd player as far as i can see it but still no sound. I installed the KDE Live cd last night and that is when the screen went black. What do you recommend I do?