sound at the front port and HDMI

Howdy,

I have an ASUS M4A78T-E Motherboard on my laptoprunning openSUSE 12.2
and KDE 4.9.2.

According to the motherboard specs, my embedded audio on this board is:


VIA VT1708S 8-channel High Definition Audio CODEC

My soundcard information is listed as the following:


tribaltrekker:/home/george # hwinfo --sound
22: PCI 14.2: 0403 Audio device
[Created at pci.319]
Unique ID: 5Dex.WnV4s1RcOt2
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "ATI SBx00 Azalia (Intel HDA)"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x4383 "SBx00 Azalia (Intel HDA)"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x8357
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfbbf4000-0xfbbf7fff (rw,non-prefetchable)
IRQ: 16 (39020 events)
Module Alias: "pci:v00001002d00004383sv00001043sd00008357bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown

32: PCI 105.1: 0403 Audio device
[Created at pci.319]
Unique ID: l4dC.vfAxXUx5zd4
Parent ID: vSkL.2yY_xudKZ6E
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.1
SysFS BusID: 0000:01:05.1
Hardware Class: sound
Model: "ATI RS780 Azalia controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x960f "RS780 Azalia controller"
SubVendor: pci 0x1002 "ATI Technologies Inc"
SubDevice: pci 0x960f
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfbdfc000-0xfbdfffff (rw,non-prefetchable)
IRQ: 19 (58532 events)
Module Alias: "pci:v00001002d0000960Fsv00001002sd0000960Fbc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

So I have these 2 audio devices on my board, the “ATI SBx00 Azalia
(Intel HDA)”, and the “RS780 Azalia controller.”

When I go to configure sound in the KDE multimedia configuration modules
by going to System Settings → Multimedia → Phonon, there are 2 audio
playback devices listed in the preferences list:


Internal Audio Analog Stereo
RS780 HDMI Audio [Radion HD  3000-3300 Series] Digital Stereo (HDMI)

Those are also the 2 sound cards listed under the “Audio Hardware Setup”
tab of Phonon under system settings.

Gstreamer is listed as the only backend available.

I have 2 problems.

  1. There is no sound at the audio jack on the front of my desktop, even
    though I have checked that the connections for the front connectors are
    all correct to the motherboard.

  2. When I connect my flat screen tv to the HDMI cable connected to my
    pc, I am able to get the video to go through but not the audio. I select
    the HDMI Audio option on the Audio Hardware Setup, but it does not work.
    I can only get audio to play through the rear audio jack on the motherboard.

I have checked my HDMI cable, and it does transmit audio fine for other
devices. Just not for my desktop.

Any help on these 2 problems?

Thanks,
George


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

I don’t have an HDMI setup, nor have I ever had an HDMI setup, so I do not know if I can be of help.

But I do believe it would help if you could provide information structured along lines different from what you have provided. Instead please run the diagnostic script (with PC connected to internet) :


/usr/sbin/alsa-info.sh

and select the share / upload option, and after it completes running, it will provide you a URL/web address where the diagnostic output is located on the web. Please post that URL here. That way our HDMI gurus can look at this. This script has been specifically designed to provide the information one needs to obtain support.

Also, I think you should also check your pulse audio settings to ensure they are setup for the HDMI. To do that I recommend you install ‘pavucontrol’ (pulse audio volume control) if it is not already installed. I wrote a blog on using ‘pavucontrol’ here, although I did not mention HDMI use in that blog as I don’t have such a hardware setup. https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

Try the (ncurses) “alsamixer” app, hit F6 and select the approp. device, then check to see it the particular output is muted or not

  1. When I connect my flat screen tv to the HDMI cable connected to my
    pc, I am able to get the video to go through but not the audio. I select
    the HDMI Audio option on the Audio Hardware Setup, but it does not work.
    I can only get audio to play through the rear audio jack on the motherboard.

I have checked my HDMI cable, and it does transmit audio fine for other
devices. Just not for my desktop.
What graphics driver are you using?

Tyler_K asks a very relevant question.

golson765, I note this:

ie you are using radeon hardware.

If you are using the opensource radeon grahpic driver (and not the proprietary fglrx graphic driver) then to the best of my knowledge, the radeon HDMI audio module is disabled by default in kernel >=3.0. To work around this you need to add radeon.audio=1 to the end of your “kernel” line in your grub boot manager applicable configuration file to get HDMI to work. To do such a ‘kernel’ line edit, are you using legacy grub or grub2 ?

wrt testing HDMI, a possible command to try is something like


speaker-test -D hdmi -c2

where I assume 2 channels in the above … which is speculation that I dislike doing. The output of the script that I requested in an earlier post would help remove some of the mystery here.

On 03/01/2013 01:26 AM, oldcpu wrote:
> If you are using the opensource radeon grahpic driver (and not the
> proprietary fglrx graphic driver) then to the best of my knowledge, the
> radeon HDMI audio module is disabled by default in kernel >=3.0. To
> work around this you need to add radeon.audio=1 to the end of your
> “kernel” line in your grub boot manager applicable configuration file to
> get HDMI to work. To do such a ‘kernel’ line edit, are you using legacy
> grub or grub2 ?
>
> wrt testing HDMI, a possible command to try is something like
>
> Code:
> --------------------
>
> speaker-test -D hdmi -c2
>
> --------------------
>
> where I assume 2 channels in the above … which is speculation that I
> dislike doing. The output of the script that I requested in an earlier
> post would help remove some of the mystery here.
>
Ok, this is good. Thanks to you all for your help in troubleshooting
this. I am going to check on installing the new graphics driver and see
if that brings out sound.

In the meantime, I did take the following screenshots that show what I
am looking at. With pavucontrol, when I select the HDMI output, it
indicates sound on the indicator bar, but no sound comes out. Also, as
you can see from the 5th link there, with the alsamixer, the HDMI output
is down at zero volume, which is an indicator of the problem. I tried
using the controls in alsamixer to increase the volume, and when pushing
any of the controls for increase, the volume stays at zero.

http://picpaste.com/HDMI1-sDeXaNPJ.jpg
http://picpaste.com/HDMI2-D1LQUYHV.jpg
http://picpaste.com/HDMI3-gIEELXfP.jpg
http://picpaste.com/HDMI4-T8EDzFDX.jpg
http://picpaste.com/HDMI5-vPTsc8U2.jpg

Also, here is the link for the also info test that I ran:
http://www.alsa-project.org/db/?f=7a8bb170fbd2604df96cd912e0f65603ac595e70

when I checked the graphics driver, as you can see below, I found I am
using the opensource driver:


tribaltrekker:/home/george # hwinfo --gfxcard
31: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: ul7N.kSZ0Bo04_yF
Parent ID: vSkL.2yY_xudKZ6E
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: "ATI Radeon HD 3300 Graphics"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x9614 "ATI Radeon HD 3300 Graphics"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x834d
Driver: "radeon"
Driver Modules: "drm"
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xc000-0xcfff (rw)
Memory Range: 0xfbde0000-0xfbdeffff (rw,non-prefetchable)
Memory Range: 0xfbc00000-0xfbcfffff (rw,non-prefetchable)
IRQ: 18 (1541352 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v00001002d00009614sv00001043sd0000834Dbc03sc00i00"
Driver Info #0:
XFree86 v4 Server Module: radeonhd
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

Primary display adapter: #31

Funny thing is, I thought that I was using the fglrx driver because I
remember installing it some time back. However, I have been having to
travel for work so much over the past few months, I can’t remember if my
system reverted to the opensource driver when I upgraded to 12.2, or if
it was after a kernel update (I don’t remember when the last one was).

I am using grub2, but I am inclined to update to the fglrx driver
instead of keeping the opensource driver. Do I still need to add the
line radeon.audio=1 to the kernel line using the grub2 update utility?


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 03/01/2013 05:40 PM, golson765 wrote:
>
> Funny thing is, I thought that I was using the fglrx driver because I
> remember installing it some time back. However, I have been having to
> travel for work so much over the past few months, I can’t remember if
> my system reverted to the opensource driver when I upgraded to 12.2,
> or if it was after a kernel update (I don’t remember when the last one
> was).
>
> I am using grub2, but I am inclined to update to the fglrx driver
> instead of keeping the opensource driver. Do I still need to add the
> line radeon.audio=1 to the kernel line using the grub2 update utility?
>

Ok, problem - I installed the proprietary fglrx driver according to the
instructions in https://en.opensuse.org/SDB:AMD_fglrx_legacy.

However, there is a problem now in that I cannot get the resolution on
my monitor and the HDMI output to do what I want. Before with the
radeonhd driver, I had the correct resolution on both the HDMI and the
monitor, with placing the HDMI to the right of my monitor screen easily.
With the proprietary driver, KDE seems to have a problem configuring it,
and it makes the HDMI TV my default monitor and forces my regular
monitor to clone it.

So, I think I want to go back to the radeonhd driver and try your
suggestion of adding the radeon.audio=1 to the kernel line.

However, I don’t know how to go back to the radeonhd driver. The
instructions I followed had me put in radeon.modeset=0 and
blacklist=radeon 3, and then create a new mkinitrd before installing the
fglrx driver. If I boot up without those flags, can I just uninstall the
fglrx rpm that I downloaded and then do a new mkinitrd to get the
radeonhd driver back?


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

You have installed the proprietary driver using a method unknown to me. So I can not help wrt its removal. Sorry.

wrt the configuring the prorprietary driver, did you try configuing the HDMI with ati-config or with ‘xrandr’ or ‘xrandr -q’ (I can not recall the arguments).

Quick notes:

  • radeon.audio=1 is applicable for the radeon OSS driver. radeon driver supports hdmi audio for your device, but it just needs to be enabled (as noted above). For newer hardware, IIRC, kernel 3.5 brought support to most r600 class devices, but again it needs to be turned on. This last point is just an FYI to anyone else for whom that info might pertain
  • radeonhd (antiquated and no longer developed) is NOT the same as radeon (more features and where all the development is in)… two completely different OSS drivers. you should be running the radeon … if you are using radeonhd its because installation problems caused it to fall back to that (either automatically, or unwittingly by your own actions)
  • configure the prop. catalyst/fglrx driver settings through the catalyst control centre or cmd line equivalent. … and not via the KDE settings
  • if you are going to go with the radeon driver, uninstall the fglrx, revert any of the kernel boot line parameters you’ve added … after that boot and lets see what driver you are actually using:
/sbin/lspci -nnk | grep VGA -A2

and then, if you are having any further problems, paste your xorg log to suse paste and provide a link

On 03/02/2013 01:46 AM, Tyler K wrote:
> Quick notes:
>
>
> - configure the prop. catalyst/fglrx driver settings through the
> catalyst control centre or cmd line equivalent. … and not via the
> KDE settings
Ah, ok, that is much better. Using the catalyst control center worked,
and I am able to effectively use both monitors.

Ok, here is an interesting thing that happened. When I plugged in the
HDMI cable and ran the catalyst control center, I was able to get sound
to go out through the HDMI cable to the television set. It was working
great and I though I had solved everything.

However, I have rebooted now, and I am back to the beginning. I am
running the fglrx driver, and I have a good picture on my HDMI TV set,
but no sound goes through the cable. Same as before, alsamixer shows the
volume at zero for HDMI and pavucontrol shows the volume going through
the HDMI cable, but no sound comes out of the TV.

Here is the output of the command verifying my use of fglrx:


tribaltrekker:/home/george # /sbin/lspci -nnk | grep VGA -A2
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD]
nee ATI RS780D [Radeon HD 3300] [1002:9614]
Subsystem: ASUSTeK Computer Inc. Device [1043:834d]
Kernel driver in use: fglrx_pci

Also, here is the also sound troubleshooting information that I just ran
again:

http://www.alsa-project.org/db/?f=3e4fb4dbea6ed109df94908bb18a8602a137e04d

It was going so well for a moment there. I feel like we are really
close, so thanks for your help.


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

I typically find that script very useful.

It tells us a number of things



!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: VT1708S Digital [VT1708S Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 2: VT1708S HP [VT1708S HP]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 1/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 2: J [A4 TECH USB2.0 PC Camera J], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

… such as your PC has 3 sound devices …

  • card0 (hw0) for playback and record, and
  • card1 (hw1) for playback and
  • card2 (hw 2 ) a webcam mic only for record

This causes me to ask is there a possibility the sound was being sent out via the card0 (VT1708S) instead of the card1 (HDMI) ? With pulse audio I think it possible to do both, or either, dependant on settings.

Don’t forget the recommendation to install ‘pavucontrol’ (if not already installed) per this guidance:

… and use it to configure pulse audio to send the sound from different applications to your sound card of choice. Note blog entry above in quoted post which while it does not cover HDMI it does cover multiple sound devices.

Also, when you note sound no longer works, with what appliction ? What sort of speaker test did you try in order to send the sound via HDMI ?

Another possibility that you need to check (if using KDE) is that you do not have KDE desktop set to block the sound. In which case you need to go into the KDE desktop “configure destop > multimedia” and ensure that its settings did not unintentionally revert to some previous inappropriate default setting upon boot.

… again, I don’t have an HDMI sound device - these are just ‘nominal’ openSUSE GNU/Linux sound check questions.

Good luck !

Maybe enabling the simultaneous sound with pulseaudio from two sound cards might solve this issue.
I can’t help much though I am using simultaneous sound because I have no idea how the radeon hdmi works.
I am using nvidia.

I don’t have an HDMI monitor, so I can’t offer any suggestion for that, but I also had the problem with no audio on the front port. I had to select AC97 in the motherboard “BIOS” setup, under the “Onboard Device Configuration” menu, in “Front Panel Select [HD Audio]”. I have a desktop with the ASUS M4A88T-M motherboard, and am using the open source Radeon driver. Hope that helps…

On 03/02/2013 04:26 PM, oldcpu wrote:
> golson765;2531169 Wrote:
> This causes me to ask is there a possibility the sound was being sent
> out via the card0 (VT1708S) instead of the card1 (HDMI) ? With pulse
> audio I think it possible to do both, or either, dependant on
> settings. Don’t forget the recommendation to install ‘pavucontrol’ (if
> not already installed) per this guidance:

Thanks so much for the help. I am not quite there yet. I do have
pavucontrol installed - that is what I am using to tell me where the
sound signal is being sent. Right now pavucontrol is telling me that the
sound is going to the RS780 HDMA Audio stream, but no sound is coming
out. The ‘alsamixer’ command tells me that this card, for some reason,
has zero volume output, and I cannot adjust the volume up on it.

I know there is a solution because it worked yesterday before I
re-booted my pc. It was after I re-booted that I again lost the
functionality.

Perhaps the audio HDMI driver has a bug in it? I know that with graphics
drivers we get better functionality using the proprietary fglrx, but is
there a similar thing with sound card drivers?

Here is the output from my hardware info:


tribaltrekker:/home/george # hwinfo --sound
22: PCI 14.2: 0403 Audio device
[Created at pci.319]
Unique ID: 5Dex.WnV4s1RcOt2
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "ATI SBx00 Azalia (Intel HDA)"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x4383 "SBx00 Azalia (Intel HDA)"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x8357
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfbbf4000-0xfbbf7fff (rw,non-prefetchable)
IRQ: 16 (334585 events)
Module Alias: "pci:v00001002d00004383sv00001043sd00008357bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown

32: PCI 105.1: 0403 Audio device
[Created at pci.319]
Unique ID: l4dC.vfAxXUx5zd4
Parent ID: vSkL.2yY_xudKZ6E
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.1
SysFS BusID: 0000:01:05.1
Hardware Class: sound
Model: "ATI RS780 Azalia controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x960f "RS780 Azalia controller"
SubVendor: pci 0x1002 "ATI Technologies Inc"
SubDevice: pci 0x960f
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfbdfc000-0xfbdfffff (rw,non-prefetchable)
IRQ: 19 (1067 events)
Module Alias: "pci:v00001002d0000960Fsv00001002sd0000960Fbc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

You can see that the driver module is “snd_hda_intel” on both of these.

Any ideas? If not on the driver, how about something similar to the
earlier suggestion of adding “radeon.audio=1” to the kernel line on
boot. Is there a similar flag that can be set while using the fglrx
driver? or do I have to go back to the radeon driver?


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

This is one of the reasons why I thought it important to check your desktop GUI settings (if a KDE user).

Recall this quote of mine:

The reason why I asked what application, is its possible some applications have difficulty with HDMI sound routing via pulse audio, and some do not. Also, there are speaker tests that can be done that are very useful to check sound functionality, and my understanding is such tests extend to HDMI also. I’m curious to what, if any , of such tests you performed to check the HDMI. The results of such tests may help us determine where there is a misconfiguration.

And if you are a KDE user the desktop settings in multimedia can be important, and these can change upon boot - which would be consistent with the observation that you lost audio upon a reboot. Ergo thats why I asked if you checked those ? What are they set at ?

Plausable, but given sound worked for you briefly with HDMI, this is not IMHO so likely. More likely the design implementation for HDMI in KDE desktop and in pulse audio is not as user friendly as it should be (IMHO).

Not to my knowledge - but I am not an HDMI user.

If it is a KDE desktop and if it is the GUI (ie KDE multimedia settings) causing the problem, you could have the exact same problem. I can’t tell if you checked that.

Thanks, but in all due honesty for a sound specific problem, where it worked briefly and then stopped, I’m not smart enough to see the relevance of that. I find the output of the audio diagnostic script that has been specifically developed and tuned by users who help other’s with sound, with input from the sound developers, far more useful.

Don’t forget to double check your cable settings. Its always possible there was an inadvent nudge of the wiring/connection that caused this loss of HDMI sound.

Further to the above post of mine … some speculative tests you could try follow. Note I obtained the ‘hw:x,y’ information off of the diagnostic script that you ran.


**card 1:** HDMI [HDA ATI HDMI], **device 3:** HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

which suggests to me your HDMI hardware is “hw:1,3”.

I am proposing multiple tests because I do not know the exact syntax and I do NOT have an HDMI setup to try this out on myself. Hence I am speculating as to the exact syntax. Try each of these tests. Possibly someone with a functioning HDMI setup can confirm the syntax.


speaker-test -c 2 -r 48000 -D hw:1,3

where I am guessing at 2 channels (with -c 2 ). Pay attention to ANY error messages as that can point to the problem.

assuming that does not work, try this:


speaker-test -D plughw:1,3

and assuming that does not work, try this:


aplay -D hw1,3 /usr/share/sounds/alsa/Front_Center.wav

and assuming that does not work, try this:


aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

(note there are various .wav files under /usr/share/sounds/alsa)

Also, sort of intuitively obvious, but for every interface there are 2 sides. ie the problem could be on the TV side of the interface. So “reboot” the receiver, monitor or tv set. Since the HDMI interface executes a handshake on connection, it might have noticed before that there was no audio stream embedded, and disabled audio decoding. You may need to have some sound playing while plugging in the HDMI cable (I do not know, … I am just speculating here).

I’ve had the same problem. I used the /usr/sbin/alsa-info.sh and the resulting output is at http://www.alsa-project.org/db/?f=c7ccffde1eb66465cdfa1aa85fafc179d309e97c. Failure to get this working is keeping me from completly traversing from Win7. Please note that there isn’t one problem with HDMI audio output in Win7 (unfortunately).

Your problem is quite likely NOT the same, even if the symptoms are similar. Your PCs configuration is massively different.

Look at your mixer settings. You have the PC audio muted. The OP does not have the audio muted.


** Simple mixer control 'Master',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 59 [92%] -5.00dB] **[off]**
**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 63 [98%] [0.00dB] **[off]**
  Front Right: Playback 63 [98%] [0.00dB] **[off]**
**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 63 [98%] [0.00dB] **[off]**
  Front Right: Playback 63 [98%] [0.00dB] **[off]**

**!!-------Mixer controls for card 1 [NVidia]**

**Card hw:1 'NVidia'/'HDA NVidia at 0xe3080000 irq 17'**
  Mixer name    : 'Nvidia GPU 0b HDMI/DP'
  Components    : 'HDA:10de000b,104d4f00,00100200'
  Controls      : 24
  Simple ctrls  : 4
**Simple mixer control 'IEC958',0**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
**Simple mixer control 'IEC958',1**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**
**Simple mixer control 'IEC958',2**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**
**Simple mixer control 'IEC958',3**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**

When all those settings set to OFF , that mostly guarantees no sound playback possible.

I also note in the above that your PC has hw:1,3 (IEC958,0) sound ON, but it also has hw:1,7 (IEC958,1) OFF and hw:1,8 (IEC958,2) OFF and hw:1,9 (IEC958,3) OFF. Does that mean you are 100% certain that hw:1,3 (IEC958,1) is the HDMI device ? If that is the case, can you explain how you arrived at that conclusion, so I can assess if it makes sense and assess if I made a mistake ?

Some further clarification from the ‘aplay’ section in the script :


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC275 Analog [ALC275 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC275 Digital [ALC275 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
****card 1****: NVidia [HDA NVidia], **device 3**: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: NVidia [HDA NVidia], **device 7**: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: NVidia [HDA NVidia], **device 8**: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: NVidia [HDA NVidia], **device 9**: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It is from the above that I can see your PC has multiple hardware HDMI devices while the OP has only one. IMHO you need to check hw:1,3 ; hw:1,7 ; hw:1,8 ; hw:1,9.

I gave a command for the OP to try for that, and you did not post if you tried this (yet you posted that you had the same problem and I asked the OP to try).

Please try each of these tests for each of your HDMI devices (I posted multiple as I do not have an HDMI device setup and I do not know the syntax for certain). Possibly someone with a functioning HDMI setup can confirm the syntax. You need to be listening, not only proper sound, but also for massive increased static with any one of them.


speaker-test -c 2 -r 48000 -D hw:1,3

where I am guessing at 2 channels (with -c 2 ). Pay attention to ANY error messages as that can point to the problem.

assuming that does not work, try this:


speaker-test -D plughw:1,3

and assuming that does not work, try this:


aplay -D hw1,3 /usr/share/sounds/alsa/Front_Center.wav

and assuming that does not work, try this:


aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

Try the above for hw:1,3 ; hw:1,7 ; hw:1,8 and hw:1,9. That is a LOT of testing. Hopefully one of those will point out which one is your audio device (possibly by only providing excessive noise above the levels of the other hw:1,x selections, and with more knowledge then we can go from there.

On 03/03/2013 03:06 PM, oldcpu wrote:
> oldcpu;2531435 Wrote:
>> The reason why I asked what application, is its possible some
>> applications have difficulty with HDMI sound routing via pulse audio,
>> and some do not. Also, there are speaker tests that can be done that
>> are very useful to check sound functionality, and my understanding is
>> such tests extend to HDMI also. I’m curious to what, if any , of such
>> tests you performed to check the HDMI. The results of such tests may
>> help us determine where there is a misconfiguration.
>>
> Further to the above post of mine … some speculative tests you could
> try follow. Note I obtained the ‘hw:x,y’ information off of the
> diagnostic script that you ran.
>
> Code:
> --------------------
>
> card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
> Subdevices: 0/1
> Subdevice #0: subdevice #0
>
> --------------------
>
> which suggests to me your HDMI hardware is “hw:1,3”.
>
> I am proposing multiple tests because I do not know the exact syntax
> and I do NOT have an HDMI setup to try this out on myself. Hence I am
> speculating as to the exact syntax. Try each of these tests. Possibly
> someone with a functioning HDMI setup can confirm the syntax.
>
>
Sorry for the delay in response. I got real busy with work the last 3
days and wasn’t able to come back and focus on this problem.

Just to give an update, here is what has happened since then. I rebooted
one time, and with running fglrx, all of a sudden the image came up on
the tv screen through hdmi and the sound also went to the tv like I
wanted. It was really nice.

Another nice feature of this was that I set it up with the amd catalyst
control center, and it allowed me to clone the displays at the native
resolution of my regular desktop display, which is 1600x900. This was
especially nice because I could see well on my desktop and it was a
simple clone on the hdmi tv.

Since then I have rebooted twice. I do have sound now working through
the hdmi connection, which solves the main problem, and it seems to be
sticking like that, which is great.

I have not been able to get the screen to clone at 1600x900 resolution
anymore through the amd catalyst program. When I set it up to clone, it
forces the display into 1440x900 resolution. So I tried rebooting again,
and it looks like this is the setup I am going to get if I want cloned
displays.

I also tried to set a multi-display desktop with the hdmi tv connection
to the right of my normal desktop. The only problem is, the amd catalyst
control center recognizes the tv as display 1 and the analog monitor as
display 2, so it puts my kicker, task manager, and all my icons on the
tv instead of my normal desktop monitor. I am not sure how to mess with
that, but I will keep trying.


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 03/07/2013 11:51 AM, golson765 wrote:
> Sorry for the delay in response. I got real busy with work the last 3
> days and wasn’t able to come back and focus on this problem.
>
> Just to give an update, here is what has happened since then. I
> rebooted one time, and with running fglrx, all of a sudden the image
> came up on the tv screen through hdmi and the sound also went to the
> tv like I wanted. It was really nice.
>
> Another nice feature of this was that I set it up with the amd
> catalyst control center, and it allowed me to clone the displays at
> the native resolution of my regular desktop display, which is
> 1600x900. This was especially nice because I could see well on my
> desktop and it was a simple clone on the hdmi tv.
>
> Since then I have rebooted twice. I do have sound now working through
> the hdmi connection, which solves the main problem, and it seems to be
> sticking like that, which is great.
>
> I have not been able to get the screen to clone at 1600x900 resolution
> anymore through the amd catalyst program. When I set it up to clone,
> it forces the display into 1440x900 resolution. So I tried rebooting
> again, and it looks like this is the setup I am going to get if I want
> cloned displays.
>
> I also tried to set a multi-display desktop with the hdmi tv
> connection to the right of my normal desktop. The only problem is, the
> amd catalyst control center recognizes the tv as display 1 and the
> analog monitor as display 2, so it puts my kicker, task manager, and
> all my icons on the tv instead of my normal desktop monitor. I am not
> sure how to mess with that, but I will keep trying.
>

And it seems now that I have figured out how to make it work. I am not
sure exactly why it works, but here is what I do.
Using the catalyst control center, I set the tv display to disabled.
Then I turn off the TV that is connected through hdmi. Then I reboot my
computer.

While the computer is rebooting, I pinch my left pinky toe 3 times and
rub my right elbow with a piece of red leather and then yellow leather.
Pull on the left ear 2.5 times and spin around. Then I chant the magic
words in ancient Swahili.

When my computer is back up and running and is fully rebooted, I can
turn on the television at any time, and it connects through the hdmi
port, and bingo, the screen on the tv is a mirror of my desktop display
at the preferred resolution for my desktop, 1600x900. Sound goes through
the hdmi when I select it to using pavucontrol.

So it looks like I have it working, at least for now.

Thanks to everyone for the suggestions! I think the key was using fglrx,
and at least I have a better idea of how to tweak things now also.


G.O.
Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it