Sound appears to be hijacked for a millisecond intermittently

So even when audio isn’t running, up in the top right corner the sound controller will ‘flicker’ for a split second. If there is audio playing, this sounds somewhat like a crackle. But I think it’s something trying to hijack the device. Here is a screen shot of the Sound panel in settings.

If I have this window, when the stutter occurs, it switches to the S/PDIF output and stays there. If I close this window, the stutter happens but it doesn’t switch the S/PDIF like when I have this window open. It’s very odd.
I then used:

$ find /proc/asound/ -name hw_params | xargs -I FILE grep -v -l "closed" FILE | grep '/proc/asound/card./pcm.p/sub./hw_params'

And switched the sound output device to run again.
Am I able to do anything with these outputs to turn off the S/DPIF controller to have peace of mind that it’s not what is hijacking the audio?
When I ran

$ cat /proc/asound/modules

I get my on board sound device twice as o and 1. I created /etc/modprobe.d/modprobe.conf as it did not exist and added “options snd_hda_intel enable=1,0” to hopefully turn off just one. But it does nothing, and if I set it 0,1 it disables both in the sound panel.
Not sure were to go from here. Any help would be greatly appreciated. If I can come over this hurdle I’ll be be able to start using linux as my daily driver. Can’t be doing that with stuttering sound every 10 seconds though.

Oh also, I’ve tried using different speakers, the front and back port and kde plasma as well as gnome as a desktop environment. The issue persists through these issues.

Thanks again.

I’m no sound guru, but the following advice may be worth investigating…

Thanks, I’ve given a bunch of things on there a go now, and I think I may have found a crappy fix which is turning off auto mute in alsamixer via the console. Now when the sound icon visually stutters, there is no audible stutter. However, all the other changes I have done have introduced pops and cracks into the audio now, not related to the hijacking issue that still happens but doesn’t affect the sound output. Looks like I’m going to have to do a reinstall. I shall be back tomorrow

I’d be surprised if reinstalling resolves this issue. Instead, I recommend waiting a bit for others to reply with further advice.