sound answer suse 11


I have,

  1. Linux x86_64
  2. openSUSE 11.0 (x86_64)
  3. AMD Athlon™ 64 X2 Dual Core Processor 5600+, speed : 2,814.43 MHz, cores : 2,
  4. Quadro FX 570

When starting suse i can hear the startup sound. however, when I play a movie file or sound file i cannot hear anything. Knowing that I am a newbie to linux, what step by step approach can help me troubleshoot this situation.



It looks like you have a 64-bit openSUSE-11.0. My advice is based on 32-bit openSUSE experience, so hopefully if some of it is bad (for 64-bit) then a 64-bit user will jump in and correct my post.

If you have startup sound, then likely your sound works ok, and there is a strong possibility your “sound” problem is a codec problem. OpenSUSE is packaged with no support for proprietary codecs, and to be able to play most movie/sound files (where most use proprietary codecs) you will need to install 3rd party codecs.

To make this installation of codecs easy, I recommend you setup your software package management to install the needed codecs/media-players.

I specifically recommend you setup your software package management for 4 and ONLY 4 repositories. Specifically, OSS, Non-OSS, Update, and Packman. Just those 4. No others. None. You can add others when you learn more about the risks/implications of adding others. There is guidance for adding those 4 here: Repositories/11.0 - openSUSE-Community
… again, ONLY OSS, Non-OSS, Update and Packman. No others!

Now with those 4 setup, you can install some codecs and media players that are not crippled. For example xine-lib packaged by Novell/SuSE-GmbH is delivered crippled. So I recommend you go to YaST > Software > Software Management and mark xine-lib for removal, but before you apply that setting, also mark libxine1 from Packman for installation. Then apply the setting. Also install xine-ui (the gui/user-interface for xine). Maybe also kaffeine (as packaged by Packman). I also recommend you install (from packman) MPlayer, smplayer, mplayerplug-in. And from Non-OSS install flash-player.

For codecs, I recommend you install libffmpeg0 (from packman). Also libquicktime and xvid.

For audio I recommend you install the packman packaged amarok (not the Novell/SuSE-GmbH version). Also install amarok-xine from Packman.

Good luck.