Sound 11.1

I have tried to get my sound working, but cannot. I have tried the guides, and they work for a while.
sometimes I get sound on a browser but not when I run a konsole or test in yast. Sometimes when the sound is not working I reboot, and get the shutdown sound but no the startup.

Any help is appreciated
john kilbert

The start up sound is not a good test for sound functionality. Instead, when testing for sound, one should use the 3 tests here: SDB:AudioTroubleshooting - openSUSE - How to test your sound ie the two speaker-tests, and also the alsa web site test. If ONLY one of those works, then your PCs sound is still functional, and problem lies at either destkop level or application level.

Note that Linux is bad when it comes to more than one application playing sound at the same time. So it is important that when starting a multimedia device, you close down any other application that might be using your sound device. Typically the ALSA API will share sound between applications, so if one sets their applications to use the ALSA API, then sound can be shared between applications. Pulse audio is also supposed to provide that capability, but pulse audio is still relatively new in its introduction and it has bugs. OSS, aRts and other sound servers/daemons do NOT support sound from multiple applications at the same time. One can read up more on it here: Sound-concepts - openSUSE

Are u sure with this statement? Im pretty sure with oss its possible to have sound from several application. Im wondering how difficult it is to get oss working in OpenSuse, because i prefer oss to alsa. If its not too difficult i might try the new OpenSuse release.

Unless this (playing multiple apps at the same time) is a recent development with OSS (within the past year or two) then YES, that is what I have read from a number of sources. Not playing multiple apps at the same time always was an OSS disadvantage.

ok thanks, I probably mixed up the old OSS (which is included in the Linux kernel sources) with the new OSS versions (often called OSSv4). OSSv4 supports sound for several applications, it works for me in Arch Linux.