Sotware RAID5 problem in VM

I am trying to build an software RAID5 composed out of 4 drives, in addition to the basic boot drive.
I start qemu with the following command:

qemu-system-x86_64 -net vde,vlan=0,sock=/var/run/vde2/tap0 -net nic,vlan=0,model=e1000 -m 256 -localtime -boot c -cpu qemu64 -vga std -name vnfs-server -hda /media/vms/vnfs-server.img -drive file=/dev/sda,if=virtio,media=disk,cache=writethrough -drive file=/dev/sdb,if=virtio,media=disk,cache=writethrough -drive file=/dev/sdc,if=virtio,media=disk,cache=writethrough -drive file=/dev/sdd,if=virtio,media=disk,cache=writethrough -cdrom /dev/dvd1 -usb -usbdevice disk:/dev/sdf -usbdevice tablet

I tried both SuSE 11.0 as well as 11.1, with KVM enabled. Also, I tried various other (newer) kernel version, all with the same result.
Inside the quest I used the ‘yast2 disk’ command to create a software RAID5 from the then available vd[abcd]1. The creation works, but looking at ‘mdadm --detail /dev/md0’ showed that vdd1 is being rebuild. Apparently this is normal behavior. What is not normal, is that after the rebuild, partition sdd1 has been removed from the array.

It’s not the drive, since doing the same outside a virtual machine gives exactly the same result except for the removal of the drive.

So I wonder, is there a problem with virtio block devices within qemu or has someone an answer or a pointer to a solution?