SONY VGN N320E wireless

I’ve looked online, but I can’t find any more information on the wifi card in the sony i have running SUSE.

Atheros Communications LAN Express 802.11 PCI-E Adapter.

I can’t get SUSE to even recognize the card.
This is my first attempt at a SUSE machine (and linux) and I am looking for some help.

On Fri, 15 Aug 2008 00:16:02 GMT
i3igi3yrd <i3igi3yrd@no-mx.forums.opensuse.org> wrote:

>
> I’ve looked online, but I can’t find any more information on the wifi
> card in the sony i have running SUSE.
>
> Atheros Communications LAN Express 802.11 PCI-E Adapter.
>
> I can’t get SUSE to even recognize the card.
> This is my first attempt at a SUSE machine (and linux) and I am looking
> for some help.
>
>

Hi, and welcome to SuSE!

Here’s instructions how to get your Atheros Wireless up and running.
You’ll need a network connection to get the drivers you need… yes, ironic.
The included ath5k driver is not mature enough yet to handle all of the
various Atheros chipsets, so the stable Madwifi drivers are recommended.

========================================

Steps to install MadWifi driver for Atheros Wireless:
(This is given as performed on a KDE 3.5.9 installation.
The applications should be similar for Gnome and KDE 4.x)

  1. Blacklist the ‘ath5k’ driver
    From a terminal:
    su - root
    {supply password}
    echo “blacklist ath5k” > /etc/modprobe.d/ath5k
    uname -r
    {remember whether it says ‘-default’ or ‘-pae’}

  2. Add the MadWifi Repository and software
    Start the YaST Setup Program
    -> Software Management
    -> click on ‘Repositories’ (top menu)
    -> click on ‘Repository Manager’
    -> click on ‘Add’ button, towards bottom
    -> verify ‘Specify URL’ selected
    -> url is ‘http://madwifi.org/suse/11.0
    -> enter a name, ‘Madwifi’ works
    -> click on ‘Next’, returns to list of current repos
    -> click on ‘Ok’, returns to software installation page
    -> click in Search box, enter ‘madwifi’, click ‘Search’
    -> depending on remembered entry from above:
    -> select either ‘madwifi-kmp-default’
    or ‘madwifi-kmp-pae’
    -> click on ‘Accept’, bottom right
    If it pops up a window saying
    ‘these packages were needed too’, say ‘ok’
    -> wait briefly while drivers are downloaded and installed
    -> exit from ‘yast control center’

  3. Reboot laptop, use Yast -> Network Devices -> Network Settings
    to configure your Atheros wireless

  4. Some Caveats…
    knetwork-manager (the green globe) has been known to be
    ‘reluctant’ to automatically connect. This should be
    resolved soon, but you may need to manually choose a
    network to connect to at startup for now.

  5. Enjoy!

========================================

Hope this helps

Loni


L R Nix
lornix@lornix.com

On Fri, 15 Aug 2008 02:42:21 GMT
L R Nix <lornix@lornix.com> wrote:

> 3. Reboot laptop, use Yast → Network Devices → Network Settings
> to configure your Atheros wireless
>
> 4. Some Caveats…
> knetwork-manager (the green globe) has been known to be
> ‘reluctant’ to automatically connect. This should be
> resolved soon, but you may need to manually choose a
> network to connect to at startup for now.
>

Oh drat! It’s always something…

In item 3, if you choose ‘Traditional Mode’ (Network Settings -> Global Tab),
you can set up your wireless with yast.

If you choose "network-manager mode’ (the default), you would use
‘knetwork-manager’ (the green globe) to set up your wireless connection.
(thus item 4)

My apologies for the confusion.

Loni


L R Nix
lornix@lornix.com

That’s great!
I will try all of this when I get home from work this afternoon and see what happens. Thank you again for the help!