Sony Vaio VGN-CR410ER

Hello, Im working on this 410ER. Its up and running on the new 11.0, There a few things that do not work and I Was wondering if anyone has full functions on one of these vaios or can at least help me with this. so …

Things that dont work

Magicgate card reader, never mounts, its not even recognized
FN keys for brightness
Camera and camera capture key When using cheese app, it crashes at start up
intel card 965 express? It works but the resolutions seems off abit. its under 1280x800, but it gives me 1024x780, it doesnt look great. but its working for now.
I got a bluetooth mouse, also viao, which links by itself but the scroll wheel does not work, It did when I Was using with Dell on 11.0 beta. but not on this vaio
also my sound keeps going out, I get sound at start up but then no music via totem nor rhythmbox

All the multimedia keys work!! which is a plus

So any help with this I will appreciate, anything, I really want to get this working

Thanks you for the views so far, still no answers though. So the sound is fixed now, I just did a re-install of the gstreamer packages and its working fine. Same with the screen resolution. I mentioned it was a bit off but not its fine, I just adjusted the settings. So today I ll be working on the camera hopefully I get something working.

Hey,man. I got a SONY VAIO VGN-CR13
When I installed openSuSE 10.3 Last year.
I am trying to solve that problems
and so far. I think, the WEBCAM is the only problem that I have solved.
any more,the Driver is for Ricoh r5u870
trying this :R5u870 - mediati|wiki
Thx to

Other problems, thr is no need to solve any more for my thinking, as I don’t use them :slight_smile:

Hey thanks for the link!! With your help I was able to get the camera working. so that s a plus. Have you tried fixing the FN and magic gate problem on yours? I will try myself by searching see what I can come up with.

Could you help me with the webcam driver? I also have a Vaio, FZ series. How did you install the driver?

I have downloaded the driver and install the kernel sources, make, and gcc. I don’t know what autotools are? Also the instructions say to execute #make, but can you tell the whole exact commands?


i have a vail vgn-c240e, the multimedia key did not work so i installed hotkey-setup

the key are correctely mapped but nothing appen when i press on the key…

Take a skim thu our multimedia stickie …
Welcome to multimedia sub-area - openSUSE Forums

If after reading the links, and following the instructions there, you still can’t get music, then post again asking for help, indicating the errors and symptoms you get.

I’m trying to get a Ricoh webcam (05ca:1839) working on a vaio CR410E with openSUSE 11.0 installed. I have the latest r5u870 firmware and -kmp packages installed, as well as uvc packages.

The commands “dmesg | grep r5u870” and trying to start “luvcview” respectively yield the following outputs:

usbcam: registering driver r5u870 0.11.1
r5u870-0: Detected Sony VGP-VCC6
r5u870-0: Unexpected microcode version (exp:0113 got:0030)
r5u870-0: interface 1 already claimed
r5u870-0: registered as video0
usbcore: registered new interface driver r5u870


luvcview 0.2.4

SDL information:
Video driver: x11
A window manager is available
Device information:
Device path: /dev/video0
Stream settings:
Frame format: YUYV (MJPG is not supported by device)
Frame size: 640x480
Unable to set frame rate: Invalid argument
Init v4L2 failed !! exit fatal

Yast shows all drivers as correctly installed with no failed dependencies, but still no life, not even a light flicker, when I try to use luvcview, Cheese, or Ekiga. Anyone have any ideas?

Why the uvc packages? Would the uvc not interfer with the r5u870 ?

I do not have such a web cam, but reading the installation instructions Installation - mediati|wiki I see no mention of uvc.

I note this Ubuntu thread:
[ubuntu] [SOLVED] Sony Vaio ID 05ca:1839 Motion Eye Webcam HELP!!! - Ubuntu Forums](
where they did not use uvc, and they had the web cam working with xawtv.

Unfortunately, following the wiki install instructions did not work for me. I had not tried xawtv, so I just installed and gave it a shot. Executing xawtv provides the following:

This is xawtv-3.95, running on Linux/x86_64 (
xinerama 0: 1024x768+0+0
xinerama 1: 1280x800+0+0
/dev/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
ioctl: VIDIOC_REQBUFS(count=2;type=VIDEO_CAPTURE;memory=MMAP): Success
ioctl: VIDIOC_S_STD(std=0x0 ]): Invalid argument
game over

Though video does show, its terribly discolored. MoTv is the same. But still nothing with Cheese or Ekiga. The result is the same with or without uvc packages installed. I need to familiarize with how Cheese differs from xawtv. It seems like a v4l issue…

Following the solution of creating the file shown at this link
Sony Vaio MotionEye Webcam… Any Success? - Page 21 - Ubuntu Forums
allows Cheese to work properly, though not Ekiga…

does you have sonypi module loaded?

i done with root access
modprobe sonypi
FATAL: Module sonypi not found.

no problem with sony_laptop

i can’t manage fnkey