Sony vaio pro 13 with Windows 8.1 - install opensuse 12.3 from USB.. boot problem

Hi all,

so, let me start by describing the laptop initial configuration:

  • Sony vaio pro 13 (haswell) (very recent laptop)
  • Windows 8.1

that’s it!

then, before install steps:

  • I shrinked the drive to make space for the linux
  • I disabled the fast startup on the windows control panel > power options > system settings > shutdown settings
  • burn opensuse iso to usb stick
  • BIOS: changed the boot of windows to “unsecured” and changed the boot order so it would boot from the usb stick

opensuse 12.3 install steps:
… all good so far, boot from usb, opensuse 12.3 first install screen… all good…
… proceeding with the normal configuration options… and then
>>>>boot loader “grub uefi” (one partition for UEFI BOOT, other for SWAP and other for /)
… do installation!
… the install starts… it install everything without any problems and then and the end, asks for the normal reboot (just after installing the boot loader… and with the green progress bar at 100%).
this all seams normal, I press ok and reboot.

I go to the BIOS, change again the boot order and make the hard drive the first option.
… boot the laptop…

AND NOW THE PROBLEM: the laptop always boot into windows 8.1 without any screen for dual boot (no grub).

I’ve read dozens of post everywhere about this… but still, I cannot find a way to solve this.

Please, can anyone help me on this? What am I doing wrong? I really want/need the opensuse… but I need to keep the windows because there are two or three software packages that I need to use from time to time on windows… and so I really need the dual boot.

Many thanks!!


On 2013-10-19 03:26, ru1marante wrote:
> AND NOW THE PROBLEM: the laptop always boot into windows 8.1 without any
> screen for dual boot (no grub).

From the little I know of UEFI, you have to select wich operating system
in the UEFI (aka bios). There select openSUSE, and then you should get
the grub window.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Please show output of “efibootmgr -v” in tags code. If you cannot boot installed openSUSE, you could perform rescue boot from installation DVD.

First - WELCOME to openSUSE.

IMHO you are not doing anything wrong. The industry wide implementation of UEFI is not yet consistent, and hence at present time no GNU/Linux distribution is guaranteed to install the GNU/Linux on a UEFI system with secureboot/UEFI enabled. Instead for all GNU/Linux distros extra ‘hacking’ is typically required to varying degrees.

You note you ‘read dozen’s of posts’, but did you try any of the suggestions in the posts ?

What worked for me on my Toshiba Ultrabook, was (for an install from the openSUSE-12.3 Installation USB, and not the openSUSE-12.3 liveKDE USB, although I did need both) the following :

(1) first, completely backup to a USB stick the content EFI partition. This is necessary to ensure you can always put things back to the default values.

(2) second, install openSUSE-12.3 from the larger 12.3 Installation .iso (via USB). But have the liveUSB handy for hacking. I encountered the same boot problem you noted - always booting to Windows8.

(3) third, boot to Windows8, and go to “Advanced Startup Option > Advanced Startup > Restart Now” and check if openSUSE entry was present. It was present for me. If not present, then my next step does not make sense and hence don’t go further with what I post.

(4) fourth, in Windows8 terminal, I sent the command:

bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

likely the above, and the following step-5 are separate methods for a solution. I do note that this step-4 did not solve the problem by itself and may not have been necessary.

(5) fifth, boot to the 12.3 KDE liveUSB and use that to access the EFI partition. In that UEFI partition, copy the /EFI/opensuse directory contents into the /EFI/Boot efi and rename the opensuse shim.efi to bootx64.efi, replacing the previous.efi. * [Note I had a backup of the original bootx64.efi on a separate USB stick] *

(6) I could reboot at this point to openSUSE and finish the install.

I have read of users with different PC (Asus I think) who needed to go the BIOS/UEFI-FIRMWARE change an innocuous setting. Save the change, and reboot to BIOS/UEFI-FIRMWARE. Change the setting back in BIOS/UEFI-FIRMWARE, save the change, and then reboot. At that point only did the BIOS/UEFI-FIRMWARE pick up the presence of the openSUSE boot options.

I have also read of Sony Pro users, who discovered that their Sony was hard coded to ignore the /EFI/opensuse and ignore the /EFI/boot but rather would only look at either the /EFI/Microsoft/Boot/ or the /EFI/sony/Boot and in there they needed in the /EFI/Microsoft/Boot/ to replace the /EFI/Microsoft/Boot/bootmgfw.efi with the openSUSE shim.efi, or in the /EFI/sony to replace the (?) bootx64.efi with the openSUSE shim.efi. I confess I would not try this myself unless I was 100% confident I could restore these files afterward, as they would break the Windows8 boot and require a liveUSB boot to restore the files from a USB backup (or require a Windows8 re-install/recovery).

I have a colleague with a Sony Vaio Pro Ultrabook, and I am hoping in the next month (possibly after openSUSE-13.1 GM is released) to help them put openSUSE on their Sony Via Pro Ultrabook. If the colleague is willing, I hope to post our experiences then.

And finally, we have a half dozen users in our openSUSE forum who are MORE knowledgeable than I on this subject (for example arvidjaar who posted above knows more on this subject than I) , and so possibly wait until they chime in on this thread, before you try the suggestions I posted above.


thank you all for the help.

First, just a reminder, this laptop doesn’t have a cd/dvd drive :slight_smile: … so everyting needs to be done with usb stick.

1 - @robin_listas, in the EUFI BIOS there nothing about the opensuse loader that I can see
2 - @arvidjaar, I’m going to try to boot with a live usb and then I will put here the output of the command
3 - @oldcpu,
- yes, I’m going to do a backup… just in case… :slight_smile:
- opensuse entry not present in the uefi bios… as far as i can tell
so now I not sure what to do and I don’t want to brick the laptop :smiley:

  now I'm going to boot from the live usb.. I will post later my findings..

thank for the help!


here it is:

linux:~ # efibootmgr -v
BootNext: 000F
BootCurrent: 000F
Timeout: 0 seconds
BootOrder: 000F,0005,0007,0008,0009,0001,000A,000C,000E
Boot0001* Windows Boot Manager  HD(3,363800,82000,4d2e8e7e-9fc6-4252-947a-a412334cb3b7)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...e................
Boot0005* Sony Original HD(1,800,82000,945e89b6-e1b8-43b6-ba64-21aef8eb7d29)File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0007* Windows Boot Manager  HD(3,363800,82000,4d2e8e7e-9fc6-4252-947a-a412334cb3b7)File(\EFI\Boot\bootx64.efi)
Boot0008* Windows Boot Manager  HD(5,425800,1a524800,571c6484-e381-4aba-8e3c-8e04e328a513)File(\EFI\Boot\bootx64.efi)
Boot0009* Windows Boot Manager  HD(5,425800,728e000,571c6484-e381-4aba-8e3c-8e04e328a513)File(\EFI\Boot\bootx64.efi)
Boot000A* Windows Boot Manager  HD(5,425800,1a475800,571c6484-e381-4aba-8e3c-8e04e328a513)File(\EFI\Boot\bootx64.efi)
Boot000C* Windows Boot Manager  HD(5,425800,12f45800,571c6484-e381-4aba-8e3c-8e04e328a513)File(\EFI\Boot\bootx64.efi)
Boot000E* Windows Boot Manager  HD(8,1336b000,50800,5fcaf30e-7837-4b86-8cd1-d088dc9a33b8)File(\EFI\Boot\bootx64.efi)
Boot000F* UEFI: Ut163 USB2FlashStorage0.00      ACPI(a0341d0,0)PCI(1d,0)USB(1,0)USB(2,0)HD(1,194,2000,cee0ec63)..BO
linux:~ # 

does this help?

I don’t enough to help here, but I do not see your openSUSE installed there, and that makes me think the installation did not go properly. Did you select the grub-efi when installing ?

For example, look at my Toshiba Ultrabook:

linux:/home/linux # efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0006,0005,0003,0000,0004,0002,0001
Boot0000* HDD/SSD       ACPI(a0341d0,0)PCI(1f,2)ATAPI(0,0,0)
Boot0001* LAN2  ACPI(a0341d0,0)PCI(19,0)MAC(e8e0b773c368,0)IPv4(<->,0, 0
Boot0002* LAN1  ACPI(a0341d0,0)PCI(19,0)MAC(e8e0b773c368,0)030d3c000000000000000000000000000000000000000000000000000000000000000000000000000000004000000000000000000000000000000000
Boot0003* Windows Boot Manager  HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...9................
Boot0004* USB Memory    ACPI(a0341d0,0)PCI(1d,0)USB(0,0)
**Boot0005* opensuse      HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\opensuse\grubx64.efi)
Boot0006* opensuse-secureboot   HD(2,e1800,82000,34e17e3e-31c6-11e2-a4d9-e8e0b773c368)File(\EFI\opensuse\shim.efi) **

where "Boot005* " and "Boot006* " clearly show the openSUSE entries in the efi boot manager on my UEFI sytem with Windows8.

Yes, I did select grub-efi… but not the secure mode because I had disabled it in the uefi bios.

But I see what you mean… I’m missing the entry for opensuse, but i don’t know why… the install went without any error or warning.
I also don’t understand why I have several entries for the windows os…

I’m getting sick over this…

well… now it’s a brick! no suse, no windows, and the recovery doesn’t work because it can’t find the recovery partition.

Sorry to read this.

Did you do anything between this post and the previous ?

Did you backup the EFI partition content like I recommended ? [my point (1)].

After you restore your Windows8 booting, I again recommend you pause in your efforts and give our volunteer experts on UEFI some time to chime in and post suggestions. These openSUSE forums are a volunteer effort. Those participating are not paid for their efforts so sometimes it can take a few days to garner an appropriate response.

I don’t understand what happened… I tried to install suse one more time, this time choosing the secure boot,… now, no suse, no windows, the recovery partition is gone!!! (how??)

Now I’m trying Sony support to see if I can have an image or something to put the full disk back to the original state.

I’m really mad about all this… instead of doing some work that I have to do… I’m trying to “unbrick” the laptop… fck!

Does anyone have any idea?

Does a live KDE USB boot ?

Anyway, after you get the Sony Vaio Pro 13 back and running with Windows-8.1 I do have some ideas. But geting Windows-8.1 running 1st is a pre-requisite for my ideas, assuming you want Windows to run in a dual boot.

1st (and do NOT skip this step) - create a dedicated Windows-8 recovery USB stick. I did that with my Toshiba Ultrabook (with UEFI). If you had done this with your Sony, you would not need to worry about not booting from a recovery partition (and not need to contact Sony support), as all the needed data to re-install is on the recovery USB stick. Windows-8 provides the functionality for creating such. Apologies for not proposing this earlier, but I confess I had thought having an external USB-stick (or external DVD for PC’s with external or internal DVD drives) backup was something everyone did independent of any GNU/Linux efforts - so I didn’t even think to mention it.

2nd (and do NOT skip this step) - backup the UEFI partition and store on another USB stick. This was the very 1st thing I suggested previous and it is very important to provide additional less drastic (than a full Windows-8 recovery) options if things go wrong.

This is the scheme of the hard drive in a sony vaio pro if it helps

I found your post searching for info to make a dual boot on the same laptop, i did a backup of the whole disk with acronis for all the partitions and a backup cd just in case something like this, i was thinking only to touch the last two partitions, resizing the 4th one and erasing the 5th, to make some space.
Dont know much about Uefi, sorry i hope that you can recover your lap

Hi all,
the good news: I have my laptop again with w8 (clean install)… now I have 25GB more of hard drive! :smiley: (due to the lost of the recovery partition) … so, not everything was bad :slight_smile:

the bad news… I still don’t know how to solve the initial problem, dual boot with opensuse.

I need a working laptop (because I need to work on it!) and so I cannot be doing “try…catch” with opensuse installs and hacking stuff to the bios/boot/uefi … So, unfortunately, for now I will have to live with w8 only, until someone posts a step-by-step trustworthy tutorial on how to put this laptop with w8/opensuse dual boot.

I would like to do it… but I don’t have the time nor the patience to be installing and formatting everyday… :frowning:

Thank you all for your help! Hope to see some solution for this soon.


On Tue 22 Oct 2013 01:06:02 PM CDT, ru1marante wrote:

Hi all,
the good news: I have my laptop again with w8 (clean install)… now I
have 25GB more of hard drive! :smiley: (due to the lost of the recovery
partition) … so, not everything was bad :slight_smile:

the bad news… I still don’t know how to solve the initial problem, dual
boot with opensuse.

I need a working laptop (because I need to work on it!) and so I cannot
be doing “try…catch” with opensuse installs and hacking stuff to the
bios/boot/uefi … So, unfortunately, for now I will have to live with
w8 only, until someone posts a step-by-step trustworthy tutorial on how
to put this laptop with w8/opensuse dual boot.

I would like to do it… but I don’t have the time nor the patience to be
installing and formatting everyday… :frowning:

Thank you all for your help! Hope to see some solution for this soon.


If you boot from a live cd what is the partition layout like now? Have
you updated the system to windows 8.1 yet? If not I would suggest
sorting that out first. Does the system have a DVD drive?

On my HP 2000 system I removed the DVD and installed a HDD caddy for
additional drive space.

What are the applications you need to run, crossover may be an option
to install/run the. It is wine, but has additional features/tools.

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.93-0.8-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I understand the sentiment … for example I waited > 1 year before I updated the OS in my Android Tablet from v.4.0.3 to a newer Android OS version for similar reasons. I wanted a ‘foolproof’ guide, and of course a ‘foolproof’ step-by-step tutorial/guide with the exact level of hand-holding that I wanted never appeared. But eventually a guide with sufficient level for me to understand did appear, and the possible impact if I bricked my Tablet lessened (after some reading and after my taking LOTS of precautions), and I was then able to take the chance (which with hindsight turned out to be next to no chance of bricking, given my conservative nature and given my reading, and given my knowledge/precautions).

I think thou, that the wording ‘foolproof’ is more accurate than ‘trustworthy’. We all can be trusted to try our best, … we are all ‘trustworthy’ … but whether we can think of every possibility, especial given the VAST diversity in UEFI implementations amongst the various laptop/desktop manufacturers is not likely. The manufacturers can not be relied on to have a common implementation of UEFI. That difference will currently break GNU/Linux installs for every GNU/Linux distro to varying degrees.

wrt your Sony Vaio Pro 13, if my colleague ends up installing openSUSE-12.3 or 13.1 successfully , I’ll endeavor to post what I learn. What I post thou, may not be a step-by-step tutorial. It will be as ‘trustyworthy’ as I can make but it most definitely won’t be ‘foolproof’. It won’t even come close wrt ‘foolproof’. I anticipate problems wrt the windows8 boot, but I am also fully confident to be able to recovery from an unplanned damage to the boot.

Before starting an installation, as Malcomlewis has aluded by his questions, it is likely 100% ESSENTIAL that you provide some information to reduce/minimize risk wrt any installation effort.

How did you recover it?

Hi there again,

first, thank you all for your help.

now… when I said “trustworthy” step-by-step tutorial on how to get dual boot w8/opensuse without getting into trouble, what I meant was in fact, some help on the steps on how to do it from someone that was already brave enough to try-catch-debug until it was really done on this same laptop. I was not saying/calling no one untrustworthy. It was just a bad choice of words… and English is not my native language, so sometimes I just don’t express myself well.

About the recovery of my laptop, I’m going to put here the steps because it may help someone with the same problem:
So, my laptop was unbootable and unrecoverable because I lost the 25GB recovery partition (somehow) during my trials on installing opensuse. (and because I was stupid and did not did a full backup before starting the opensuse install…)

Steps to recover (clean install of Window 8):
1 - download Windows 8 iso image (it is critical to download the exact same version that came with the laptop… in my case Windows 8 - see point 12 about this)
2 - prepare a ubs stick to be bootable (instructions here: Using DISKPART to create a Bootable USB of Windows 8 | PowerBiz Solutions)
3 - extract the iso image to the usb stick
4 - download from Sony Web Site (support) the minimum necessary drivers to put all the computer devices working (I will put a list of the files below) - put this file on another usb stick
5 - with the laptop turned off, press the assist button to go into the UEFI bios (set bios mode = UEFI and boot mode = SECURE)
6 - exit the bios (saving the settings) and then select boot from usb external device (the usb stick with Windows must be already connected) (see points 1, 2 and 3)
7 - windows installations will begin (fallow the steps… next, next next… as usual… during this process, when prompted for windows partition where to install the Windows, delete all the present partitions and then create two partitions (one for windows and another one for the future installation of Linux :wink: ) - windows will automatically create other two small partitions (one for UEFI and other for recovery command-line tools)
8 - everything should go smoothly and you will end up with a clean installation of Windows 8
9 - remove the usb stick and plugin the other one (with the drivers)
10 - install all the drivers (a reboot after each one is recommended… you know how it is with windows…)
11 - by now you should have a working laptop!
12 - now, and only now, connect your laptop to the network (internet) and you can see that your windows will instantly be activated (this happens because windows reads your windows-product-key from the UEFI bios… and this is also why during the installation you will not be asked for the product key - nice!)
13 - now, update the windows several times until there are no more updates available (with the usual reboots in the middle) (don’t update the apps from the store even if you get warnings about apps that need to be updated)
14 - go to the windows app store and you should see that the windows 8.1 upgrade is available (do so if you wish)
15 - now, and only now, install your favorite anti-virus software (it is important to leave the anti-virus to the end because it can cause interference with the previous steps… do a full scan just to check that you are fine :slight_smile: )

And, this is how I recovered my laptop.


  • at least 25GB more of disk (no recovery partition on the disk)
  • no “garbage” software installed (those software packages that came with the laptop… office and anti-virus trials, stupid games and other stuff…)

List of necessary drivers (see point 4):

  • INDMEI-00295815-0082.EXE
  • INDNFC-00295907-0082.EXE
  • INDOTH-00295906-0082.EXE
  • INDVID-00296376-0082.EXE
  • INDWLL-00296585-0082.EXE
  • REDMCC-00295911-0082.EXE
  • SOAVLU-00286395-0082.EXE
  • SODFEP-00270203-0082.EXE
  • SPDTPD-00294670-0082.EXE

At this point it is a good idea to make a full backup of the windows (there are several software packages that can do this… don’t forger to include all the partitions on the backup - windows + UEFI + recovery) so you can recover if something goes wrong in the future… and so you don’t need to do this full process again.

Ok, that’s it! Hope this helps!

And please, if you have news on how to put opensuse dual booting with w8… let me know!! :wink:


Just in case this can be helpful, now, my laptop boot and disk partitions are like this:

C:\WINDOWS\system32>bcdedit /enum

Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {xxxxxxxxxxxxxxxxxxx}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 8.1
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {xxxxxxxxxxxxxxxxxxx}
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {xxxxxxxxxxxxxxxxxxx}
nx                      OptIn
bootmenupolicy          Standard


DISKPART> list vol

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     C                NTFS   Partition    145 GB  Healthy    Boot
  Volume 1     D                NTFS   Partition     91 GB  Healthy
  Volume 2         Recovery     NTFS   Partition    300 MB  Healthy    Hidden
  Volume 3                      FAT32  Partition    100 MB  Healthy    System