sony vaio laptop and Fn keys not working in 11.0

Hi All,
I’ve just installed several days ago opensuse 11.0 nearly in the default presets apart from selecting KDE 3.5 and found that no Fn keys are working.
I also installed spicctrl and found that the command line can change the screen brightness but nothing works using the Fn key. On the same Sony Vaio S2HP (European name) the Linux Mint 4 KDE edition works with Fn keys.
I found in lsmod that sony_laptop module was added by default and I even added sonypi and still nothing.
After that I’ve installed KDE 4 and as the Fn didn’t work I also installed kde4-kmilo and still nothing.
Can you please help me solve this issue?
Once I solve this problem I will be able to install it also on another desktop and laptop as I do not want to use more than one distro.

Thank you very much for your help,

Should I submit a bug as I see no help in the forums?


I have this same problem on a VAIO VGN-SZ430N. The Fn keys worked just fine in ubuntu, but here it just doesn’t work.

I wish someone could post a simple fix for this :frowning:

Please submit a bug report and post any progress you get.

I tried to solve this problem but looks like compatibility issues between the sony_laptop kernel module and the BIOS on our laptops. Before for sony they’ve used the sonypi and that was working.
Opensuse has a bug opened from the time of 10.2 with this kind of issues but some of the laptops are not supported. shows that even other distros have problems.

I will try to double check the steps from these bugs and try to fix it but looks like there is little chance for this.


hi everyone

  • they don’t work for me in 10.3 either :frowning:
    – apparently the sonypi and another module intended to make it working, all i can get with that intallation is brightness percentage changing on the screen without any change in brighness!
  • the cooling fan (i imagine that is a cpu fan) keeps roaring all the time - haven’t been able to do anything with kpowersave either… >:( …this one is really sad

any ideas please ?

I’ve just discovered the same problem having updated my VGN S270P to openSUSE 11.0. The function keys and on-screen display have worked with no problems for me using 9.2, 9.3, 10.0, 10.2 and 10.3, but not any longer.

The sony-laptop module is loaded and seems to boot with no issues, but it says that sonypi is not loaded when I go to the KDE 3.5 Control Centre section for the Vaio. I don’t really understand how to get sonypi added, but from the post above it seems that won’t make any difference anyway.

I also downloaded the spicctrl from the Build Service, since I couldn’t find it in my package list. Although I grabbed the 1.9 version, when I run it the opening message says it is 1.8. I’m not sure if this is because it was originally installed on the machine years ago from a source package rather than a RPM, and I don’t know how to go about uninstalling the original if so. Regardless, that doesn’t seem to be the issue either.

When I press the Fn keys for volume / brightness etc., there is hard disk activity, but nothing actually happens. I’ll try to file a bug report if I can find out how to do it.

Perhaps I spoke too soon. The Fn keys do appear to work when logged in as root (as does the KDE Control Centre Vaio module) but not as a user. Not sure if permissions need changing somewhere. All the Fn keys are okay except brightness+, for some reason, which was always fine before.

check this file and add your model


This doesn’t work for me, unfortunately, although I can’t be completely sure if the format of the model string I entered is how it needs to be. I can’t find anywhere on my system info where the model of my machine is actually recorded.

to know the write name to write in this file…

lshal | grep system.hardware.product

This almost works correctly now. I’d guessed my model string as being VGN-S270P, whilst this command specifies it as VGN-S270P(UC). As root, the brightness+ key is a little erratic. The first press acts as brightness-, whilst subsequent presses act as brightness+. However, it’s impossible to get it to return to 100% brightness once adjusted. It will only ever go up to 94%.

Still get no response at all when logged in as user.


i couldnt even add my model to this file since it isnt allowing me to save it after editing it, it is giving me an error telling me that i dnt have the permission to do that…

so?? what to do??
i would appreciate if someone can reply! thx in advance!

to edit this file, you have a couple of options.
first, you can open the terminal and type “sudo nautilus” and enter the root password, then edit the file that way.
this creates a file manager with root access and lets you open any file with root access as well.

or, you can also type in “sudo gedit /path/to/file/” where gedit is just a basic txt editor. gedit can also be replaced with any other text editing program, like if you use KDE or want to use something like emacs, vim, etc.

also, I have a sony VGN-FW139E and none of these methods works.
I’ll keep posting here since im a linux “helper” (in between a n00b and someone thats knows their way around…), but I’m also starting my own thread for this., ill edit with link later.