Sony vaio - brightness and sound

I have installed 11.1 recently on my laptop and everything seems to be working fine except for LCD brightness control (neither power management setting under gnome nor the function keys) and sound output (not muting the internal speakers). I tried several methods posted on other forums but no luck.

I have a Sony Vaio VGN-NR38M with Intel graphic card.

Any suggestions?

Speakers not muting can be very irritating. I find that an essential feature for a laptop.

In my case, to help with muting, more information is necessary. With your laptop connected to the internet, open a kde konsole or a gnome terminal and with root permissions, type a couple of times: /usr/sbin/ the first time should update the script, and the second time the script will upload your sound software/hardware config to a web site and give you the URL address. Please post the URL address here. Just the URL.

Also, in a gnome terminal or kde konsole, send the following commands and post here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

With that information I hope it will be possible to provide a good recommendation.

Here’s my URL from

Output from terminal:

linux-p9h8:/home/pawel # rpm -qa | grep alsa
linux-p9h8:/home/pawel # rpm -qa | grep pulse
linux-p9h8:/home/pawel # rpm -q libasound2
linux-p9h8:/home/pawel # uname -a
Linux linux-p9h8 #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
linux-p9h8:/home/pawel # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.XWUnASPgADB:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=vaio enable=1 index=0 position_fix=1

The last line in /etc/modprobe.d/sound was added by me following advice on some forumbut it didn’t work.


Thanks, according to that your Sony has an ALC262 hardware audio codec.

I searched the alsa web site for information on the ALC262 hardware audio codec, and found this link: Search results - AlsaProject and this link: Search results - AlsaProject which suggests there was an update for one model of Sony that comes with version 1.0.19 of alsa (you have a mix of 1.0.17 and 1.0.18 on your openSUSE-11.1). So its possible an update to your alsa version may help.

My understanding is one has to be very precise when selecting the group of model options to use. For the ALC262, I note this from 1.0.19 of alsa’s HD-Audio-Model.txt file:

  fujitsu	Fujitsu Laptop
  hp-bpc	HP xw4400/6400/8400/9400 laptops
  hp-bpc-d7000	HP BPC D7000
  hp-tc-t5735	HP Thin Client T5735
  hp-rp5700	HP RP5700
  benq		Benq ED8
  benq-t31	Benq T31
  hippo		Hippo (ATI) with jack detection, Sony UX-90s
  hippo_1	Hippo (Benq) with jack detection
  sony-assamd	Sony ASSAMD
  toshiba-s06	Toshiba S06
  toshiba-rx1	Toshiba RX1
  ultra		Samsung Q1 Ultra Vista model
  lenovo-3000	Lenovo 3000 y410
  nec		NEC Versa S9100
  basic		fixed pin assignment w/o SPDIF
  auto		auto-config reading BIOS (default)

There is no mention of the model “vaio” there for the ALC262.

I recommend you:

  • 1st update your alsa and
  • 2nd, if alsa update is insufficient by itself, try each of the model options for the ALC262, one at a time (restarting your sound driver in between each

To update your alsa version, there is guidance here: Alsa-update - openSUSE which in the case of your PC means send the follow six zypper commands (see below). To do that, open a gnome terminal or a kde konsole, and with your PC connected to the Internet, type “su” (no quotes - enter root password when prompted) to get root permissions and then copy and paste the following six zypper commands in sequence, one at a time, into that konsole / terminal :

zypper ar multimedia 
zypper install alsa alsa-utils alsa-plugins alsa-plugins-pulse alsa-oss alsa-oss-32bit alsa-tools alsa-firmware libasound2
zypper rr multimedia
 zypper ar multimedia 
 zypper install alsa-driver-kmp-default 
 zypper rr multimedia

and then restart your PC and test your sound.

If that does not work, then edit your /etc/modprobe.d/sound file so that it looks like this (with the model “auto”):

options snd slots=snd-hda-intel
options snd-hda-intel model=auto
# u1Nb.XWUnASPgADB:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and restart your alsa sound driver with su -c ‘rcalsasound restart’ and restart your mixer, and test your sound. If that does not work, replace “auto” in that /etc/modprobe.d/sound file with “fujitsu” , restart your alsa sound driver, restart your mixer, test your sound. If “fujitsu” does not work, try another option from the list I quoted above, and keep trying until you find one that works. Only one at a time.

The option sony-assamd in /etc/modprobe.d/sound worked! Thanks a lot oldcpu.

Any advice on screen brightness?


Great !! Congratulations on sorting this and thank you for sharing your solution.

No, sorry, nothing to add there. Fortunately our old family Fujitsu Amilo 7400M laptop and new Dell Studio 15 laptop “just worked” with openSUSE Linux for screen brightness.

Someone else will need to chime in for your “brightness” problem.

I have installed the latest kernel from Factory and brightness buttons are working perfectly now,but the volume buttons stopped working :’(
When installing the kernel I had some dependencies problem with some alsa package but I choose to ignore it. Could this be it? There are no new version of alsa packages in the repository.

I’ll try to compile new kernel, maybe this will help.


Same problem here :frowning:

pavkw, which factory kernel did u intall? version?
I tried to compile 2.6.30-rc7 but brightness controll still does not work :frowning:

Once one starts installing factory applications, then one is close to a “no mans land” area where minimal to no testing has been done. Hence many things could break.

You could take a look at this wiki to see if it might help:
how to get Hp Mutimedia Keyboard buttons to work - openSUSE Forums

The thread relating to that wiki is here: how to get Hp Mutimedia Keyboard buttons to work - openSUSE Forums

Sorry to say but I became too frustrated with OpenSUSE and have moved to a different distribution.

But perhaps those things should be fixed in 11.2?


I don’t know if it will be addressed in 11.2. If it is working in another distribution, you could check what kernel version, and what applications the other distribution is using, and then check to see if those versions are to be included in openSUSE-11.x

Further more, we are looking for testers. The only people who will test 11.2 are users like YOU and ME. And if we don’t do it (the testing) then I don’t know who will. I suspect if we don’t do the testing, then nobody will.

So we need help !!

So if you have a spare PC, or a sufficient hard drive space to afford some spare partitions (and are confident to handle any bad behaviour by grub boot manager) then PLEASE install 11.2 milestone-2, and start testing. Note this is NOT for a main PC, but rather for a test PC or a test partition.

The call for testers is here: openSUSE-11.2 - CALL FOR TESTERS - openSUSE Forums

I’m having the same issues with my Sony Vaio and I was hoping that I can solve it this way but I have an ALC260. I tried to find the HD-Audio-Model.txt file to try the same technique but I couldn’t locate it.
Anyway here are the details:
dan@bonaire:~> rpm -qa | grep alsa
dan@bonaire:~> rpm -qa | grep pulse
dan@bonaire:~> rpm -q libasound2
dan@bonaire:~> uname -a
Linux bonaire #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux
dan@bonaire:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.pEJFnZjN46E:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

and here is the location of my alsa details:

Thank you in advance oldcpu for your support to the community.

By the “same issues” do you mean sound works, but when you plug in your headset sound is muted?

In future, PLEASE start a new thread. If one of the users who have already posted in this thread were to start posting again, I would need to hunt back and forth to get the technical details, and I find that difficult. My memory is so poor I can never remember various users sound problems from one post (or one day) to the next, and hence that sort of hunting back and forth is needed by me to refresh my memory.

One has to download the tarball of 1.0.18 (or now 1.0.20) to find the HD-Audio-Model.txt file. However in your case you have 1.0.18 of alsa, and not 1.0.20, and for 1.0.18 of alsa there is no HDA-Audio-Model.txt file (for the HDA-Audio-Model.txt file was introducted in 1.0.19 of alsa) . Instead the information you need is in the alsa-configuration.txt file for 1.0.18 of alsa.

So if I look in 1.0.18 of alsa-configuration.txt file I find:

	  hp		HP machines
	  hp-3013	HP machines (3013-variant)
	  hp-dc7600	HP DC7600
	  fujitsu	Fujitsu S7020
	  acer		Acer TravelMate
	  will		Will laptops (PB V7900)
	  replacer	Replacer 672V
	  basic		fixed pin assignment (old default model)
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
	  auto		auto-config reading BIOS (default) 

If I search on ALC260 of alsa I obtain this (which notes there are updates to the ALC260) in the more recent alsa versions up to 1.0.20 of alsa:
Search results for ALC260 - AlsaProject

I took a look at that, … it confirmed a 32-bit openSUSE-11.1 with the kernel and the ALC260 as you noted. I checked the mixer settings and I could not spot anything obviously wrong there.

So you could try forcing a model option per the output of the alsa-configuration.txt file for the ALC260 that I posted above. Failing with that you could try updating alsa.

There is general guidance here

If you need more detailed guidance (as the above may be too complex for you) then post I can walk you through it (in essence I will pull extracts out of those guides).

hi oldcpu, sorry for late reply but i was sick with a cold for more than a week. Should I open a new thread for this one?
I was trying to follow your instructions and I updated the /etc/modprobe.d/sound file but encountered this error when trying to restart rcalsasound restart
Starting sound driver: hda-intelFATAL: Could not load /lib/modules/ No such file or directory
but the file exists I just don’t know what’s going on. I tried to switch back to the old configuration but same thing. Now I cannot restart and lost the sound completely. So let me know if I should open a new thread. thanks

Yes please, start a new thread.

Your timing is not good, unfortunately. A new kernel was released yesterday, and that could add complications to getting your sound to work.

I am also leaving on a 3-week vacation on Tuesday next week, and hence my replies on vacation may be very intermittent and sporadic due to not having internet access for a good portion of the holiday.

I will start a new thread and refresh it by end of June. Enjoy your vacation!

For those with non-functioning sound as a result of the new kernel, the SuSE-GmbH packager has now released the rpms for the update to 1.0.20 of alsa for the kernel. Note this is on a special multimedia repository and not on the standard “update” repository.

There is guidance here for doing the update:
Alsa-update - openSUSE

Note one MUST send six zypper commands, being certain to pick the one’s specific to one’s openSUSE version. I recommend one optimize the alsa apps to be installed to match what one has on one’s PC already. … and also the second last command in the 3 command group should be specific to one’s kernel. Do NOT install multiple alsa-driver-kmp-<packages> … Only install the ONE that is applicable.

Did anyone get Sony VAIO brightness hotkeys working??
For me, sound hotkeys are working perfectly but brightness hotkeys don’t work.:frowning:

mukuls wrote:
> Did anyone get Sony VAIO brightness hotkeys working??
> For me, sound hotkeys are working perfectly but brightness hotkeys
> don’t work.:frowning:

Do you have the module named “sony-laptop” loaded? Check the output of
the command ‘lsmod | grep sony’. If that does not list a line with
“sony-laptop”, then you need to use the command

sudo /sbin/modprobe -v sony-laptop

If your brightness controls now work, you should add the module name
to the modules loaded on boot. You can do that with YaST => System =>
/etc/sysconfig Editor.

mukul@linux-w5lp:~> lsmod | grep sony
sony_laptop            35200  0

So I believe the module is already loaded. Still I cannot get the brightness keys working.