Songs won't play in some apps, will in others.

I’m running OpenSUSE 11.2. My sound has an issue, it must be played through PulseAudio. Phonon or whatever the default is kept dropping the ball, so I made PulseAudio the default sound server by doing:

setup-pulseaudio --enable

So now, I get something as opposed to nothing. But Amarok still wasn’t playing my songs, even after telling it to prefer PulseAudio for all outputs under Settings>Configure Amarok>Playback>Configure. I hit “Test” and the sound played. But it wouldn’t play any songs from my music library. So I navigated there in Dolphin, found a song, right-clicked, and decided to Open With every audio program associated with it. Banshee and Mplayer worked. Kaffiene, Totem, and Amarok did not (though I could see that Amarok at least queued it up). What gives?

Please follow
Multi-media and Restricted Format Installation Guide - openSUSE Forums

It worked, thanks! But why did Banshee and Mplayer play the same song while the others did not? I thought the codec was either there or it wasn’t?

To keep the explanation simple:

Not all applications use the same backend (xine or gstreamer).
Making sure all multimedia is from packman is the key to getting everything working.
You only need libdvdcss from the Videolan (libdvdcss repo) - You should then remove this repo to avoid any mixup in future. The libdvdcss package will remain.