(Somewhat) official repository for newer kernels?


Are there any official, almost-official or maybe even reasonably stable kernel repositories with new kernels for opensuse 11.2? I recently changed my laptop for a new one which has some issues, which then again are solved in 2.6.33 (and even in 2.6.32 with some tweaking). I would by any means try to avoid kernel recompilation.


There is this:ftp://ftp5.gwdg.de/pub/opensuse/repositories/Kernel:/HEAD/openSUSE_11.2

openSUSE does not provide major kernel upgrades to a distribution’s version. You will only see updates to 2.6.31 in the “official repos”, i.e. Update. If you want another kernel, either use the above at your own risk, or compile your own kernel.

maybe the 11.3 M6 kernel would wind your watch…but, maybe not…be
sure and backup first…


note: i am not recommending any of the above

maybe best if you just fetch a 11.3 M6 Live CD and see how it works:

any and all questions on that software goes to

DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Until 2 hours ago, the HEAD kernel was the same as for M6. Now 2.6.34-rc7 is in the HEAD repo. I have it running on my laptop. No issues so far.
Mind again: forgot to mention that installing this kernel will remove some installed packages, IIRC preload-kmp. I have not found any delay or slowdown after doing so.

Thank you both for quick replies.

The problem I’m experiencing is related to USB ports, being dead after the machine wakes up from sleep mode, so I guess a live CD wouldn’t prove much.

Additional problem which maybe waits for me is related to NVidia drivers, which I’ll obviously need to compile manually, even more I’ll have to use beta ones…

Just to complete the story, this new laptop is Lenovo ThinkPad T510, which is really great and better than the old one, ThinkPad R61, but on R61 I had some crazy uptimes for a laptop, actually I used to reboot the machine only on kernel updates, everything worked flawlessly.

Thanks again,

Unfortunatelly, computer won’t even boot with the latest, 2.6.34-rc7 kernel. It looks like that kernel doesn’t have compiled support for ext4, which is quite strange. No luck here…

Something went wrong during your attempts to install the kernel. Don’t know what, but IMHO it can be fixed. You will need an 11.2 LiveCD. Download one, burn the ISO to disk and boot from it. Get back here as soon as you have that, I can help you through.

Hi Knurpht, and thank you very much for your kind offer.

Fortunatelly, I managed to revert the stable kernel and right now I’m tweaking other packages, nvidia driver and so on. 10+ years in linux make you kernel-panic-proof :slight_smile:


Pre: You need to have the Linux Kernel Development Pattern installed through the software installer.

NVIDIA driver download page: ftp://download.nvidia.com/XFree86/

Current NVIDIA version 195.36.24

To install, start in runlevel 3
sh NVIDIA…run -q, accept all,
init 5

10+ in linux should make this mean something to you :wink: . Nice you got it sorted though.

Tested this tonight: Reinstalled 11.2’s 2.6.31 kernel-packages, incl. sources, added Kernel:HEAD repo, started software installer, selected the Kernel:HEAD repo in the repo view, clicked the “Switch system packages to…”, accepted, installed, rebooted, all OK, back on 2.6.34-rc7 again, NVIDIA driver installs without problem.



Thanks for your detailed description. I’ve followed the steps, installed the Linux Kernel Development pattern and upgraded my kernel:

davor@linux:~> uname -a
Linux linux 2.6.34-35-desktop #1 SMP PREEMPT 2010-05-20 21:31:23 +0200 i686 i686 i386 GNU/Linux

However, NVidia driver fails to load. It seems to be compiled correctly, but not installed and loaded. I’ve tried both 195.36.24 and 195.36.15 versions, with the same results. This is the error log message (from 195.36.15):

   /usr/src/linux-2.6.34-35/arch/x86/include/asm/mmzone_32.h: In function ‘pf
   /usr/src/linux-2.6.34-35/arch/x86/include/asm/mmzone_32.h:87: warning: compa
   rison between signed and unsigned integer expressions
     ld -r -m elf_i386 -T /usr/src/linux-2.6.34-35/scripts/module-common.lds --
   build-id -o /tmp/selfgz14424/NVIDIA-Linux-x86-195.36.15-pkg1/usr/src/nv/nvid
   ia.ko /tmp/selfgz14424/NVIDIA-Linux-x86-195.36.15-pkg1/usr/src/nv/nvidia.o /
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
       frequently when this kernel module was built against the wrong or
       improperly configured kernel sources, with a version of gcc that differs
       from the one used to build the target kernel, or if a driver such as
       rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
       obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU
       installed in this system is not supported by this NVIDIA Linux graphics
       driver release.
       Please see the log entries 'Kernel module load error' and 'Kernel
       messages' at the end of the file '/var/log/nvidia-installer.log' for
       more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
   -1 No such device
-> Kernel messages:
    2712.852192] NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel
    2712.852192] NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
    2712.852193] NVRM: support), then try loading the NVIDIA kernel module
    2712.852198] NVRM: No NVIDIA graphics adapter probed!
    2902.163757] CPUFREQ: Per core ondemand sysfs interface is deprecated -

no nvidiafb, rivafb nor rivatv are loaded, graphic card is supported. gcc looks suspicious, although I don’t where’s the problem:

davor@linux:/usr/src> rpm -qa | grep gcc

Kernel related packages I have installed are:


Any ideas?


Eh… I remembered that “native” nvidia module is now available in kernel sources, nouveau, which NVidia installation procedure didn’t mention. I had to blacklist it in /etc/modprobe.d/50-blacklist.conf

After restart, nvidia driver compilation procedure finally succeeded and now I’m happily running 2.6.34 with the lastest nvidia driver!


It is tricky when you have multiple kernels and different versions of all the related packages. So do you really need all that?

Right now I have only one kernel (the newest one, 2.6.34, check my older posts to see which packages are installed) which has been installed over the original one, Other, non-kernel related packages are the same and everything works just fine.

However, I remember my older days when I had enough patience to poke my system here and there: having many kernels on the same system is quite possible and could be done without any problems, especially when the kernels are of the same major version (e.g. 2.6.x) and reasonably compatible.

I found this guide on compiling a kernel:

Beli’s blog » Compiling kernel in openSUSE – easy way

I believe theres was a post somewhere on the forum with a simple way of compiling too, couldnt find it though.

Yes, user lwfinger’s;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 1:48, 4 users, load average: 0.22, 0.25, 0.19
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Theres a thing i quite dont understand, if i download the .bz2 kernel from kerne.org, and then unpack it, whats the next step?

After you uncompress the bz2 archive and then change to the directory
and run the commands…

oscar-sled:/data/build/$ tar xjf linux-
oscar-sled:/data/build/$ cd linux-
oscar-sled:/data/build/linux-$ cp /proc/config.gz  .
oscar-sled:/data/build/linux-$ gunzip config.gz
oscar-sled:/data/build/linux-$ cp config .config
oscar-sled:/data/build/linux-$ vi .config
oscar-sled:/data/build/linux-$ make
HOSTCC  scripts/basic/fixdep
HOSTCC  scripts/basic/docproc
oscar-sled:/data/build/linux-$sudo make modules_install install

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 5:54, 2 users, load average: 0.18, 0.18, 0.11
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Simpple and Clean, thanks!