something wrong with gnome!

I need some help with my system. I have just reinstall opensuse 11.1, install the nvidia, codecs and compiz-fusion all from 1-click install. Then i update the packages from package manager from yast. After the restart the system in unstable, it has installed the gnome 2.26, the bar with close, minimize and maximaze don`t appear, the graphic look horrible. I get this message when i log in:

(zenity:10070): Gtk-WARNING **: GModule (/usr/lib/gtk-2.0/2.10.0/engines/ initialization check failed: Gtk+ version too old (micro mismatch)

and the X process is now using 98% the proccesor.

Please help me. I don`t want to reinstall the system, i just did it.


I do know that after any install from the openSUSE cd’s or DVD there is a kernel update that you have to install. So usually if I reinstall on my Nvidia machine I’ll install everything, update and bring in the kernel update, restart, then install my drivers.

As for your compiz-fusion problem I might be able to help with that. Open up CompizConfig Settings Manager (CCSM) and under effects make sure Window Manager is checked. Then click into it and find the entry Command and type this into it

emerald --replace

Then logout and log back in.

Hope that helps with the window decorations problem,


Edit: also did you try running sax2 to get that to recognize your card?

when i open ccsm i get an error:

(ccsm:6104): Gtk-WARNING **: GModule (/usr/lib/gtk-2.0/2.10.0/engines/ initialization check failed: Gtk+ version too old (micro mismatch)

(ccsm:6104): Gtk-WARNING **: GModule (/usr/lib/gtk-2.0/2.10.0/engines/ initialization check failed: Gtk+ version too old (micro mismatch)
Info: No sexy-python package found, don't worry it's optional.
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 99, in <module>
    import compizconfig
ImportError: cannot open shared object file: No such file or directory

the compiz fusion i didnt activate it..i just installed the system update it the installed the nvidia and compiz then update it again and after a reboot that is what i get. Is not the first time when i install opensuse, this is i do every time, but i dodnt know what it has this time. :’(

Why the need to update Gnome and Compiz? The defaults install of 2.24
works fine, compiz etc?

What you need to do is probably re-install your system, run updates
to get the newer kernel and other updates.

Then install the codecs, nvidia driver and then image your system
(partimage) off to a backup source.

Then look at just upgrading gnome (if you must) and see how that goes

If it all doesn;t work, roll back with your image.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 22:41, 1 user, load average: 0.27, 0.27, 0.24
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

First of all i installed the system again, update the kernel and other packages, but i did not install the Compiz-Fusion and now works great.

What i found here is :

Compiz on openSUSE 11.1 hates me

Start yast2 software management, search and remove everything related to compiz. Remove old configurations (rm -rf ~/.config/compiz), now use this 1-click installation to get new compiz packages. Enable compiz via simple-ccsm (“Desktop Effects” in main-menu).

I remove all the things that i have about compiz and installed from 1-click. I receive an dependencies error.

You can see it from here.

I ignore the dependencies, and then it adds some repositories: Gnome Factory, KDE Factory which from those repositories, the Software Management from yast finds the upgrade packages for gnome 2.26.

When i want to start the ccsm it doens`t start. So i removed again all related about compiz, the repositories and now back to normal :slight_smile:

But, how can i install the compiz-fusion? Other times i installed from 1-click but now it doesn`t work.

Can anyone help me with this problem?


Not sure if you still need help with this, but for the conflicts that yast is giving you, choose

[X] Do not install compiz-0.7.8


[X] Do not install compiz-gnome-0.7.8

It’s mixing packages up. When you tell it not to install those, it will automatically install the 0.8.2 versions instead, which is what you want.

Good Luck,