Some wireless/wired issues: D-Link WDA 2320

Hi there, I’m sort of a newbie when it comes to linux - I’ve dabbled for years but always had to go back to Windows because of the lack of support for VST (virtual synth tables) in Linux. Long story short, that’s changed a lot over the past year or two and I’m trying my hardest to make the switch now. So I’d describe my level of proficiency as lower, but not totally incompetent.

Anyway, I installed 11.0 RC1 the other day and it was just a dream. Apart from really goofy GRUB errors (my second SATA drive has a WXP-SP3 install on it that GRUB bizarrely reports as “windows-1” and “windows-2” - neither of which will boot; I have to go into the bios and manually set the second sata drive to boot in the HD boot priority list), the whole thing was a pretty good process. However, my D-Link WDA 2320 - although recognized generically out of the box, won’t work.

I’ll fill this out and then sum up at the end:

1 ) make and model of wireless device. D-Link WDA 2320
2 ) driver version in use - whatever the default 11 RC1 driver is
3 ) any error message. - just simply, won’t connect to network. it doesn’t give an error when I run through the configuration.
4 ) what you have tried to rectify the problem. My wireless router is set up with DHCP so i set my card to DHCP, entered the WEP key (pass phrase) and hit finish, just like with any other device i’ve hooked up to my network (macbook, iphone, laptop, etc)
5 ) any trouble-shooting guide you have tried to follow. none - i figured i may be missing something obvious
6 ) openSUSE version: 11 RC1
7 ) type /sbin/lspci -v" in a terminal; copy and paste the section that identifies your wireless card and it’s chipset. Can’t copy-paste from there, because I can’t connect to the internet. Right now I’m on a windows machine.
8 ) if it is a usb device type lsusb in a terminal;copy and paste the result (not a USB device)

The odd thing was, I connected via wire to my router, and even that didn’t work.(??) Just wondering, in Windows it doesn’t matter if there are both wired/wireless connections going on at the same time, but in linux does it conflict? they’re both set DHCP so I don’t know why it would. I know the network works because I have a skype phone base station hooked up (dhcp) via a wire to the router and it works just fine.

System specs:

Intel quad core (2.4)
Abit mobo, IP35
4gb ddr
1 dvd-rw (sata)
1 dvd-rw (ide on Jmicron sata/ide, for boot purposes since the sata dvd-rw won’t boot the system for some frustrating reason)
nvidia 8800 GT
M-Audio USB Mobile Pre
D-Link WDA 2320

I think the network thing is the most frustrating because there’s barely anything I can do to move forward with this without connectivity…once that’s done, I can spend more time messing about with the other problem areas (GRUB, recognition of my mobile-pre). Thanks for any help!!

Moved thread to Pre-release Beta forum

The D-Link WDA 2320 should have an Atheros chipset. You need to install the Madwifi drivers for that. I have no idea what the current state of Madwifi is with regard to the kernel present in OpenSUSE 11.0 RC1. Someone else can help hopefully. Normally it’s just a matter of adding the madwifi repository to YaST then installing 2 packages. If you were running OpenSUSE 10.3 I could walk you through it in a couple of minutes.

Madwifi have been releasing packages for openSUSE 11.0 betas and RCs.

Open up YaST Software Repositories and add the following URL: (http -> fill in appropriate details)

Index of /suse/11.0

then open up YaST Software Management and install the


package. It should automatically select the required kernel module through dependencies depending on which kernel version you are running. Then reboot and try the wireless again :wink: I’m afraid wireless support is one of the few remaining common issues in Linux, mostly due to non-cooperation by hardware vendors …

thanks for the help with that! will try it out tonight and will hopefully my followup will be from within gnome…

actually - my wired net isn’t working with 11 either (even though my onboard ethernet is recognized properly as eth0) so the login to YaST isn’t going to work. Any ideas on that? I’m connected right now on my windows partition via DHCP, so I’m not sure why the linux side (also set up for DHCP) wouldn’t be working. Do i have to uninstall the wireless card within the network manager in suse first?

I have the same card, and here’s what I did.
I downloaded the latest stable release: Files

Copied it to my OpenSuse RC1 Desktop by USB drive.
Untarred the tarball.
cd in the madwifi directory
and as root, ran:
make && make install

Next, I ran:
rmmod ath5k
modprobe ath_pci

ifconfig ath0 up

You should be able to see your card.

For me, I have a wpa secured network, and had to set up a wpa_supplicant.conf file, and then run the wpa_supplicant command to login to my network.

Let me know how that goes.


Amir, thanks for the tips - how did you do the steps for the config file? mine is WEP (Open, I think…), 128. I think it’s “wep open” because I can hook into my home network with any of my mobile devices by just entering the wep key. Do i need to do any sort of config file for WEP? Thanks again!

The easiest thing to do would be to hit the MadWifi how-to for WEP. (It looks pretty straightforward):

UserDocs/FirstTimeHowTo - - Trac

There’s a section for WEP specifically.