Some update issues

I have some issues with updating.

First the kupdateapplet (I am using KDE). It is showing updates, but when I click on the applet it seems to have a permission problem and recommends going into Yast and updating manually. No means to authenticate seems to be given. Do I need to log in as root to be able to use this tool to update? I’m used to the Ubuntu security model of not having a root account password…

Next, YAST. I will update with YAST (through GUI) and it will inform me that the YAST updates should be happening first. But I can’t see any easy option to select these updates. I went through and selected the ones beginning with YAST and tried again, but this led to YAST no longer working. I fixed this by updating with zypper.

Finally, Zypper. I get the same message as with YAST when updating with zypper - I should be installing the YAST updates first. Can I safely ignore this when using zypper? I followed some advice and tried

zypper update in yast*

but stopped it when I saw that it was downloading all the language versions. Seemed like an inelegant solution to me.

Any advice?

I am using OpenSuse Edu-li-f-e 11.3 with KDE.

Simply do

zypper up

to install all updates from the ‘update’-repository (including the ones referring to YaST).

I have no idea about that updater-applet (I never used it), sorry.

I think the updates that are first are the zypp/satsolver updates. Just update those first in YaST (Go into Online Update and don’t tick or untick any boxes) and just press the next button and let it update zypp/satsolver packages then once that it is done it will say restarting package management as you have just updated the package management packages (zypp/satsolver) and automatically select the other updates (then you can tick any more updates you want)