Some text at top not printed, Epson ActionPrinter 4000

Hi. I have been struggling to find printing software for an Epson ActionPrinter 4000 in OpenSuSE 11.1 which can produce sharp letters in the printing and not have other problems. Via OpenPrinting database - Printer Listings on the Internet (an) Omni printer driver(s) is suggested for this printer. I installed the packages Omni-0.9.2-1.i386.rpm and OmniEpsonVendor-cups-0.9.2-1.i386.rpm and their dependencies via commands of the form “zypper in PackageName.rpm” while connected to the Internet using a fast Internet connection in a friend’s mobile home. I worked with “drivers” which could be found via YaST2 (Yet another Software Tool 2), System, Printer, selecting the line for the particular printer I am using, clicking on “Edit,” then under “Driver” entering something like “24 pin” and maybe more text, and then clicking “Show Matching Drivers.” As in YaST2, Hardware, Printer, I use the word “driver” very loosely in this posting; actually I may have been working with PostScript Printer Description (ppd) files in YaST2. With the drivers labeled “Epson 24-Pin Series, 1.3” and “Oki 24-Pin Series, 1.3” the printing was readable; but the printed letters were not sharp, even with a relatively new print ribbon. A driver at least labeled “24-pin 80 Col” was very successful in Fedora-Core-3 (FC3) Linux with this printer.–It might have also had “KS_24_pin_80_Col” in the file Generic-24-pin_80_Col.xml associated with this “driver” in FC3 Linux; but I cannot be certain of that. In OpenSuSE-11.1 Linux I found a similar driver labeled “KS 24-pin 80 Col, CUPS + omni[omni/KS/KS-KS_24_pin_80_Col-omni-cups.ppd.gz].” But with this driver and one of “Epson 24-pin 80 Col, CUPS + omni[omni” or “downloaded/Epson/Epson-Epson_24_pin_80_Col-omni-cups.ppd.gz]”, in probably /var/log/cups/error_log I found a record of some events while a test page was attempted to be printed. There I could see that the executable file CUPSToOmni could not “locate” the required shared-object files with names of the form “”. I followed the two-command solution to enable CUPSToOmni to “locate” such a lib file that was posted at; in my case that problem was gratefully eliminated by in a terminal program as a superuser by typing the commands “/usr/lib/ghostscript/Omni >> /etc/” and then “ldconfig”. I’m not sure if a restart of my computer was necessary after entering those commands or not. But the result with attempting to print using the KS…-labeled driver in OpenSuSE 11.1 was that I could obtain sharp-looking letters and/or digits of gibberish when attempting to print a test page and just form feeds or blank pages when attempting to print a portion of a text file via the text editor Kate. With the choice “Epson 24-pin 80 Col, CUPS +omni[omni/Epson/Epson-Epson_24_pin_80_Col-omni-cups.ppd.gz]” the result was sharp-looking letters in the printing. However the beginning of a document was not printed.–The printing began further down the first page of text in the document, leaving just blank lines on the top sections of sheets of paper. Of course this is unacceptable for practical use. This was the case when printing a .dvi file using 1) the combination of dvips and lpr and 2) a .txt file from within the text editor Kate. So I assume this phenomenon is associated with the Omni driver I chose to use with this Epson printer. How should I enable the printing to instead begin at the beginning of a document and on the top section of a sheet of paper, of course leaving a more normal-sized section of blank space as a top margin? Can this problem be eliminated from outside the driver by, for example, changing some driver option or perhaps inputting a datum used by the driver? Thanks in advance for help.


Way too verbose…(hard to read) > filter > Your printer: 24-pin Epson Action 4000

(I haven’t touched a dot-matrix printer since the early 90’s :))

IMHO, you can really only expect limited results with this type of printer. Some drivers may yield better results, but you would have to analyse the ppd’s (and possibly customise them) to get the level of control you seek. Thats way beyond the scope of what can be offered here. (Your banging your head against a brick wall!)

Anyway, I guess you could try an alternative driver, but it will be a process of trial and error. For example, the Epson LQ-510 may be worth a shot (included CUPS driver).

A quick way to test is to configure your printer via the CUPS interface (via your browser):


You can test print from here as well.

Thanks, deano_ferrari, for kindly offering me some advice here. Gratefully the general approach you suggested of simply trying more printing software [in the form of PostScript Printer Description (.ppd) files] eventually yielded a good result. I think your suggestion also broadened my “horizon” a bit to help me realize that I didn’t have be able to immediately see “24” or “24-pin” in the label for the driver or .ppd file for that file to possibly be suitable for a printer using 24 pins or so. After trying seven more .ppd files, including “Epson LQ-510” and the following, successful, gzip-compressed, .ppd file, good-quality printing without additional problems was obtained for the Epson ActionPrinter 4000 using:

“Epson Generic ESCP 24-J84, CUPS +omni[omni/Epson/Epson-Epson_Generic_ESC_P_24_J84-omni-cups.ppd.gz].”

The broad search for .ppd files was performed within YaST2 (Yet another Software Tool 2), Hardware, Printer, etc., as I discussed in my previous posting in this thread, using just the word “Epson” in the search for matching “drivers.” In choosing the above, compressed, .ppd file I recalled from IBM - Information on Printers from Epson on the Internet that the Epson ActionPrinter 4000 impact printer, listed there in a table of dot-matrix printers, had for its printer data stream “ESC/P.” Without knowing exactly what that means and/or represents, among the “Generic” printers I decided to try “Epson Generic ESCP 24-J84,…ppd.gz” first. And gratefully it worked well in printing a portion of both a .txt file from within the text editor Kate and a page of a .dvi (DeVice-Independent) file via a terminal command as a superuser of the form “dvips -f -p2 -n1 DVIFile.dvi | lpr -PEpsonAP4000 -h,” where EpsonAP4000 is what I chose for the printer name. Both printouts had good quality; the printouts began with the texts that should have been printed; and these times there were no large blocks of unwanted blank space preceding the printed texts.

My experience in the Fedora-Core-3 and OpenSuSE-11.1, Linux operating systems is that when a driver or .ppd file cannot be found to match the model identification for a printer, one could try to choose a printer driver or .ppd file labeled with the word “Generic,” the number of pins perhaps minus one in the printer’s electrical connector (25-1=24 in my case), and the number of columns handled by the printer (80 in my case). Then among that resulting set of drivers or .ppd files one could look in the label for the driver or .ppd file for anything else which closely matches known characteristics of the printer or the software it uses (in my case “escp” in the .ppd file’s label closely matching ESC/P for the printer). Toward the latter goal it may be good to learn some detailed specifications from the Internet, the printer’s manufacturer, or the printer’s manual, if one is available for it, about the particular model of one’s printer. The other approach of choosing model identifications (Epson AP-3250 and Epson AP-5000 in Fedora-Core-3 Linux and Epson AP-3260 in OpenSuSE-11.1 Linux) among the choices of printer software close to the model identification of one’s printer (Epson ActionPrinter 4000 in my case) proved unsuccessful in my case. In general the more characteristics of the printer one can match in the label for a printer driver or .ppd file, the greater the probability ought to be that the chosen printer driver or .ppd file will be successful for practical printing. I hope the general strategy I outlined here will be helpful to someone else.

Thanks again, deano_ferrari, for kindly taking the time to promptly offer me some good, practical advice. I am grateful to have found printing software that can make the Epson ActionPrinter 4000 practically useful for printing documents in the OpenSuSE-11.1, Linux operating system!